No internet connection on clients for WIFI


I previously had DD-WRT running on my Netgear Nighthawk X6 (R8000) router in Canada for the last 3 years. I decided to move to OpenWrt today.

This router is connected to my internet provider's modem. I also have (another) WIFI Access Point that is connected to one of the Nighthawk's LAN ports.

After flashing the firmware, I could connect to the other Access Point through WIFI and access the internet, and so I know OpenWrt is correctly configured to at least give me wired access to the internet. I also logged in with SSH to the Nighthawk and pinged with success.

I then tried to configure WIFI. The Nighthawk has 3 radios, one for the 2.4 GHz band, and two for the 5 Ghz band. After removing the default settings for the 3 radios, I created each of the 3 WIFI accesses according to

At first, none of the wireless networks would work. Whenever I tried to connect my phone to WIFI, I got a "No internet connection" message. After trying some changes (can't remember which) and rebooting a couple of times, I finally got my 2.4 access working. But, the other 5 GHz WIFIs still give me "No internet connection".

Can anyone help ?

The current settings in the wireless overview are :slight_smile:

radio0: Channel 149 (5.745 GHz)
radio2: Channel 48 (5.240 GHz)

Both are set up for Canada.

Have you bridge them to the LAN interface?


Yup, that was it, thx

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.