No internet connection after upgrade from 17.01.x to 18.06.x

Hello, I am grateful and satisfied user of the OpenWRT on D-Link DIR-860L, but I have a problem with the new 18.06.x branch. After upgrade, I have no issues to connect to the router from LAN, but there is no internet connection on clients whatsoever. I tried to keep or reset configuration, but I can not get it working. After downgrade to 17.01.x the connection is back. Any ideas?

Looks like incompatible config from 17.01. Have you tried to reconfigure the router from scratch?

1 Like

Sorry, my first post was not clear enough.

After upgrade from 17.01.x to 18.06.x there is no connection on clients:

  1. with kept configuration,
  2. with default 18.06.x configuration,
  3. with new configuration based on default with my changes regarding password, Wi-Fi, client separation.

My setup is as follows: ISP modem/router >> D-Link DIR 860L running OpenWRT >> 2 ubuntu workstations. Everything set to use DHCP.

After downgrade to 17.01.x the internet connection is immediately back.

Could you post the configuration you have?
/etc/config/network , /etc/config/firewall and the output of these commands ip -4 addr , ip -4 ro , ip -4 ru

For what it's worth, I am on 18.06 HEAD with my DIR-860L and upgrades have been fine (as well from 17.01 to 18.06+).

'No internet connection whatsoever' is a broad statement. Is it DNS? Can you still ping outside? Or is DNS not working either? Have you checked your router's configuration and logread output for pointers?