Cuel
November 26, 2024, 7:45am
1
Hi.
I'm about to replace my Nighthawk 7000 running Openwrt with the GL-iNet Flint 2 MT6000. I've performed the sysupgrade and basically left all settings unchanged, which at minimum should work with LAN out of the box to my understanding.
Connecting the Flint2 to the existing Nighthawk over LAN ports and then PC into Flint2 works just fine. If I however connect the WAN cable currently providing the Nighthawk with internet to the Flint2 WAN, I'm not able to perform ping or anything from the admin interface. It displays as green and there's traffic on the wire in LuCi, acts as the DHCP server for the PC but there's no internet.
If I just swap back to the Nighthawk router, everything comes back online.
My ISP does not lock to any MAC adresses as far as I'm aware. I've also cycled the fibre converter.
Flint2 openwrt config:
{
"kernel": "5.15.167",
"hostname": "OpenWrt",
"system": "ARMv8 Processor rev 4",
"model": "GL.iNet GL-MT6000",
"board_name": "glinet,gl-mt6000",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.5",
"revision": "r24106-10cc5fcd00",
"target": "mediatek/filogic",
"description": "OpenWrt 23.05.5 r24106-10cc5fcd00"
}
}
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd7f:bca6:24f8::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
list ports 'lan5'
config device
option name 'lan1'
option macaddr '94:83:c4:a6:64:a9'
config device
option name 'lan2'
option macaddr '94:83:c4:a6:64:a9'
config device
option name 'lan3'
option macaddr '94:83:c4:a6:64:a9'
config device
option name 'lan4'
option macaddr '94:83:c4:a6:64:a9'
config device
option name 'lan5'
option macaddr '94:83:c4:a6:64:a9'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.2.1' # nighthawk uses 192.168.1.1
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'eth1'
option macaddr '94:83:c4:a6:64:a7'
config interface 'wan'
option device 'eth1'
option proto 'dhcp'
option peerdns '0'
config interface 'wan6'
option device 'eth1'
option proto 'dhcpv6'
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
option filter_aaaa '0'
option filter_a '0'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
frollic
November 26, 2024, 7:55am
2
I'd still clone the WAN MAC from the 7000 over to the MT6000.
one less source of error.
How is the WAN interface on the Nighthawk configured?
Cuel
November 26, 2024, 8:21am
4
Nighthawk config. VLAN was for an IPTV (not used anymore) and also got a pihole dns, which is not connected to the flint2 yet.
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd11:5995:4bf0::/48'
config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option ifname 'eth0.23 eth1.1'
list dns '6,192.168.1.155'
config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'
config interface 'wan6'
option ifname 'eth0.2'
option proto 'dhcpv6'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '2 4 6t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0t 5'
option vid '2'
config switch_vlan
option device 'switch0'
option vlan '3'
option ports '0t 3 5t'
option vid '23'
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option localservice '1'
option confdir '/tmp/dnsmasq.d'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv6 'server'
option ra 'server'
option ra_management '1'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config dhcp 'iot'
option start '100'
option leasetime '12h'
option limit '150'
option interface 'iot'
option force '1'
config dhcp 'iotnonet'
option start '100'
option leasetime '12h'
option limit '150'
option interface 'iotnonet'
config host
option mac 'DC:A6:32:E7:4B:C5'
option leasetime 'infinite'
option dns '1'
option name 'rpi4'
option ip '192.168.1.155'
egc
November 26, 2024, 9:10am
5
I might have missed it but I do not see any DNS configured on your flint so maybe it is a DNS problem?
Cuel
November 26, 2024, 12:16pm
6
Wouldn't it use the ISP dns by default? The nighthawk used the rPI DNS but I figured I'll set that up later.
You have set option peerdns '0'
to prevent DHCP DNS servers being used.
1 Like
Cuel
November 26, 2024, 4:25pm
8
But I'm actually looking to use peer DNS until I have working internet. Hence why settings aren't touched.
egc
November 26, 2024, 4:29pm
9
which translates to:
option peerdns '0'
So enable it on the wan interface i.e. set to 1
Cuel
November 26, 2024, 4:32pm
10
Misread sorry. I'll try that!
Cuel
November 26, 2024, 4:43pm
11
Enabled the setting but seems to be no change.
ping: bad address 'openwrt.org'
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd7f:bca6:24f8::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
list ports 'lan5'
config device
option name 'lan1'
option macaddr '94:83:c4:a6:64:a9'
config device
option name 'lan2'
option macaddr '94:83:c4:a6:64:a9'
config device
option name 'lan3'
option macaddr '94:83:c4:a6:64:a9'
config device
option name 'lan4'
option macaddr '94:83:c4:a6:64:a9'
config device
option name 'lan5'
option macaddr '94:83:c4:a6:64:a9'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.2.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'eth1'
option macaddr '94:83:c4:a6:64:a7'
config interface 'wan'
option device 'eth1'
option proto 'dhcp'
config interface 'wan6'
option device 'eth1'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
Can you please ping 1.1.1.1
before and after cloning the mac address of wan of the previous router into that of new router?
Didn't your ISP give you something like user id and password to provide upto limited bandwidth (say like 100 mbps)?
And what about the firewall zones?
1 Like
Cuel
November 26, 2024, 10:25pm
13
To my surprise, overriding the MAC fixed it.
The apartment comes with an ISP provided router that's configured with a VLAN to make the IPTV work, but I removed it directly when moving in and replaced it with the Nighthawk. If my memory serves me correctly I never changed its MAC adresss.
The ISP does not provide any username/password, it's 1Gbps unlimited
before
PING 1.1.1.1 (1.1.1.1): 56 data bytes
ping: sendto: Network unreachable
PING 1.1.1.1 (1.1.1.1): 56 data bytes
64 bytes from 1.1.1.1: seq=0 ttl=58 time=10.080 ms
64 bytes from 1.1.1.1: seq=1 ttl=58 time=10.486 ms
64 bytes from 1.1.1.1: seq=2 ttl=58 time=9.976 ms
64 bytes from 1.1.1.1: seq=3 ttl=58 time=9.985 ms
64 bytes from 1.1.1.1: seq=4 ttl=58 time=10.447 ms
--- 1.1.1.1 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 9.976/10.194/10.486 ms
1 Like
system
Closed
December 6, 2024, 10:25pm
14
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.