No internet access with Snapshot version of OpenWrt

I have a TP-Link router which has a Snapshot version of OpenWRT installed on it. This version does not have a GUI such as LUCI and I cannot get it working properly.

I manage to setup a SSH session to the device, but the device doesn't have internet access. Otherwise I would use OPKG to install LUCI on it.

What do I need to do to get internet access on the device ?
I want to connect one of the LAN interfaces to my wired network and make sure the device has the right IP configuration to access the internet. I edited the /etc/config/network file, but it doesn't seem to take affect.

Primarily I need to configure the device right in order to install LUCI, where to start ?

Sounds like you need a "dumb AP" config.

Wiki gives more LuCI oriented advice:

But it might be easier to follow this old advice from me:

If you connect an Ethernet cable you should have internet or of the box. It goes without saying that if you connect to the WAN port then you need router's LAN IP to be on a network different than upstream router's, and if you connect to LAN port you need them to be on the same network.

1 Like

I just wrote a reply, but it seems to be gone.

Thank you for the link for the dumb AP configuration, this is very usefull.
I have one problem with it, I cannot save and reload the device.
I use SmarTTY, opened the file remotely and saved it, but the reload command doesn't work.
Powering the device off (after saving the file) doesn't keep the changes.

Welcome to Smart Terminal.
root@ /etc/init.d/network reload
sh: /usr/bin/xauth: not found
ash: bash: not found

To verify if things are saved and applied, I only modified the IP address from .1 to .2, but that doesn't even work, It stays on .1
Can it be related to the snapshot version ?

How to deal with this ?

@Piet200, welcome to the community!

What model TP-Link device are you using?

This symptom has appeared for approximately 2 regular issues:

  • flash is full on a low space device
  • you need to flash the image a second time to resolve

The most common issue is the former, hence my question.

It is an very old device, a WDR1043 v1.
Is there anything I can do to get it working properly ?

It depends on how you are connected to internet. You need to ask your ISP. Maybe you need to setup PPPoE, etc.

Another option is to install a snapshot that has Luci.

For instance:

If your existing wired network uses IP addresses outside the range of 192.168.1.X, you can simply plug the WAN port into the wired network and the router will have access to the Internet. Leave your PC plugged into a LAN port.

If the IP range does conflict, you would need to change either the OpenWrt LAN IP, or the IP of the existing main router.

Or take another approach of making the OpenWrt router a LAN device. To do that, set its LAN IP to something that is in the range of the main router's network, but not used by any device. Also you need to add a gateway and DNS to the LAN configuration:

config network 'lan'
    option type 'bridge'
    option device 'eth0.1'
    option proto 'static'
    option ipaddr ''    #Change this from
    option netmask ''
    option gateway ''   #These lines point to your main router
    option dns ''

After doing this, reboot the router or restart the network and connect the existing network to one of the LAN ports. Then ssh to the router at
Of course the "lan device" approach can be used no matter what the IP of the main router is, you just have to be sure to configure to match it.

That is exactly what I want to achieve.
But how do I get this version (incl. LUCI) on it ?

  • Do as instructed above
  • Then, you should be able to run:
opkg update
opkg install luci

You can also install a release version of the firmware, including LuCI.

It appears you may have not seen:

Also be advised, if I checked the correct model, your device only has 32 MB of RAM, LuCI may run very slowly.

I have this device. Luci works well with standard set of packages.

1 Like

This is exactly my problem.
I have no internet connectivity with my router and I am unable to adjust the configuration so it does connect to the internet.

Once that is possible, the two OPKG command will do the rest. but how to get at that point ?

Why are you unable? Do you know the correct configuration?

As I wrote before you have two options:

  1. Find out the correct settings from your ISP and set them up using CLI.

  2. Flash another image containing Luci using CLI.

1 Like

I advise to calm down and not get frustrated. You will have to perform some command line steps to get Internet and either:

  • install LuCI; and/or
  • sysupgrade to a version with LuCI.

It seems that you haven't read my previous posts.
The configuration doesn't seem to be correct to get internet access and I am having a problem saving the adjusted configuration.

@Piet200, you must remain calm.

  • You will have to attempt @mk24's steps above
  • You will save then apply them by running /etc/init.d/network reload
  • You will not turn off the router in this process

If this works:

cd /tmp
sysupgrade openwrt-18.06.4-ar71xx-generic-tl-wr1043nd-v1-squashfs-sysupgrade.bin