No Internet access via 5Ghz on netgear nighthawk x4s r7800

Hi there,

  • I have two Netgear nighthawk x4s r7800 device
  • The first one I bought last year is running successfully OpenWRT, latest version as dumb access point
  • This year I bought another one (2nd hand) and tried to do same trick. However
  • I install latest release, no extra config, I get 5Ghz up and running, but no acces to Internet via WAN port
  • No issue with 2.4Ghz
  • When I copy config of first rourer and copy it to 2nd every works, except, I can't get Internet access via 5Ghz, I connect home network via LAN port
  • When Install an older firmware I can't login on 5Ghz, 2.4Ghz, no issue
  • When I restore original Netgear firmware, configured as access point, 5 Ghz works like a charm, and can access the Internet
  • The only difference between both devices in MAC range
  • 1st, working, starting with 2C:30:33
  • 2nd 5Ghz issues, starting with 14:59:C0
  • Both have: Qualcomm Atheros QCA9984 802.11acn hardware for 5GHz radio

What could it be?
And can it be fixed?

Best regards,


Why are you using WAN port for a dumb AP

I use the WAN port, with 2nd router, just to have the most basic set-up as possible
So, if issue is not hardware related, it's more easy to find (read less config to examine, to find issue)

You should actually have 2 different configs. The routerwith the ethernet cable to the internet should be configured with the simple router config Where the ethernet cable to the internet is in the WAN port.

Then the second router should be configured a "dumb AP" where the ethernet cable from this router to the other should be in the LAN port of each router.

Thanks for all responses
And the suggestions how to create a better set-up.
But I don't think that will give a solution to the not working Internet via 5GHz, or does it?
As it should work out-of -the box...

Best regards,


Unless you want 2 completely different, isolated and firewalled subnets in your network where devices connected to router A can't talk with devices on router B, then this is how it works "out of the box". If you have 2 routers in your network, one must to be configured as the "master router to the internet" and the other must be configured as a "wifi provider for the local LAN (aka dumb AP)".

Why do you want to give up 20% of your ports on a dumb access point? I mean I prefer to hook-up 4x LAN + Wifi devices. I use it in the livingroom near my TV/radio/receiver/android box. And now a days they all want Internet via RJ45 (I prefer cable above wireless access)

I sold my trouble Netgear R7800 and got me another one (2nd hand online) and this worked out of the box with OpenWRT and 5Ghz. Although it seems to contain same hardware, there is something that prevents it to access Internet via LAN or WAN port

I guess what I was saying is why would double NAT