No internet access on guest wifi (separate VLAN)

Got a separate VLAN setup with a guest wifi, but I am having trouble connecting to this wifi network. Finally managed to connect with my Windows laptop, but noticed that there is no internet connection. Can this be the reason why most devices don't want to connect to this wifi?

/etc/config/network

config interface 'guest'
	option proto 'static'
	option ifname 'eth2.10 eth3.10 eth4.10'
	option type 'bridge'

/etc/config/wireless

config wifi-iface
	option device 'wifi1'
	option ifname 'wl11'
	option network 'guest'
	option mode 'ap'
	option wpsdevicename 'XiaoMiRouter'
	option wscconfigstatus '2'
	option disabled '0'
	option hidden '0'
	option ssid 'KPG'
	option key '***'
	option encryption 'psk2'
	option bsd '0'
	option rrm '0'
	option wnm '0'

brctl show

bridge name     bridge id               STP enabled     interfaces
br-guest                7fff.28d1274d2dac       no              eth2.10
                                                        eth3.10
                                                        eth4.10
                                                        wl11
br-lan          7fff.28d1274d2dac       no              eth2
                                                        eth3
                                                        eth4
                                                        wl0
                                                        wl1

No firewall rules which includes this VLAN.
What am I missing?

This looks quite wrong, but let's get more info:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall