No internet access on another VLAN

I'm trying to configure an xDSL router with LEDE. I want to use one of the switch ports as WAN port and the remaining ports for wired clients. So, first I configure VLANs:

Then I create a new interface on eth0.2 (VLAN2) set as DHCP client.

The problem is:

  • the router has internet connection (from the wired link on VLAN2)
  • no internet access for wired or wireless clients

How can I make internet access work for VLAN1 clients?

I've tried this on two different routers (BCM6358+BCM5325 and BCM6368) - the same result.

root@LEDE:/# cat /etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd23:d6f5:f0a7::/48'

config interface 'lan'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option gateway '192.168.1.1'
    option _orig_ifname 'eth0.1 wlan0'
    option _orig_bridge 'true'
    option dns '8.8.8.8'
    option ifname 'eth0.1'
    option ipaddr '192.168.1.1'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 8t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '0 8t'

config interface 'vlanip'
    option proto 'dhcp'
    option ifname 'eth0.2'
    option macaddr '02:xx:xx:xx:xx:02'

root@LEDE:/#

If you want to provide internet to the computers in the LAN, you must also configure the firewall in your router.