No gateway on ipv6 on clients (A default route is present but there is no public prefix on ziggo_lan thus we don't announce a default route!)

Raspberry Pi 4 Model B Rev 1.2
OpenWrt 21.02.2 r16495-bf0c965af0 / LuCI openwrt-21.02 branch git-22.052.50801-31a27f3

On my vlan (ziggo_lan) I there is no public prefix so I do not have a gateway on my vlan.
I think it has something to do with the prefix I have on my lan and ziggo_lan, but can't figure it out somehow. Must be my small brain capacity :wink:

The log tells me:

Thu Mar 31 12:36:19 2022 daemon.warn odhcpd[979]: A default route is present but there is no public prefix on ziggo_lan thus we don't announce a default route!

my /etc/config/network file

onfig interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdad:b459:8594::/48'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option device 'br-lan'
	option ip6assign '60'

config interface 'wan'
	option proto 'dhcp'
	option peerdns '0'
	list dns '84.200.69.80'
	list dns '84.200.70.40'
	option device 'eth0.10'

config interface 'wan6'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option peerdns '0'
	list dns '2001:1608:10:25::1c04:b12f'
	list dns '2001:1608:10:25::9249:d69b'
	option device 'eth0.10'

config interface 'vpnclient'
	option proto 'none'
	option device 'tun1'

config interface 'vpnserver'
	option proto 'none'
	option device 'tun0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.20'

config interface 'ziggo_lan'
	option proto 'static'
	option device 'eth0.30'
	list ipaddr '192.168.180.1/24'
	option ip6assign '62'

config interface 'RECOVERY'
	option proto 'static'
	option device 'eth0'
	option ipaddr '10.0.10.1'
	option netmask '255.255.255.0'

ifstatus wan6

root@Router:~# ifstatus wan6
{
	"up": true,
	"pending": false,
	"available": true,
	"autostart": true,
	"dynamic": false,
	"uptime": 18378,
	"l3_device": "eth0.10",
	"proto": "dhcpv6",
	"device": "eth0.10",
	"metric": 0,
	"dns_metric": 0,
	"delegation": true,
	"ipv4-address": [
		
	],
	"ipv6-address": [
		{
			"address": "2001:1c04:131e:6300::51c5",
			"mask": 128,
			"preferred": 604665,
			"valid": 604665
		},
		{
			"address": "2001:1c04:131e:6300:dea6:32ff:fe9e:b780",
			"mask": 64,
			"preferred": 604798,
			"valid": 1209598
		}
	],
	"ipv6-prefix": [
		{
			"address": "2001:1c04:131e:6310::",
			"mask": 60,
			"preferred": 86091,
			"valid": 172491,
			"class": "wan6",
			"assigned": {
				"lan": {
					"address": "2001:1c04:131e:6310::",
					"mask": 60
				}
			}
		}
	],
	"ipv6-prefix-assignment": [
		
	],
	"route": [
		{
			"target": "2001:1c04:131e:6300::",
			"mask": 64,
			"nexthop": "::",
			"metric": 256,
			"valid": 1209598,
			"source": "::/0"
		},
		{
			"target": "::",
			"mask": 0,
			"nexthop": "fe80::aef8:ccff:fe8f:9efa",
			"metric": 512,
			"valid": 1798,
			"source": "2001:1c04:131e:6310::/60"
		},
		{
			"target": "::",
			"mask": 0,
			"nexthop": "fe80::aef8:ccff:fe8f:9efa",
			"metric": 512,
			"valid": 1798,
			"source": "2001:1c04:131e:6300:dea6:32ff:fe9e:b780/64"
		},
		{
			"target": "::",
			"mask": 0,
			"nexthop": "fe80::aef8:ccff:fe8f:9efa",
			"metric": 512,
			"valid": 1798,
			"source": "2001:1c04:131e:6300::51c5/128"
		}
	],
	"dns-server": [
		"2001:1608:10:25::1c04:b12f",
		"2001:1608:10:25::9249:d69b"
	],
	"dns-search": [
		
	],
	"neighbors": [
		
	],
	"inactive": {
		"ipv4-address": [
			
		],
		"ipv6-address": [
			
		],
		"route": [
			
		],
		"dns-server": [
			"2001:b88:1002::10",
			"2001:b88:1202::10",
			"2001:730:3e42:1000::53"
		],
		"dns-search": [
			
		],
		"neighbors": [
			
		]
	},
	"data": {
		"passthru": "0017003020010b8810020000000000000000001020010b88120200000000000000000010200107303e4210000000000000000053"
	}
}
root@Router:~# ^C
root@Router:~# 

uci set network.lan.ip6assign='62'
uci set network.ziggo_lan.ip6assign='62'
uci commit network
/etc/init.d/network restart
1 Like

thx @trendy

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.