No connectivity on router but connected devices do have internet access

hey guys i connected a second router in my house to extend range,i connected it to my primary openwrt device through lan port 1 on router 2.
everything works like a charm i set static ip on router 2 and disabled dhcp all devices connected through it have internet access and get the proper ip the only problem i have is that on the router itself i cant use opkg or ping any ip outside of the network.
below is my uci export network

root@trickery:~# uci export network
package network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.178.2'
	option ipaddr '192.168.178.3'
	list dns '8.8.8.8'
	list dns '8.8.4.4'
	option delegate '0'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'static'
	option netmask '255.255.255.0'
	option broadcast '192.168.178.255'
	option ipaddr '192.168.178.3'
	option gateway '192.168.178.2'
	list dns '8.8.8.8'
	list dns '8.8.4.4'
	option delegate '0'

config device 'wan_eth0_2_dev'
	option name 'eth0.2'
	option macaddr '14:cc:20:92:08:16'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 5 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 0t'

Delete the wan network entirely. A dumb AP only needs one network; usually keeping the default lan. A dumb AP does no routing or firewalling, it bridges everything together in one network.

Likewise you can remove VLAN 2 from the switch and move port 1 into VLAN 1 so all five Ethernet ports are lan.

thank you very much

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.