No connection what so ever after upgrade

This is still the same subnet as the wan. Change it.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fddb:ca00:43a::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.88.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option proto 'static'
        option device 'eth1'
        option ipaddr '192.168.86.37'
        option netmask '255.255.255.0'
        option gateway '192.168.88.1'
        list dns '192.168.86.8'

config device
        option name 'eth0'
        option ipv6 '0'

config device
        option name 'eth1'
        option ipv6 '0'

root@OpenWrt:~#

still the same issue.

Your gateway is incorrect. You cannot have a gateway that resides in a different subnet.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fddb:ca00:43a::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.88.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option proto 'static'
        option device 'eth1'
        option ipaddr '192.168.86.37'
        option netmask '255.255.255.0'
        option gateway '192.168.86.1'
        list dns '192.168.86.8'

config device
        option name 'eth0'
        option ipv6 '0'

config device
        option name 'eth1'
        option ipv6 '0'

root@OpenWrt:~#

what i dont understand how it got messed up when it was working fine yesterday.

i fixed the mistake of the gateway i downloaded another image and see

1 Like

Your config was invalid. I don’t know why it worked, ever.

Is it working now??

nope not working at all.

i will try the previous version and see how it goes tomorrow

Is the lan dhcp server working now? If you connect a computer to the built-in ethernet port, does it get an address? It shoud.

That won't solve your problem. And you won't (easily) be able to go back to an earlier snapshot unless you have it saved.

You probably don't need to be using snapshot anyway... you should be using 24.10.0 stable release.

https://firmware-selector.openwrt.org/?version=24.10.0&target=bcm27xx%2Fbcm2712&id=rpi-5

And I'll say it again...

Wild guess:

The OP [perhaps] has the upstream plugged into LAN (eth0) and not WAN (eth1). That would explain why it "worked".

If so, merely swapping the cables might solve the problem (depending on how the OP's wire plant is).

@avillamarin

  1. To be clear, where is your upstream router plugged in?
  2. Confirm its IP is 192.168.??.?

no i have my eth0(factory ethernet port) from my pi to the switch and the usb ethernet adapter(eth1) to the modem. now i have the eth0 from my router to my switch and not using eth1 since i have nothing going outside when i connect eth1 to my switch i loss all connectivity besides internal so that one is unplugged for now.

just downloaded the 24.10.0 once i am back home will try and see. noticed that the apk-mbedtls failed on the 24.10.0 so had to get libustream-mbedtls which allowed me to download it. wonder if thats the issue, will find out soon

Your response didn't clearly answer a question needed to assist you:

Thanks for clarifying that you use eth1 for your Internet modem.

  1. To be clear, we're troubleshooting your Internet connection, correct?
  1. Do you have LAN "connectivity" (i.e. can you access the OpenWrt at 192.168.88.1 via eth0)
yes were troubleshooting internet connection after downloading a fresh image it started working fine. i noticed that when i tried the 24.10 version it didnt let me apk-mbedtls so i put libustream-mbedtls and said didnt had the apk package but it doesnt let me put add. 

i did the snapshot and added apk and libustream-mbedtls and now everything is working as it should

@avillamarin - please do not enclose your comments in the code formatting blocks (</>). I have now asked you 3 times.

The code blocks are designed to make it easier to read the output of config files and logs. But they make it harder to read normal comments/discussions. The formatting option is there to improve readability for code, and is not supposed to be used for general discussion.

i totally understand was an oversight, lack to attention to details, i blame the STIGs