No Connection to Internet via Notebook and Amazon FireTV

Hello there,

I am quite new to OpenWRT and flashed it to a AVM Fritzbox 7362SL and it works qutie good. To be conneted to the Internet, I use a Zyxel VMG1312-B30A Modem in Bridge Mode.

As the WAN port of the 7362SL does not support VLAN, pppoe goes through LAN port 1 as I need vlan tag 7 for my ISP. I have access to the internet through the router and the pings to openwrt.org are working fine. Still, my clients (Notebook with Ubunutu and a Amazon Fire TV) are not able to reach the internet.

For my Notebook: Connected via LAN2. It worked on one evening, but on the next day, no connection - nothing was changed with configuration during this time.
During the small time when I got a connection, some website were not able to load, e.g. Duckduckgo. Are there any settings I need to change?

I was not able to get my FireTv to work, which is connected via LAN3. I know it needs IPv6, but the device does not get an IPv6 adress. DHCP with IPv6 is enabled.

Here is my full configuration as as an newbie I have only some replies:

Network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdac:bf77:dc88::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option xfer_mode 'ptm'
	option ds_snr_offset '0'
	option line_mode 'vdsl'
	option annex 'a'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option broadcast '192.168.1.255'
	option ip6assign '64'

config device 'lan_eth0_1_dev'
	option name 'eth0.1'
	option macaddr '34:31:C4:0E:6C:FB'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr '34:31:C4:0E:6C:FE'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '2 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '7'
	option ports '4 6t'

config interface 'DSLBridge'
	option proto 'pppoe'
	option ipv6 'auto'
	option ifname 'eth0.7'
	option username 'xxx#xxx#xxx@t-online.de'
	option password 'xxx'
	option type 'bridge'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option ports '6t'
	option vid '30'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option ports '0 6t'
	option vid '40'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option ports '6t'
	option vid '50'

config interface 'LAN2'
	option ifname 'eth0.40'
	option proto 'static'
	option ip6assign '64'
	option type 'bridge'
	option force_link '0'
	list ipaddr '192.168.10.1/24'
	option broadcast '192.168.10.255'

config switch_vlan
	option device 'switch0'
	option vlan '6'
	option ports '6t'
	option vid '60'

DHCP:

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option ra 'relay'
	option dhcpv6 'relay'
	option ndp 'relay'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'LAN2'
	option interface 'LAN2'
	option ra 'server'
	option dhcpv6 'server'
	option ra_management '1'
	option start '100'
	option leasetime '12h'
	option limit '150'
	option dynamicdhcp '0'

Firewall:

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'DSLBridge lan'

config include
	option path '/etc/firewall.user'

config zone
	option name 'LAN2'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option network 'DSLBridge LAN2'
	option forward 'ACCEPT'

config zone
	option network 'DSLBridge'
	option input 'ACCEPT'
	option forward 'REJECT'
	option name 'DSLBridge'
	option output 'ACCEPT'

config forwarding
	option dest 'DSLBridge'
	option src 'lan'

config forwarding
	option dest 'DSLBridge'
	option src 'LAN2'

Thank you for any advice and help.

Lasko