No connection, no static change, no openvpn

OpenWrt 19.07.0 r10860-a3ffeb413b / LuCi openwrt-19.07 branch git-20.006.26738-35aa527

I'm trying to setup linksys wrt1900ac (very first gen era) as a repeater and I'm having trouble with just about everything.

Network: when I scan and connect to home wifi (wrt3200) its connected but has no internet connection. (Home is default may be interference) but when connected to iPad tether, works fine.

Change static on 1900: fails to make changes (change static to to change conflict from home router by assumption of above issue) reverting back in 30 seconds. But it just freezes, hold down reset button in back, delete ssh key from laptop and start over. : oops, the page you are looking for doesn't exist. From following link in openvpn setup

Following instructions on openVPN instruction: opkg update - worked fine (after temporarily dealing with connection issues)
opkg install openvpn-openess1 luci-app-openvpn - cannot install package openvpn-openss1

Questions: why do I have internet connection issue from home router, but not iPad? Why am I directed to a link that doesn't exist? Why can't I install openVPN on router (does it not exist anymore?)

I have ipvanish account that I let run out and can continue. Should I change router install from openwrt to dd-wrt where ipvanish works? (Spoiler, ipvanish is $80 a year and openVPN is $90 for 3 years)

Please advise.

depending on what is upstream, you may need to change to an entirely different subnet (i.e. change it from to something else like (as an example).

What is your WRT1900AC WAN port connected to?

1 Like

I have it double connected. Ethernet to my laptop for setup purposes (mostly so I can do directly connected settings and to ssh into it) and I have it connected to wifi (to check and confirm wifi connections status)

While connected both ways: With it connected to home wifi, opkg update fails to connect. When connected to iPad tether, opkg updated. I can confirm connections. Home connection the laptop (via ethernet), my android phone, and my iPad all show connected (limited) internet. But I have to fight my android phone with connection. And ssh gives me failed on updatto check internet connection. When I change client to my iPad, laptop, phone and Git (using windows) works with internet (ssh in Git download updates) I have unplugged ethernet cable link to 1900 and get access denied port 22 for ssh root@ (I believe the 3200 is conflicting) and when I'm not connected thru ethernet, and connected as wifi (no internet connection) to 1900, in browser tries to connect to while I have no internet connection instead of luci. Wired connection is only link at this point.

I'm sorry, but I find the description a bit confusing. Could you draw a diagram for your network?

If you're doing a routed client (Internet access through home network, but not fully merged into the home LAN), change the 1900's LAN IP to something like It can't be in the same range that the WAN uses. All of 192.168.1.X is claimed by the 3200.

This should also fix another common problem where if you previously used a web login to a different device at, the browser's cache can prevent LuCI from operating properly. The solution is to clear the browser cache.

1 Like


that is not a helpful diagram. What is "home internet" -- draw a complete picture. It is hard to figure out what might be wrong without more details.

Also worth mentioning that both @mk24 and I have told you that it is highly likely you'll need to change your OpenWrt router's IP address to something else, like (we've both told you this) -- have you tried to make this change?

@mk24 this was my fear. But changing from to resulted in a crash (it froze) would I get same result changing to I don't know if it is related to wired connection lost after static change that I have listed above.

Hard to say with how few details you are providing. But changing the address the way you did previously will not solve the problem. So try and tell us what happens (be specific)

Before I do this. I used the instructions of

give me a minute to come up with a drawing. My interpretation my differ from yours, i'll do my best. please hold.

Im sorry, but this is the best I could come up with that shows my home wifi gives no internet connection, and my I pad gives internet connection.

I tried chaning to and it didnt take. even after selecting save and apply

Thank you. That is a more helpful diagram.

What are you hoping to achieve? Why are you trying to use two routers? What purpose does each one serve for your network? It is typically not good practice to use two cascaded routers, but sometimes there is a good reason for it... so let us know what you are trying to achieve and we can go from there.

Meanwhile, I'd recommend eliminating the iPad from the equation. This will only confuse things for the moment.

And in terms of the actual connections -- this is really important. Each of your Linksys devices has 1 WAN port and 4 LAN ports, as well as Wifi. How are you connecting the WRT1900ac to the WRT3200? Can you put that information on the diagram? And how does the internet arrive at the WRT3200? Do you have a cable modem or DSL modem? Or fiber optic?

ok, even though openvpn failed to install (via Git ssh) it is now available in GUI web interface. But this doesnt fix issue with network connectiviy using home wifi router (linksys wrt3200) as i'm still connected try ipad

There is an 'auto rollback' process that is intended to prevent mistakes. You probably need to have your network settings open and click the renew DHCP lease button right after you click save & apply.

please hold while i come up with this

As stated, hide my ass.

There are the ports on back of router. One us basicaly a pass thru, the other 4 are for wired connections to router. I have tried the output (pick a port) to input on 1900 and it doesnt pass thru. LAN connection I assume (no luck)

I would recommend against the wifi repeater type configuration for the WRT1900 -- can you connect that via a wire instead (LAN from the WRT3200 to WAN of the WRT1900)? You will want to change your WRT1900 LAN address to You should have working network/internet connectivity once you do that.

i can connect, but that leaves 2 questions: 1- what radio do i set it to and what settings do I need to change for it?

2- how do I change to i fallowed instructions to change static in these instructions and it failed to change?