No configuration from ISP on Asus RT-AC85P

Hello.
After installing latest released OpenWrt to AC85P I found it is not able to get network configuration from ISP - WAN interface has not IP etc. Allthough all interfaces including WAN is UP as showed by IP addr command. I tried also applying static to WAN but this not helped: config was applied but no connection to Internet. Any ideas?
P.S. Yes, it worked fine with OEM firmware.

ip addr
BusyBox v1.33.1 (2021-08-31 22:20:08 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 21.02.0, r16279-5cc0535800
 -----------------------------------------------------
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
--------------------------------------------------
root@OpenWrt:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1504 qdisc fq_codel state UP qlen 1000
    link/ether d4:5d:64:86:68:6c brd ff:ff:ff:ff:ff:ff
    inet6 fe80::d65d:64ff:fe86:686c/64 scope link 
       valid_lft forever preferred_lft forever
3: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether d4:5d:64:86:68:68 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::d65d:64ff:fe86:6868/64 scope link 
       valid_lft forever preferred_lft forever
4: lan1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether d4:5d:64:86:68:6c brd ff:ff:ff:ff:ff:ff
5: lan2@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether d4:5d:64:86:68:6c brd ff:ff:ff:ff:ff:ff
6: lan3@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether d4:5d:64:86:68:6c brd ff:ff:ff:ff:ff:ff
7: lan4@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
    link/ether d4:5d:64:86:68:6c brd ff:ff:ff:ff:ff:ff
8: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether d4:5d:64:86:68:68 brd ff:ff:ff:ff:ff:ff
9: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether d4:5d:64:86:68:6c brd ff:ff:ff:ff:ff:ff
10: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether d4:5d:64:86:68:6c brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fddf:633b:f1ee::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::d65d:64ff:fe86:686c/64 scope link 
       valid_lft forever preferred_lft forever

Who is your ISP ?

If you use a cable modem, have you tried turning it off for a few minutes?

To confirm the WAN port is working, plug the Openwrt router into the LAN port of any router, and check the WAN interface acquires an IP address from the router.

Someone else may be able to help once we know the ISP and details of the external modem.

My ISP is Triolan. But now I am not able to enter router's web-interface at all. Router not gives my machine any config. Seems it is bricked. And this happened after I reset MAC-addresses on the appropriate tab of Interfaces configuration. 8( I tried reset button but not helped.

If holding down Reset button for 10 seconds after switching ON power does not work, have you tried using Asus Restoration utility?

https://www.asus.com/Networking-IoT-Servers/WiFi-Routers/ASUS-WiFi-Routers/RT-AC85P/HelpDesk_Download/

https://youtu.be/T8YKnpXxhx0

If holding down Reset for 10 sec after switching ON power makes power led flashing slowly but I am not able to open 192.168.1.1 in browser, no ping to it also.
Unfortunately Asus Restoration Utility is only for Windows while I am using Linux. Will think what to do and where to get windows.
P.S. I can't find firmware restoration tool on RT-AC85P homepage. o_O

Choose 'Windows 10' in previous Asus web page link and click 'Show All' to reveal restoration tool

Version 2.1.0.2
2018/07/23 4.08 MBytes
ASUS Firmware Restoration version 2.1.0.2
OS support: Windows XP/7/8/8.1/10
Firmware Restoration is used on an ASUS Wireless Router that failed during its firmware upgrading process. It uploads the firmware that you specify.

1 Like

Yes, I found it at last. Thanks. Now I should find windows machine which is not so simple.

Perhaps visit SmallNetBuilder forum and seek advice for non-Windows option?

https://www.snbforums.com/forums/asus-ac-routers-adapters.47/

Recently debricked with Asus firmware tool successfully (found an old HDD with windows on it). But I don't understand what to do now and why there was an issue getting network configuration from my ISP. With OEM firmware it works fine.

What protocol does your ISP require for authentication?
DHCP, PPPoE?

Did you confirm the WAN port is working in OpenWrt by wiring it to LAN port of any other router, with WAN set for DHCP client mode?

I don't know your ISP, so cannot provide any further suggestions.

My ISP provides network configuration by DHCP. No authentication but MAC binding on ISP's web-page. It means I should open it's web-portal and manually enter MAC of my router's WAN-interface (or my machine's Ethernet-port).

I did not make it in time to check if WAN port receiving something from LAN-port of my old TP-Link. But I can try flashing an OpenWrt again. Just not sure how to do that best: by SSH (as first time) or by SFTP.

fwiw, I used ssh method several times for my RT-AC57u for OpenWrt 19.07 without problems in the past.

Recently checked. It receives the IP address from another router. I made a call to my ISP and they told me that my router doesn't send its MAC to them.
So...
My old TL-WR1043ND with OpenWrt 19.07 works good with ISP.
My desktop and other laptops works good with my ISP.
RT-AC85P with stock firmware works good with my ISP.
RT-AC85P with OpenWrt is not able to get network config from ISP.
...maybe the issue in OpenWrt ?

Should I raise bug report on a tracker?

A workaround I found:

ethtool -s wan speed 100 duplex full autoneg on

Bug report: https://bugs.openwrt.org/index.php?do=details&task_id=4090

Unfortunately not fixed in released 21.02.1. :frowning_face: