"No client associated" - Wireless Signal

root@OpenWrt:~# uci del network.wan.type
uci: Entry not found
root@OpenWrt:~# uci commit network
root@OpenWrt:~# /etc/init.d/network restart
'radio1' is disabled
'radio2' is disabled

I wonder if the problem is that this isn't expected in the first place.

I think you'll want to use a text editor to fix this... vi is included by default, although it's not the easiest editor to use. A reference.

vi /etc/config/network
  • use your cursor keys until you find the bridge line in the wan interface.
  • type dd (that will delete the line)
  • hit escape
  • type :x and hit return

Then restart the network as described earlier.

I'm only seeing "bridge" be mentioned under config device

                                      
config device                         
        option name 'br-lan'          
        option type 'bridge'          
        list ports 'lan1'                 
        list ports 'lan2'                 
        list ports 'lan3'                 
        list ports 'lan4'

config interface 'wan' has the following options:

config interface 'wan'                                                   
        option device 'wan'                                              
        option proto 'dhcp'                                              
        option peerdns '0'                                               
        option metric '20'                                               
        list dns '10.2.0.1' 

Do I enter "dd" for config device's option type?

If you keep scrolling down, there should be the line with the bridge defined.

Yes.

So I entered "dd" in the following way but now when I try to connect via terminal it says network is unreachable, Luci won't load, and Ethernet no longer has internet connectivity. Maybe I needed to enter it just before 'bridge'. should I reset my router? If so, could you just remotely take a look at it via Teamviewer? It would probably be the fastest and easiest.

config device                         
        option name 'br-lan'          
     ddoption type 'bridge'          
        list ports 'lan1'                 
        list ports 'lan2'                 
        list ports 'lan3'                 
        list ports 'lan4'

You will need to go back to vi /etc/config/network.

  • press the esc key
  • scroll down to the line showing ddoption type ‘bridge’ and place the cursor directly on the first d. Press the del key twice to make the line show option type ‘bridge’
config device                         
        option name 'br-lan'          
     ddoption type 'bridge'          
        list ports 'lan1'                 
        list ports 'lan2'                 
        list ports 'lan3'                 
        list ports 'lan4'

Now continue down to find this stanza:

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option peerdns '0'
	list dns '10.2.0.1'
	option type 'bridge'   <—- this line must be removed
	option metric '20'
  • place your cursor on this line and press dd and you should see the option type ‘bridge’ entry removed.
  • press :wq to update the changes.

You need the bridge defined in your lan and not in your wan.

Restart your network /etc/init.d/network restart.

There was no such option under config interface 'wan', only under config device. Ever since I deleted that line on config device I get [device@fedora ~]$ ssh root@192.168.1.1 ssh: connect to host 192.168.1.1 port 22: Network is unreachable and no connectivity of any sort. I'll factory reset the device and check again without making any other changes.

After resetting, I'm getting this error message when I try to SSH. I don't know how to add the correct host key in /var/home/device/.ssh/known_hosts.

[device@fedora ~]$ ssh root@XXX
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!     @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the ED25519 key sent by the remote host is
SHA256:XXX.
Please contact your system administrator.
Add correct host key in /var/home/device/.ssh/known_hosts to get rid of this message.
Offending ED25519 key in /var/home/device/.ssh/known_hosts:1
Host key for XXX has changed and you have requested strict checking.
Host key verification failed.

You don't need to redact RFC1918 addresses (chances are, that is 192.168.1.1).

The warning you are getting is because the ssh key has changed...
on many platforms, you can fix this by issuing the following command:

ssh-keygen -R 192.168.1.1

2 Likes

Actually you inadvertently inserted dd into the line. So your network config was invalid.

``’
config device
option name 'br-lan'
ddoption type 'bridge'
^^

1 Like

Also @psherman, after entering vi /etc/config/network,this is the output. There is no "bridge" under config interface 'wan'. Should I follow the steps from those two videos mentioned in my original post first? "bridge" wasn't under 'wan' prior to my reset either.

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd2e:a2b0:d9d6::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr '62:38:e0:b7:2d:20'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

~
~
~
~
~
~
~
- /etc/config/network 26/37 70%

You are back to OOB behaviour, so you should have connectivity over the wire. You won’t have wireless capability until you configure it.

3 Likes

Instead of following some video that may or may not be accurate (I haven't watched it, I don't know how good it is), I'd recommend that you describe your goals here. We can point you to the relevant OpenWrt wiki/tutorial articles (and/or provide specific guidance as needed).

Very well, I'm trying to use my OpenWRT router as my main one since I don't trust my ISP's device. On mine I'd like to setup Proton VPN (and its DNS), an isolated guest network, and if possible, have multiple different VPN server configurations added and readily available to easily switch when needed. Essentially I'm trying to improve my network's security and privacy as much as possible.

So, I would say that the simple option is to start with the OOB configuration.

  • Connect a cable between your ISP device's LAN port and your OpenWrt WAN.
  • If the ISP router uses 192.168.1.0/24 for its network, you must change one of them... easy to change the OpenWrt lan to something else (for example, 192.168.5.1)
  • Enable wifi (set the country code, SSID, encryption type, and password, then enable the radio).
  • Test -- things should just work now.
  • Install Wireguard or whatever VPN protocol you need, and configure appropraitely. You won't need to make any changes to the wifi configuration, and only a few small changes to the firewall and network files. No new bridges should be required.
  • Raise questions when you get stuck or have an issue, complete with the configuration files as we've requested previously.
2 Likes

Do you intend to completely remove the ISP device altogether?

1 Like

Unfortunately no, I do not have a modem. Would there be any benefit to using my own instead of their device?

I merely asked because:

  • The instructions provided to you would have varied
  • Your statement implied that you wanted it gone altogether
  • :spiral_notepad: I wasn't aware it was some kind of modem too
  • Yes, you would use the OpenWrt as a router (i.e. not connect to a LAN on the ISP's router with a 192.168.x.x network)
  • The OpenWrt could have become your border router/gateway

When you use your router to send everything through a VPN, the OpenWrt router's WAN port really only has to be connected to the Internet somehow. The ISP provided modem / router will send and receive only encrypted packets, so you don't have to trust it very much. NAT between the router and the Internet is not an issue since packets arrive through the VPN tunnel directly to the OpenWrt router and need to be NATd at most once on the way to the LAN.

Alright so the ISP router seems to be using a different IP address to the one you mentioned. I followed your steps plus set the channel to "auto" and added two NextDNS addresses but my devices can't detect the signal and when I hover over the radio on Luci it says "no client associated". I haven't done anything relating to WireGuard yet.

BusyBox v1.35.0 (2022-10-14 22:44:41 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 22.03.2, r19803-9a599fee93
 -----------------------------------------------------
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr 'XXX'
	option netmask 'XXX'

config globals 'globals'
	option ula_prefix 'fd2e:a2b0:d9d6::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr 'XXX'
	option netmask 'XXX'
	option ip6assign '60'
	list dns '45.90.28.77'
	list dns '45.90.30.77'

config device
	option name 'wan'
	option macaddr 'XXX'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option band '5g'
	option cell_density '0'
	option country 'CO'
	option htmode 'VHT20'
	option channel 'auto'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option macaddr 'XXX'
	option encryption 'sae-mixed'
	option key 'XXX'
	option ssid 'Chromecast'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '1'
	option country 'US'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option macaddr '60:38:e0:b7:2d:21'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
	option channel '34'
	option band '5g'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

root@OpenWrt:~# cat /etc/config/firewall
config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
root@OpenWrt:~#