"No client associated" - Wireless Signal

I'm trying to setup my router to provide WiFi from my ISP's router/modem. After I get this working, I'd like to set up an isolated guest network for added security. So far I've only followed this initual setup guide and then this WireGuard guide (starts at 5:25) for Proton VPN. At first, the wireless connection worked for just a few minutes but then on the mobile devices it started saying "no internet access" and LuCI says "No client associated" for the signal in the Wireless Overview tab (Ethernet connection works flawlessly though and with the VPN included).

I've already set my country code accordingly, tried stopping the VPN interface, factory resetting the router and setting it up accordingly with the two aforementioned video tutorials, and rebooting it countless times but nothing seems to have worked thus far. I saw this similar post but I'm not trying to do all the stuff this poster mentioned and I couldn't find the "Create bridged" button to test it out. I tried to post my system logs here but they seem to be over twice the post character limit. Any help is much appreciated!

I'm using -

  • Device: Linksys WRT3200ACW
  • Firmware Version: OpenWrt 22.03.2 r19803-9a599fee93
  • Kernel Version: 5.10.146
  • Encryption: WPA2-PSK

Let's see your config files

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Where do I enter those commands? When I enter them in my computer's terminal, I get the following output:

[device@fedora ~]$ cat /etc/config/network
cat: /etc/config/network: No such file or directory

you need to ssh into your router first.
the username is root, password is whatever you set (or if you haven't set it, it'll just go right in

ssh root@<router.lan.ip.address>

Alright, here's the output. I believe I've redacted the sensitive details with "XXX". By the way, my VPN doesn't support IPV6 and therefore doesn't provide an IP address for it. I'm not sure if this could cause any issues.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr 'XXX'
	option netmask 'XXX'

config globals 'globals'
	option ula_prefix 'fd88:3598:0d70::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr 'XXX'
	option netmask 'XXX'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr 'XXX'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option peerdns '0'
	list dns '10.2.0.1'
	option type 'bridge'
	option metric '20'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config interface 'vpnserver'
	option proto 'wireguard'
	option private_key 'XXX'
	list addresses '10.2.0.2/32'
	option peerdns '0'
	list dns '10.2.0.1'
	option metric '10'

config wireguard_vpnserver
	option description 'Ecuador6'
	option public_key 'XXX'
	list allowed_ips '0.0.0.0/0'
	option route_allowed_ips '1'
	option endpoint_host 'XXX'
	option endpoint_port '51820'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option band '5g'
	option htmode 'VHT20'
	option country 'CO'
	option cell_density '0'
	option channel 'auto'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option macaddr 'XXX'
	option ssid 'Chromecast'
	option key 'XXX'
	option encryption 'psk2'
	option ieee80211w '2'
	option wpa_disable_eapol_key_retries '1'
	option isolate '1'
	option network 'lan'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '1'
	option country 'US'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option macaddr 'XXX'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
	option channel '34'
	option band '5g'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

root@OpenWrt:~# cat /etc/config/firewall

config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'wan6'
	list network 'wan'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config zone
	option name 'vpn'
	option output 'ACCEPT'
	option forward 'REJECT'
	option input 'REJECT'
	option masq '1'
	list network 'Ecuador6'

config forwarding
	option src 'lan'
	option dest 'vpn'

Remove the bridge from the WAN... I'm pretty sure this is your main issue.

also note about the wan interface -- setting a DNS that (appears) to be available when the vpn is active means that it won't work properly any other time. You should change this to a public DNS server.

Remove the DNS related entries from here -- they don't do anything in WG config stanzas:

This doesn't do anything right now because Ecuador6 is not a network name... that's just a description in your wg config. The correct network name is vpnserver

Since IPv6 is not supported upstream (through the VPN), set the lan dhcp so it will not advertise itself as an IPv6 capable router. Change ra and dhcpv6 to 'disabled'.

1 Like

Another quick thing... it is not necessary to redact this information. It doesn't reveal anything sensitive or private since it is (or should be) an RFC1918 address.

@mk24 I believe this is already disabled, right?

Go to Network-->Interfaces and edit the LAN. Click the DHCP Server tab then click the IPv6 Settings tab on the next line below it.

On the LAN.

1 Like

How do I Remove the bridge from the WAN?

Also, Ecuador6 is what I named the VPN interface. I just entered vpnserver in my post because I thought that detail might've been sensitive. :sweat_smile:

I'm actually not sure how it got there in the first place... I'd remove it with either a text editor or the UCI commands.

names like that are typically not sensitive.

Do you know of a command to remove it? I'm not sure how I'd do so with a text editor.

I think it would be:
uci del network.wan.bridge
uci commit network

That option should not exist in the LuCI of 22.03, so I also wonder how it got there.

I got this:

root@OpenWrt:~# client_loop: send disconnect: Broken pipe

Can you reconnect?

[device@fedora ~]$ ssh root@192.168.1.1
root@192.168.1.1's password: 


BusyBox v1.35.0 (2022-10-14 22:44:41 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 22.03.2, r19803-9a599fee93
 -----------------------------------------------------
root@OpenWrt:~#  uci del network.wan.bridge
uci: Entry not found
root@OpenWrt:~# uci commit network

What do you see when you do

uci show network
root@OpenWrt:~# uci show network
network.loopback=interface
network.loopback.device='lo'
network.loopback.proto='static'
network.loopback.ipaddr='XXX'
network.loopback.netmask='XXX'
network.globals=globals
network.globals.ula_prefix='fd88:3598:0d70::/48'
network.@device[0]=device
network.@device[0].name='br-lan'
network.@device[0].type='bridge'
network.@device[0].ports='lan1' 'lan2' 'lan3' 'lan4'
network.lan=interface
network.lan.device='br-lan'
network.lan.proto='static'
network.lan.ipaddr='XXX'
network.lan.netmask='XXX'
network.lan.ip6assign='60'
network.@device[1]=device
network.@device[1].name='wan'
network.@device[1].macaddr='XXX'
network.wan=interface
network.wan.device='wan'
network.wan.proto='dhcp'
network.wan.peerdns='0'
network.wan.type='bridge'
network.wan.metric='20'
network.wan.dns='10.2.0.1'
network.wan6=interface
network.wan6.device='wan'
network.wan6.proto='dhcpv6'
network.Ecuador6=interface
network.Ecuador6.proto='wireguard'
network.Ecuador6.private_key='XXX'
network.Ecuador6.addresses='10.2.0.2/32'
network.Ecuador6.peerdns='0'
network.Ecuador6.dns='10.2.0.1'
network.Ecuador6.metric='10'
network.@wireguard_Ecuador6[0]=wireguard_Ecuador6
network.@wireguard_Ecuador6[0].description='Ecuador6'
network.@wireguard_Ecuador6[0].public_key='XXX'
network.@wireguard_Ecuador6[0].allowed_ips='0.0.0.0/0'
network.@wireguard_Ecuador6[0].route_allowed_ips='1'
network.@wireguard_Ecuador6[0].endpoint_host='XXX'
network.@wireguard_Ecuador6[0].endpoint_port='51820'
root@OpenWrt:~# 
uci del network.wan.type
uci commit network
/etc/init.d/network restart
1 Like