No bridge mode available for ISP-provided modem

Hi all, I am planning to get a Belkin RT3200 as recommended by fellow forum members, and install OpenWRT on it. I want to configure VLAN and everything for my home network on the RT3200 without touching the ISP modem. As far as I understand, the way to go is to place the router right behind my ISP-provided modem, and switch the modem to bridge mode.

However, the modem I have is Zyxel VMG8825-T50 which apparently doesn't support bridge mode (and the ISP confirms so on their website). It does have DMZ, however:

The LAN client in the Demilitarized Zone (DMZ) is no longer behind this device and therefore can run any Internet applications such as, video conferencing and Internet gaming without restrictions, but with the same reason, it also uncovers itself to Internet security threats.

Is DMZ a suitable alternative in this case? If not then what are my options?

Our wiki actually has a page for that situation. Basically you would be using the DMZ as an "IP passthrough." How well this works largely depends on how the DMZ is implemented on the ISP router/modem, it may or may not end up as a double NAT with significant limitations.

That article was written pre-21.02 and as such not with DSA in mind. It's straightforward enough though.

1 Like

I have fiber-optic internet, and the ISP-provided Zyxel basically plugs the internet Ethernet cable into its WAN port. Can I just basically plugs this same cable into my own router instead? Or bridge / DMZ is a must?

The broadband menu is not avaialble for my case.

It probably will work provided you know what settings are required to authenticate, if your ISP permits it.

Would be helpful if you can tell us who is your ISP and what service you subscribe to?

If there is a community forum for your ISP, have you asked on the forum whether it is possible to replace the Zyxel with your own router?

It appears to be VDSL, given the ISP device.


Or fiber, via external ONT connected to wan port. Just guessing.
Saw some huawei, technicolor with this config too