No automatic MTU, PPPoe, LEDE Reboot 17.01.4, Buffalo WZR-HP-AG300H

Hello Folks.

I spent the whole weekend setting up my router for my ADSL2+ connection to 1und1 (vodafone net). After configuration i had a weird problem. Sites like youtube, google worked, german sites like or werent accessible. Thought its a ipv4 v6 problem, but it wasnt. Im completely on ipv4. After hours and days i started messing with every setting... just for fun i changed the mtu of the pppoe connection to 1400.. and suddenly it worked. Found out that my optimal mtu is 1472. But why doenst LEDE set it automatically? I red smth about ip tables, layer 2 and layer 3, firewall... seems like a bug in all versions? Mss clamping is activated (ive resetted LEDE to defaults and just set up the pppoe, wlan and mtu value). I had the same problem on openwrt 15.05, thought a flash to LEDE will solve the problem. But it doesnt. Can anyone help?

Sure, set your WAN MTU to 1472.

Because, if it did, then that would break OpenWrt for everyone else who expects to use the device with standard Ethernet (MTU of 1500).

It seems like you tested using ping with a payload of 1472 bytes and the DF bit which instance, you should get the number: 1472. Plus the payload of IP 20+ICMP 8 = 1500!

If you're serious, there is an Ethernet overhead, this is why you have to lower it. OpenWrt can't magically guess that your particular Ethernet connection is less than the standard MTU of 1500. All standard Ethernet equipment sets the MTU to 1500 by default.

i am sympathetic to op here
expecting a full ethernet mtu from a tunnel interface produces the breakage

What tunnel?

The OP's LAN should be plain Ethernet. The OP's client has to send a packet with a 1472 MTU too, or the router will fragment on the LAN side too.

All networks behind the router needing to use the WAN must have the same MTU. Please explain how OpenWrt could (or should) guess or know that the OP wishes that MTU for all his VLANs?

If so, please offer some idea for the community to script into the DSL WAN proto.

I also noted the 28 byte overheard, because I suspect there's another issue, as that's not the DSL overhead.


excactly, i suspect op's wan mtu with german dsl is actually 1492 as is reported by pppd in debug mode.

debug pppd[3959]: rcvd [LCP ConfAck id=0x1 <mru 1492>]

i just rememered how i had to learn this the same way op did, a century ago. little has changed so maybe a safe default mtu would be sensible for pppoe interfaces, as a too low mtu only wastes a tiny tad of protocol efficiency.

1 Like

Erm, I use pppoe on a german vdsl line and the system defaults to (path) MTU 1492 without me needing to do anything, so I would say the defaults should work and the question is why don't they for the OP...

1 Like

Im no pro with networks but shouldnt mss clamping adjust the mtu automatically? With ICMP messages that tell that the packages are to big? Whats the deal with PMTUD?

its ticked for me at the firewall settings but it doesnt work. I checked my mtu with and it says its 1472. Any settings above doesnt work. I modded my fritzbox 7412 (dsl modem router combination) to work as a dsl modem only to let LEDE do the work.

Background is that my girl and me got a 10000 adsl2+ connection and i couldnt play rocket league without lags while she was looking hd movies on amazon prime. The qos of the fritzbox is a joke and i had spikes every 20 seconds. Now it works perfectly with LEDE (and before openwrt) with sqm qos. Just this one problem/question made me think there could be a problem with this awesome piece of software.

Why can this cheapass fritzbox adjust the mtu automatically and LEDE cant? you're saying your issue is with PMTUD???

Your first post didn't mention PMTUD.

Did you open the firewall for those ICMP packets???

ack, sry for the noise

i think he asked why this did not prevent the problem.
valid imho.
pmtud mostly doesnt work because of

and thus we have mss-clamping, no?

for one, fritzbox is exclusive to germany and can be more effectively optimized for specific conditions whereas openwrt has to basically work with every isp on the planet.

gratulations on your sqm success! :slight_smile:

1 Like

Okay, typically you do not need to set the MTU at all, so could I convince you to 1) save your settings ans 2) run "firstboot" to wipe all your changes and have the router come up in pristine condition and then only configure the pppoe user name and password, but leave the MTU alone. And then get back to use about any observed oddities please.

Best Regards

P.S.: Could you also post the output of "cat /etc/config/sqm", "tc -s qdisc", and "tc -d qdisc"?

I can confirm that auto MTU works just fine with my version of Lede/OpenWRT.
In my case: Lede SNAPSHOT r7093 with pppoe.
I haven't touched any MTU settings and it got correctly set to 1492... Not sure why it doesn't work for the op.
Are you sure that your ISP needs 1472 and not 1492 ?

Btw, this online test site ( tells me that my maxiumu MTU size is 1500 and I had to put a firewall rule to allow ICMP@IPv4 for the test (but i think the Lede/OpenWRT default fw settings should allow ICMP request to the WAN).
Weird test site... :confused: