No address range available for DHCP request error

I have set up a guest network on my WRT3200ACM running OpenWRT with guest interface 'WRT_Guest' which bridges a VLAN and my WRT3200ACM's wireless network. This setup was working perfectly but for some reason I cannot work out (probably something stupidly obvious), devices joining this network cannot obtain ip addresses - the following error is shown in the system log: "dnsmasq-dhcp[10564]: no address range available for DHCP request via br-WRT_Guest."
I've included some of the relevant config info below:

Network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ip6assign '60'
	option igmp_snooping '1'
	list ipaddr '192.168.10.1/24'
	list dns '1.1.1.1'
	list dns '1.0.0.1'

config interface 'WRT_Guest'
	option proto 'static'
	list dns '1.1.1.1'
	list dns '1.0.0.1'
	option type 'bridge'
	list ipaddr '10.10.3.1/24'
	option ifname 'eth0.3' ```

DHCP

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'
	option start '11'
	option limit '200'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'WRT_Guest'
	option leasetime '12h'
	option limit '150'
	option interface 'WRT_Guest'
	option start '100'
	option netmask '255.255.255.0'

Any help would very much be appreciated.

I have found the issue and it is not openwrt related - seems to be the fault of my Linksys Velop guest access which despite being in "bridge mode" is still trying to act as a dhcp server, at least for the guest network. For now I have enabled "Force DHCP on this network even if another server is detected" on my Openwrt network and will report the issue to Linksys.

3 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.