No access to router on LEDE wifi

hi all,

i apologize right away for my massive stupidity:
i accidentally flashed the openwrt-15.05.1-ar71xx-generic-tl-wr841n-v10-squashfs-factory.bin firmware on my router, i actually wanted to flash the hedy-1.0.0-tl-wr841-v10-sysupgrade.bin firmware (https://en.wikipedia.org/wiki/Freifunk).
now i can see the LEDE wifi and i can also connect to it, but i do not have access to the router via 192.168.1.1. (as described here: https://openwrt.org/docs/guide-quick-start/basic_wifi) in order to reflash the freifunk firmware.
is there any other way to access my router on the LEDE wifi?
thanks in advance!

screenshot of the LEDE connection:
https://transfer.sh/NEqAp/LEDE.png

  • WiFi is disabled by default and has to be manually enabled on a new flash, unless you ticked the box to save your current config... if you did not tick that box, you're likely connected to someone else's network.

  • You will need to SSH in to:
    1. Determine what your current issue is
      &
    2. Reflash the router

  • On a side note, OpenWrt supports Freifunk and has several Freifunk packages.

thanks for your quick reply.

i'm sure the LEDE wifi that is visible is my router's: the ssid disappears if i switch off the router.
also, i'm rather convinced nobody else in my neighborhood is running a LEDE of Freifunk wifi.

anyway, i followed your link and tried to "ssh in" to my router via wifi, here's what i got:

ssh: connect to host 192.168.1.1 port 22: Network is unreachable

or

ssh: connect to host 192.168.1.1 port 22: Connection timed out

then i established a lan connection between my laptop and my router and got this:

ssh: connect to host 192.168.1.1 port 22: No route to host

still no access :confused:

Have you already tried failsafe mode?
https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset

thanks for your reply.
i followed your link, a few lines down it says:

Caveat: Failsafe mode is only available if you have installed firmware from a SquashFS image, that includes the required read-only root partition. To verify whether your device has the SquashFS root partition, check for “squashfs” either in the LEDE image name or perform the following check on your device:
grep squash /proc/mounts

i tried and entered that line but didn't get any response from the terminal.
does that mean there's no failsafe mode available with the image i accidentally flashed (openwrt-15.05.1-ar71xx-generic-tl-wr841n-v10-squashfs-factory.bin)?

Are you sure?

right, sorry, my bad.

still, i didn't get any response on

grep squash /proc/mounts

from the terminal :confused:

Whoa...stop...you got to the terminal???

If you're at the terminal, that's all you need...

again, sorry.
i'm talking about the windows terminal emulator "cmder" (https://openwrt.org/docs/guide-quick-start/sshadministration#windows_terminal_emulators).
this is where i typed in:

grep squash /proc/mounts

and didn't get a response.
(both, while connected to my router via lan and via wifi)
cmder

(which is probably not where i'm supposed to type it in?)

Why are you typing that command into Windows!?!?

That isn't "connected to your router." You're simply on it's network. YOU HAVE TO CONNECT TO THE ROUTER'S COMMAND PROMPT, NOT WINDOWS.

Have you ever used a program like PuTTY to connect to a device via Serial, Telnet or SSH?

In this instance, you'll need SSH.

https://www.chiark.greenend.org.uk/~sgtatham/putty/

...to, as @JW0914 said:

If you are connected to the router then you should have a gateway IP, you will connect to that IP via SSH. That IP should be 192.168.1.1; but if you changed it at some point, it may be something else.

You will first have to:

ssh root@192.168.1.1

in your cmder window.