No 2.4GHz but the wireless adapter should have both

I set OpenWRT VM on a PC along pfsense to add wireless capability to my router. The wireless adapter https://www.amazon.com/gp/product/B07R62F8R2/ should have both 2.4GHz and 5GHz but I can only see the 5GHz. I wonder if there is something I can do to enable the 2.4GHz.

#cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdc0:d20f:12ca::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option ipaddr '192.168.30.2'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.30.1'
	list dns '192.168.30.1'

config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'

config interface 'vlan60'
	option proto 'static'
	option ifname 'eth0.60'
	option type 'bridge'
	option netmask '255.255.255.0'
	option ipaddr '192.168.60.2'
	option gateway '192.168.60.1'
# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:06.0'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:05.0'
	option htmode 'VHT80'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'Test'
	option encryption 'psk2'
	option key 'password'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option mode 'ap'
	option key 'password'
	option encryption 'psk2'
	option ssid 'School'
	option network 'vlan60'

Thanks in advance.

Are you sure the card can do both bands at the same time?

1 Like

Thank you @eduperez for your reply. I am not sure about this. I sent this question to the manufacturer. While waiting for their answer:

  • Are there wireless cards that provide 2.4GHz and 5GHz at the same time? example?
  • Can I switch between 2.4GHz and 5GHz? I would like to test the range and performance of the 2.4GHz.

I am still waiting to hear from the manufacturer but reading the product description:
Qualcomm Atheros QCA6174A/QCNFA364A Wireless Network Adapter is designed for laptop or desktop computers for internet surfing and Bluetooth device roaming. It will provide 2X2wave (Stream) wireless AC network connection, allow computers get 300Mbps on 2.4GHz and 5GHz 867Mbps for video source streaming, gaming or office use. The Bluetooth 4.1 is mainly used for wireless device such as wireless headset, mouse, keyboards etc. Build in advanced low power consumption technology to extend battery working time.

The product title say Dual Band Wireless AC

Do these suggest support for simultaneous 2.4GHz and 5GHz?

I have no more info about this device, and cannot recommend any other that can do both bands simultaneously.

I know of some devices can do both bands, but not at the same time, and you just need to change the "hwmode" and "channel" options to choose one band or the other.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.