Nexxt nyx1200-ac

Trying to figure out what makes this thing tick and get something else running on it. so far i've gathered the following.
it has
1x 100mbps wan
2x 100mbps LAN (although the chipset can support 4x lan)
64mb ram (winbond w9751g6kb-25 looks like it is)
I have telnet access via stock firmware, MemTotal: 61356 kB.

CPU mediatek MT7628AN
wireless chip MT7612E (5ghz?)
cat /proc/cpuinfo
system type : MT7628
processor : 0
cpu model : MIPS 24Kc V5.5

can't figure out the flash size but I think it's 8MB. the firmware is 4.2 MB

Is there any question or do you want to tell us only your research and assumptions?

Both, is there any known way of getting openwrt running on this device? or porting it over?

This effort has to be done by anyone that owns such device.

Probably you are the one which could do this...

Here are one starting point:

Here are a lot of examples of device tree files for mediatek mips based devices:

This devices is a spinoff from JCG (aka Kuwfi too) JIR-AC681M, and there is a thread of someone that successfully port OpenWrt to this device fully functional 5G on the thread [SOLVED] MT76: MT7612E Firmware loading hangs (adding support for CUDY WR1000)
and I can confirm it, have also this device on Nexxt and it does work!

Ok, sorry if my last post was not very helpful. With this I think I can help you with a definitive solution (somewhat risky but it worked for me). I imagine that your device, like mine, at the bottom has a label that says that the model is ARNEL904U1 being a Nexxt Nyx1200-AC router and has a sticker inside that says JIR-AC681M-( and another 3 numbers that I suppose they vary), so in effect as said before, we are facing a JCG JIR-AC681M device.
Search the router compatibility database for the Cudy WR1000 v1 brand and model (an another brand that receives this device, so its a twin brother one), download the Sysupgrade firmware (the Factory will tell you when trying to flash it, that the device is incorrect), it is important that this process you do it connected by LAN and not by wifi (otherwise you may brick the device), when finished the router will reboot and the WPS light will be flashing (this will be the status light from now on), once it is finished it may end up with the first 3 lights all time on, if this is the case, press reset for 5 seconds until it restarts and from there, the WPS light will flash again and then turn off, an then you only have the first light all time on, there you are ready, you can enter with OpenWrt.

Some further notes:
I used the "openwrt-19.07.10-ramips-mt76x8-cudy_wr1000-squashfs-sysupgrade.bin" file, I can report that the router is stable and both bands 2.4 Ghz and 5 Ghz works rock solid, no problems has been found yet!
LuCi will report that the router is a Cudy WR1000 but that doesn't matter to me, Im just happy that OpenWrt is running!
Memory for further software packages to install is around 3 MB.
Has an a BIG improve on bandwidth support compared to the Nexxt factory firmware!
I would suggest that, if by some miracle at the first time to boot OpenWrt you end up with just the first light steady on, I would avoid the reset procedure.
OpenWrt first time starts with no wifi settings so don't spect a wifi signal neither a wifi light, so you have to set it up through LAN!


Do you know how I can return to the factory firmware if I remain bricked?

First of all, how did you ended up with the device bricked?
I have already flashed two Nyx1200-AC routers with the same firmware that Ive posted earlier and all have been a successful port to OpenWrt, so I almost can confirm that this firmware fits to this router.
Unfortunately the device doesn't comes with an emergency boot firmware, depending on which state the device may be (you could see it using the debug interface), it could be recovered through TFTP procedure or in most common cases, using a flash chip programmer with a known good read chip backup.
What I would suggest you, is to first calm down, OpenWrt comes by default without any WiFi config, so don't expect that the router will emit any signal, USE THE LAN PORTS INSTEAD, if no IP is assigned set manually your pc to (or something in that range) and try accessing through web interface to or through SSH, if that doesn't work then do a 30-30-30 reset and try again what I've said before.