NextDNS CLI install failure

I just tried to install NextDNS on A4001N (18.06.8) through ssh, sh -c "$(curl -sL" and it gave few errors first then I upgraded tar, gzip and zlib based on the errors but now it gives this:

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now

How can I fix this? They have GUI service as well on 19.07 but 19.07 FW didnt work for my router as the luci pages got stuck on "loading view" all the time when I set up it (another problem).

Any reason you’re not using opkg to install it?

EDIT: I just tested, and the standard opkg process works perfectly and installed the main ipk as well as the dependencies (ca-bundle).
opkg update; opkg install nextdns

Sadly GUI service is only for 19.07 FW and I have loading view problem on it. If anyone knows how to fix this issue I would gladly re-flash to latest version.

Basically luci gets stuck on "loading view" prompt on some pages and never load the page. Pages like overall, wireless, software tab etc. but other pages like backup page just load fine.

If I cant solve this then Im stuck with 18.06 CLI.

Nevermind, gave up on the CLI errors and tried re-flashing latest FW again but this time w/o removing settings... and now its working and NextDNS also installed perfectly in GUI.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.