Newly installed LuCI app doesn't show up in menu with OpenWrt 19.07.3

when I try to install luci.app.simple-adblock or adblock

it will install, but it won't come up in the black bar on top menu, it won't even spawn the services tab.

it happened the same with luci.app.sqm, but a reboot made that one appear.

I'm on a D team newifi D2.

AFAIK, 19.07.3 has not been officially released. It is likely still in the build process. It is entirely plausible that your problem is simply that the build bots have not finished yet and there are, as a result, missing packages. This should hopefully resolve itself soon assuming that there are no build errors, but until the official release notification happens, it is reasonable to expect that things are still in progress.

6 Likes

usually it would error out if this happens that the files aren't available, but I agree, I should give it a break to be actually released lol... got the regular adblock to install and work though, a second install with "overwrite files" worked... after a reboot

Is there a sane way to check to see if all packages are built for a given uarch? For example, ipq806x?

Honestly, I don't know... maybe someone can chime in about that.

However, it would probably just make sense to wait for the official announcement -- at that point, the complete build process would be complete, presumably without any significant errors or breakages.

I agree. I looked at the output of opkg update and substituted 19.07.3 for 19.07.2 in the urls and manually check them to see that the needed packages I would reinstall are up. For my R7800, they were so I updated and all is well under 19.07.3. There is probably a more elegant method.

BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 19.07.3, r11063-85e04e9f46
 -----------------------------------------------------

I use an archer c7 v5, sysupgraded with -k option six hours ago, reinstalled all packages

by using

opkg update
grep "\toverlay" /etc/backup/installed_packages.txt | cut -f1 | xargs -r opkg install

and everything is fine including adblobk, stubby, external hard drive, transmission etc

Actually its almost the same with 19.7.2 + all updates

3 Likes

https://downloads.openwrt.org/snapshots/faillogs/

(This technically shows if they failed...there is a also a build log somewhere...)

1 Like

Or actually for 19.07:
https://downloads.openwrt.org/releases/faillogs-19.07/

And the package downloads:
https://downloads.openwrt.org/releases/packages-19.07/

Buildbot compiles all pckages fir each target at one batch, and then uploads all packages for that target.
packages:
http://buildbot.openwrt.org/openwrt-19.07/packages/grid
images & kernel packages:
http://buildbot.openwrt.org/openwrt-19.07/images/grid

2 Likes

apparently 19.07.3 is fine, but adblock and/or simple-adblock give issues to spawn the services tab, tried on a second device and it has the same issue...
(One a ramips Newifi D2, one on my fleet of WNDR37/800s devices)

I can configure it to run with SCP/SSH... but to apply the settings will need a restart, again nothing show stopping, just a minor inconvenience.

Edit: on the WNDR device it needs a reboot for SQM to appear in the network tab

I do not have open tabs "openvpn" and "vpn-policy-routing"

It seems to be caused by https://github.com/openwrt/luci/issues/3866, the fix has been backported to 19.07 today.

Once the updated packages are built, it should work fine again (you will need to opkg update && opkg upgrade luci-app-XXX if you installed the buggy packages).

2 Likes

I assembled the assembly 3 hours ago

For reference: Newfi D2 wifi crashes on 19.07.2

For the original issue: new packages may require to logout and login again (or even reboot) to show up properly in the menus.
It's a known issue:
https://openwrt.org/releases/19.07/notes-19.07.3#known_issues

If you have other issues, please open new topics or check bug reports.

3 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.