Newifi3 D2 WiFi FIX tutorial

OK. Thanks Jona. I will stay with 20 dBm. Not expecting many problems as mine is a simple use case of max two dry walls from this router location.

Cheers & have a great day.

test with iperf3. how about yours? i didn't know if the result are good enough?
config

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option country 'ID'
        option cell_density '0'
        option txpower '20'
        option htmode 'VHT80'
        option channel 'auto'

the result

Accepted connection from 192.168.99.241, port 45506
[  5] local 192.168.99.1 port 5201 connected to 192.168.99.241 port 45508
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-1.00   sec  10.0 MBytes  84.0 Mbits/sec
[  5]   1.00-2.00   sec  13.5 MBytes   113 Mbits/sec
[  5]   2.00-3.00   sec  14.2 MBytes   119 Mbits/sec
[  5]   3.00-4.01   sec  14.8 MBytes   123 Mbits/sec
[  5]   4.01-5.01   sec  14.1 MBytes   118 Mbits/sec
[  5]   5.01-6.00   sec  12.2 MBytes   103 Mbits/sec
[  5]   6.00-7.00   sec  12.7 MBytes   106 Mbits/sec
[  5]   7.00-8.01   sec  14.8 MBytes   124 Mbits/sec
[  5]   8.01-9.00   sec  12.4 MBytes   105 Mbits/sec
[  5]   9.00-10.00  sec  16.0 MBytes   135 Mbits/sec
[  5]  10.00-11.00  sec  14.6 MBytes   122 Mbits/sec
[  5]  11.00-12.00  sec  15.6 MBytes   130 Mbits/sec
[  5]  12.00-13.01  sec  14.0 MBytes   117 Mbits/sec
[  5]  13.01-14.00  sec  15.3 MBytes   129 Mbits/sec
[  5]  14.00-15.01  sec  16.1 MBytes   134 Mbits/sec
[  5]  15.01-16.00  sec  14.2 MBytes   120 Mbits/sec
[  5]  16.00-17.01  sec  17.6 MBytes   147 Mbits/sec
[  5]  17.01-18.00  sec  13.8 MBytes   116 Mbits/sec
[  5]  18.00-19.00  sec  15.7 MBytes   132 Mbits/sec
[  5]  19.00-20.01  sec  16.0 MBytes   134 Mbits/sec
[  5]  20.01-21.00  sec  15.8 MBytes   133 Mbits/sec
[  5]  21.00-22.00  sec  15.4 MBytes   129 Mbits/sec
[  5]  22.00-23.00  sec  13.6 MBytes   114 Mbits/sec
[  5]  23.00-24.01  sec  14.6 MBytes   122 Mbits/sec
[  5]  24.01-25.01  sec  13.5 MBytes   113 Mbits/sec
[  5]  25.01-26.00  sec  14.4 MBytes   121 Mbits/sec
[  5]  26.00-27.00  sec  15.6 MBytes   131 Mbits/sec
[  5]  27.00-28.01  sec  17.4 MBytes   146 Mbits/sec
[  5]  28.01-29.00  sec  13.2 MBytes   112 Mbits/sec
[  5]  29.00-30.01  sec  13.6 MBytes   113 Mbits/sec
[  5]  30.01-31.01  sec  17.0 MBytes   143 Mbits/sec
[  5]  31.01-32.01  sec  18.7 MBytes   157 Mbits/sec
[  5]  32.01-33.01  sec  12.7 MBytes   107 Mbits/sec
[  5]  33.01-34.00  sec  10.9 MBytes  92.3 Mbits/sec
[  5]  34.00-35.01  sec  15.5 MBytes   130 Mbits/sec
[  5]  35.01-36.00  sec  13.8 MBytes   116 Mbits/sec
[  5]  36.00-37.00  sec  18.2 MBytes   152 Mbits/sec
[  5]  37.00-38.00  sec  14.7 MBytes   124 Mbits/sec
[  5]  38.00-39.00  sec  15.7 MBytes   132 Mbits/sec
[  5]  39.00-40.01  sec  16.2 MBytes   135 Mbits/sec
[  5]  40.01-41.01  sec  16.4 MBytes   138 Mbits/sec
[  5]  41.01-42.01  sec  16.6 MBytes   139 Mbits/sec
[  5]  42.01-43.00  sec  18.1 MBytes   153 Mbits/sec
[  5]  43.00-44.00  sec  17.2 MBytes   144 Mbits/sec
[  5]  43.00-44.00  sec  17.2 MBytes   144 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-44.00  sec   664 MBytes   127 Mbits/sec                  receiver
iperf3: the client has terminated
-----------------------------------------------------------

How many people and how many devices did you test? I want to apply it on my Newifi D2 tomorrow, but I do not want to end up with a brick. The cost of this device has increased significantly (~145 RMB) compared to the last time I bought (~100 RMB). Importing from China is also super slow and could take up to a month compared to 10 days before the pandemic.

If you don't have a problem with the WIFI you don't need the eeprom fix. I imported mine from China (Taobao + Superbuy) which took about 9-10 days after it was shipped (depending on what shippment you pay for) and I only got 5-10 Mpbs on 2.4GHZ out of 100Mbps which clearly indicated something was wrong with the WIFI driver. If you order a new device from original manufacture, i doubt you need to change anything because chances are it's already been setup to work properly.

You won't brick it either way. This is why I made the tutorial, step by step. There have been multiple posts before of people doing this fix and it's been working. But nobody has made the instructions clear enough for less technical people to understand and perform by themselves. Wait and see until you get your router.

All my devices are used, old, retired from mining farm. I have around 5 of this device currently running. My main router does not have Wi-Fi issue. However, one of the rest has strange problem: the 5Ghz radio has very short range and is almost undetected for everyone except for my Realme phone.

I do not really understand the reason behind this strange behavior because they should have the same hardware and software. Is this has anything to do with hardware revision of the board?

If it has short range it probably suffers from the problem of having low TX power levels. As mine was limited to 16 dBm and same for several others.

In those cases, you need to perform the EEPROM fix to unlock 20 dBm.
If you have flashed it to Openwrt, you can easily look this up by going into the configuration. If you are on stock firmware, I'd recommend getting breed bootloader -> Openwrt so you can see for yourself.

It is also a well known issue with version 1.1 and below for behaving strange when it comes to the wifi. This was fixed in version 1.2 down at the hardware level/PCB. Because you have a couple older devices which are probably on the old versions it can be a combination of things. But it doesn't hurt to try

1 Like

Another strange behavior I saw. After I got this to work, I had one of the router set to channel 140 in garage (Netgear R6220) and this one is close to backyard and I set this to channel 40 and dBm to 19. However the Luci kept showing it to be at 21 dBm being used and my tinkering with power level or rebooting made no difference. It also wasn't connecting to any client in the proximity. I even replaced the basic wpad with full wpad and subsequently with full wpad-wolfssl. Nothing made the tx power come below 21 and nothing made it connect to device. Then I changed it to channel 60 and the max transmit power dropped to 19 and it started to connect to clients.

I am enamored by its 512MB of RAM and, this has 802.11AC and I have many many smart devices (close to 60) for the 2.4 Mhz band. It is rather strange that a device so promising is this melodramatic!!

1 Like

From what I've read. Even if you are on version 1.1 the EEPROM fix will make it more stable then before. But it will not fix your router completely. You will always experience problems to some degree since the main problem lies in hardware.

It is known that Newifi D2 has 5Ghz radio issue due to MT7621 driver bug in the Linux kernel. The issue does not present on stock firmware. From the steps you provide, you simply replace the factory partition (mtd2) with a 64KiB image.

dev:    size   erasesize  name
mtd0: 00030000 00010000 "u-boot"
mtd1: 00010000 00010000 "u-boot-env"
mtd2: 00010000 00010000 "factory"
mtd3: 01fb0000 00010000 "firmware"
mtd4: 0028d7dc 00010000 "kernel"
mtd5: 01d22824 00010000 "rootfs"
mtd6: 01970000 00010000 "rootfs_data"

What does the partition contain and why flashing it fixes the issue? Can you be a little more specific on the purpose of that 64KiB image?

Opening up the bin with hex editor doesn't tell you much of anything. I tried, so I don't know why flashing fixes the issue, only that it adresses the issue with power leves and stability on the dual bands which seems inherit on some devices. All i can tell you is that if you have version 1.2 (like me, SN: HND..1813), the router became flawless since I've had it running for a week and haven't had a single issue at all. I also live in Europe so default country code settings seemed to have work from the start aswell.

Version 1.1 will always have a bit more issues on the 2.4G, which is why they made the revision. There is also a manual way of upgrading your router to V1.2 if you know how to solder as shown here.

https://www.taobao.com/list/item/654932489433.htm?spm=a21wu.10013406.taglist-content.23.3e8a698dx7mE5y

You can also try out different firmwares. See if it makes a difference if some have software tweaks better than others. PADAVAN seems interesting in that regard because It seems to have had positive impact on some devices. From what I've read on YouTube in comments below, the stability also seems to rely on the region and power levels. https://www.youtube.com/watch?v=IMR6HySKfis&ab_channel=JAPRAM

The fix worked for me at least and I currently run PCWRT which is based on OpenWrt 19.07-SNAPSHOT, r11144-2ca5a386ee. TX power: 100% Channel 11@20MHz | 36@40MHz

Hi Jona and others

From what I understand from all these discussions, wireless is a problem. My question to you: Is the rest of the hardware OK? I mean if we use it like a wired router only and leave the two radios in the disabled state. The reason I ask is that the hardware is pretty powerful.

Appreciate your thoughts.

Does it mean that this bug has at least some impact on all the devices that have MT7621 in them? For example, the Router Netgear R6220 is also built with MediaTek MT7612EN. Trouble on that box too?

Anil

From what people have been reporting on this forum, all devices with MT7621 are affected. You can find countless threads about that.

1 Like

OK. Thanks.

Is your hardware a Newifi3 D2? Looks like your missing radio1 (5Ghz) / 802.11ac

Running OpenWRT 21.02.1 on Newifi3 D2 v1.?


The Taobao link, looks to be a hardware mod that adds additional capacitors.

Hi Jim

I have disabled the 5 Ghz channel and use another access point (Netgear R6100 converted to a dumb AP) and use this more like a wired router. Newifi D2 has 500mb of RAM and gig ports and that made me feel its good as a gateway.

I am not looking to get my hands dirty with soldering iron and capacitors. I guess I am little lazy!

Cheers.

1 Like