Newifi D2 Terrible WiFi Performance on OpenWrt

Thanks for testing.

Unfortunately, I set the LAN incorrectly, so I had to restart the whole router to the factory settings (i holded down the reset button for 5s).

After this factory setting, I was no longer able to replicate my previous results.

I try different combinations of settings and firmware all day, but I still have unstable slow WiFi. :persevere:

I don't know what I'm doing wrong, but I'm already crazy about it.
Can you please write a step-by-step procedure on how you have made all the changes to make WiFi work stably and quickly?

1 Like

First try the 21.02-SNAPSHOT :slight_smile:
i made some setting change from default config (like enabling "Disable Inactivity Polling" to avoid problem with all the stupid IOT device in home :wink: , enabling 802.11r, disabling 802.11w )... no "special" setting to make it work....

Thank you for the advice.
I have no idea how I did it, but I managed to set everything back to OpenWrt 19.07.7. :grinning: I prefer this version because it has simple VLAN settings.

I'll see how long it will works. In a few days I will write the result of stability.

I made the 19.07 firmware boot directly from the breed bootloader, 5ghz to 35mb / s download and 20mb / s upload, I believe that the limitation is already in the laptop driver, if possible prefer the standard wifi settings "channel 36, 80mhz, I had to change the channel due to a connection problem with one of my devices.

I'm trying everything on my Newifi3 D2 to make the 5G wifi work reliably, but it's impossible. After some time my iPhone for example appears connected to the wifi but internet is not working. Do you know what I can do? Thanks.

I've tried many version of Openwrt like yesterday snapshot and today I'm using the 21.02.0-rc1.

1 Like

please share the eeprom from the minihere site, the site is no longer working, I can not download it.

I need this too. Can someone please post here.

I used the eeProm from this build for awhile. I still had problems with the switch crashing though. Not sure if it is the same one from the minihere site.

It's online

I recommend this one:
I've been using it for a few months, so far very stable and the signal strength is better.
I've got Newifi 3 rev 1.2

1 Like

I've done a EEPROM upgrade using BREED BOOTLOADER and thanks to @maksz the 5G of my Newifi D2 is working nice for the first time ever. So I can use OpenWRT normally.

Thanks @maksz

I'll try it today, hope it works for me too :slight_smile:

I will try today either. Finger cross.

If this works, comment here because the more positive comments, the better for those who have the same model, is this link working?@maksz


requiert to modify for have good 4 * MAC values

I changed to this eeeprom two days ago. Till now it's more stable but i need to do more tests in signal stregth. I will post feedbacks here later.

What do you mean by this? I didn’t do anything with the MAC.

for the 4 MAC addresses if you use such as the file you will have all these same values and it will not match the device label

I did the eeprom update on both of these links. Initially things worked as normal. Rebooted the router the next day, the WAN interface is not conecting. Put a static IP on it still no luck with pings, no packets being received on physical level. I can get IP on same cable with a Windows machine. So these eeprom updates messed it up it seems. Used the factory original eeprom listed in the github, still the same. Any ideas?

Forgot to mention.. newifi D2

Well, now it started working again. And I rebooted a few times before I post this. Not sure why it didn't work the first few times.. Anyways, on the wifi front it seems the eeprom upgrade is making a difference.. more stable. But I am noticing something interesting. I can push to ISP limit when using Windows 10 machine but not from Android phone when using wifi. Not sure what to make of it.

Ok, sorry for flooding the thread. It seems my WAN port issue was related to flaky cable. Changed it and it's acting as expected. Meanwhile I put the eeprom from site onto Lenovo D1 and it made a difference. With the original eeprom the wifi speeds were jumping up and down, very unstable. With the new eeprom IT IS STABLE! The D1 is on par with D2 maybe even better.. these are initial observationis.. time will tell.. But I am happy I got these two routers to a point where wifi seems stable and usable. Was very close to chucking them in the bin before I tried the eeprom update.

1 Like