Newifi D2 5 Ghz WiFi issue

I recently bought a newifi D2 but despite the update to the latest version of OpenWrt available on 19.07.6 I still have problems with instability and continuous restart of the 5 Ghz card, I also tried with Padavan and it works well, the LOG shows continuously these messages:

Thu Feb 27 21:31:20 2020 kernel: [ 97.235622] mt76x2e 0000:01:00.0: Firmware Version: 0.0.00
Thu Feb 27 21:31:20 2020 kernel: [ 97.241761] mt76x2e 0000:01:00.0: Build: 1
Thu Feb 27 21:31:20 2020 kernel: [ 97.245936] mt76x2e 0000:01:00.0: Build Time: 201507311614____
Thu Feb 27 21:31:21 2020 kernel: [ 97.272300] mt76x2e 0000:01:00.0: Firmware running!
Thu Feb 27 21:31:21 2020 kernel: [ 97.282360] ieee80211 phy1: Hardware restart was requested

Any solutions about? I already try with change of power supply and flashed with various versions of openwrt.

Many thanks.


This is a known problem unfortunately, see this issue on the MT76 tracker:

Could you test a snapshot image and see if the issue is present there? I do suppose so, but it never hurts to try... Keep in mind you cannot keep your network configuration between 19.07 and master. So flash without keeping settings, both ways!

Hello, nothing to do! I've the same problem also with snapshot.
Many thanks

if I understand correctly there is still no solution to the problem? Or is there a workaround?

For mt76 snapshot has better drivers.

Maybe @nbd can shed some light?

1 Like

Since it is little that I use Openwrt I ask you for a little patience ... it is necessary to download from which link? Then I compile the image by copying the downloaded files?

I'm trying everything on my Newifi3 D2 to make the 5G wifi work reliably, but it's impossible. After some time my iPhone for example appears connected to the wifi but internet is not working. Do you know what I can do? Thanks.

I've tried many version of Openwrt like yesterday snapshot and today I'm using the 21.02.0-rc1.

Hello, I have tried various versions of Openwrt and the problem always arises! With the latest snapshoot it doesn't seem to happen. However, I realized that the problem does not always arise and not even on all models.

I'm trying with latest SNAPSHOT but I can't make the 5G to work reliable. Do you have any suggestion?

Hi all,
i've the same problem and i opened the ticket bugs on openwrt project :

But But no one answered me.