Newby help active web interface

hello

i got tplink wr1043nd with openwrt onit

it have only ssh access no web

how do i activate the web interfade?

thanks

You probably flashed a snapshot version. Snapshots do not include LuCI. You can install it with the opkg package manager, but probably best to install an official stable release build unless there is a specific reason you need the snapshots.

The device info page here will help you find the right download link. You can download it directly on the router (to the /tmp directory), or use scp to transfer it from your computer. Then, via an ssh session, run sysupgrade -n </tmp/<filename> to perform the upgrade.

thanks for the answer

i got it like this ,how do i know what version i have on it from the cli?

i will try to upgrade it thanks

What do you see when you login?

The banner message usually shows the version number and type.

If not, run:

cat /etc/openwrt_release

this is what i see

BusyBox v1.22.1 (2015-07-21 15:13:55 GMT) built-in shell (ash)
Enter 'help' for a list of built-in commands.


| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -| || | | || || |
|
_____|| |
||||___||| |____|
|
| W I R E L E S S F R E E D O M

CHAOS CALMER (Bleeding Edge, r43800)

  • 1 1/2 oz Gin Shake with a glassful
  • 1/4 oz Triple Sec of broken ice and pour
  • 3/4 oz Lime Juice unstrained into a goblet.
  • 1 1/2 oz Orange Juice
  • 1 tsp. Grenadine Syrup

root@OpenWrt:~# cat /etc/openwrt_release
DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='Bleeding Edge'
DISTRIB_REVISION='r43800'
DISTRIB_CODENAME='chaos_calmer'
DISTRIB_TARGET='ar71xx/generic'
DISTRIB_DESCRIPTION='OpenWrt Chaos Calmer r43800'
DISTRIB_TAINTS='no-all'

  • You don't have to double post
  • Chaos Calmer is extremely old and not supported, please upgrade OpenWrt for support

ok thanks

can you tell me that image to take?

https://openwrt.org/toh/start?dataflt[Model*~]=wr1043nd

The "supported current release."

thanks alot for your help

probelm solved router is up with gui

thanks agian for your time and patience

1 Like

If your problem is solved, feel free to mark the relevant post as the solution; and/or edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).

grafik