Newbie needs help with setting up DSL on a FRITZ!Box 7430


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd58:d15a:c57e::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option ds_snr_offset '0'
	option annex 'j'
	option tone 'bv'
	option firmware '/lib/firmware/vr9-B-dsl.bin'
	option xfer_mode 'ptm'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config device
	option name 'lan1'
	option macaddr 'E8:DF:70:**:**:**'

config device
	option name 'lan2'
	option macaddr 'E8:DF:70:**:**:**'

config device
	option name 'lan3'
	option macaddr 'E8:DF:70:**:**:**'

config device
	option name 'lan4'
	option macaddr 'E8:DF:70:**:**:**'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'dsl0'
	option macaddr 'E8:DF:70:**:**:**'

config interface 'wan'
	option proto 'pppoe'
	option device 'dsl0.7'
	option username '****'
	option password '****'
	option ipv6 'auto'

config interface 'wan6'
	option device '@wan'
	option proto 'dhcpv6'