Newbie here. Could i get a guide on how to install OpenWrt with serial, step-by-step or a link to an existing one?

Yeah as i wrote i have both a pyramid/triangle and the J3. So i should count from the triangle then or the J3?
On J3 GND-NC-RX-TX-NotUsed
Seems confusing right now..

It's easier to just know that the GND is the lonely pin, and then NC has no pin. Then i know the order. Thanks though. Ok now i'm confused on which direction i should count it on haha.
On the other router the NC had no pin.. If i count from the side with the triangle and follow this:
On J3 GND-NC-RX-TX-NotUsed

Gnd is not a lonely pin.. TX would had been empty.
If i count it the other way it would be correct if i start with notused.

As I noted, you count from the triangle since one exists.

Not sure how that's confusing.

(Isn't a NC pin missing anyways???)

Yeah.. Gonna try later now that i know NC has no pin..
What tools do you recomend being installed for this on debian? Some command with all the tools i need maybe? Thanks

Because TX would be missing a pin then.. instead of nc and however i count hehe
Or if i confuse it with the other router...
if i count from the triangle i get..

three pins, no pin, one pin on the right..
no pin being tx.
if i turn it around i get an empty pin on the left instead so..

one pin, empty pin, three pins..
which would make more sense.
GND-NC-RX-TX-notused

It's a Lantiq SoC, so DSL is supported. If I was stuck with having to use an ADSL line, that's the only reason I'd consider using this model. But it's really not for beginners. After installing the hacked bootloader, you can't use bootloader CLI any more. So if OpenWrt ever bricks, the only possible recovery is to use hardware to write directly to flash. Also the CPU is very slow and the RAM is only 64M.

1 Like

The ones used in the WIki. You install them using the normal package procedures in Debian. (Are you mentioning Debian because the link goes to it's TFTP server WIki??? You can use any TFTP server - I hope that's not confusing to you.)

(If you're asking for actual Debian install commands, etc. - this is beyond the scope of this forum).

Screenshot (of your actual device) please!

Recall, you're in the best vantage to see, not us!

I would just follow the diagram, I wouldn't keep "questioning the pins" (I donno what else to call it), I'd go in order. You only get traffic by hooking them up properly anyway.

Oh wow!

Thanks for the clarity!

thanks. But how would i change LAN IP of the freshly booted OpenWrt on the serial console to provide Internet connectivity (ifconfig br-lan, default route, provide nameserver etc) to download and verify directly the OpenWrt firmware (or get squashfs “sysupgrade” image for zyxel_p-2601hn?
A few wprlomg examples perhaps?

Would this be enough?
setenv ipaddr 192.168.0.1
setenv serverip 192.168.0.33
Some "universal settings" maybe..
have done other stuff, but read some on this. Good to learn some before i try it out. or i could just try it out soon actually

If OpenWrt is running, you should be able to browse to its web GUI.

Again:

So, unless you want command line instructions...?

(You notice how we go in circles...I think you're ready!!!) :raised_hands:

So you have hope.. Good. :wink: I started today.. This is harder then i thought.. But i have a working tftp server on debian now! And i want to know how i plug it it? I have the three flashing cables.. called the serial cables perhaps? And i plug in the flasher in the usb, but do i need to connect ethernet and electricity, or can the flasher alone flash this router? How do i see the booting of the router? Do i see nothing in the terminal, and i should press z in >tftp ? I need a video. A video anyone???! Similar router so i see kinda how a flashing process looks like. THANKS

Do tftp work with jumper cables alone or do i need to plug in ethernet and electricity also? I have no clue.
This:
interrupt boot by pressing “z”, followed by ZLGU to get U-boot cli prompt AMAZON_S #
Do i press z and ZLGU on the tftp> in the terminal when i boot the router up with electricity and the wires on ground, and so on? hmm, this is for experts.. just to get open source, but im closer now, help me succeed getting open source someone :wink:
edit: do i connect with putty through router_serial? If so i need to re-adjust the wires.. depending on if i need electricity or not... or if i would fry the router using normal power for it?
You don't plug in laptops when you flash them. It's the same with routers right?

# dmesg | grep tty
[    0.053424] printk: console [tty0] enabled
[   18.947920] systemd[1]: Created slice system-getty.slice.
[   23.669921] cdc_acm 3-4:1.1: ttyACM0: USB ACM device
[   23.670303] cdc_acm 3-4:1.3: ttyACM1: USB ACM device
[   23.670511] cdc_acm 3-4:1.9: ttyACM2: USB ACM device

And three cables connected.. getting closer.. But cant get connection with putty though... how do i get a connection with serial? Do i need some drivers also for the black edition?

edit.. nah i wasted my entire day on this. I'm skipping this! Did not get past..

  • Connect serial and interrupt boot by pressing “z”, followed by ZLGU to get U-boot cli prompt AMAZON_S #

I had a tftp server though.. need to but the hub 5 instead or flash 7530 and buy an adapter..
this was way to complicated! I could manage this with a step-to-step guide but there are none out there. And i'm no electrical engineer hehe
Just a dude trying to get an open source router. Guess i picked the "wrong" one.. still fun to maybe try in the future if i learn more so im keeping it.. it costed like nothing so.. I did thought it had like an GUI and just uploading a file or ssh or something easy.. This was more complicated then corebooting a laptop.. If you know nothing about the subject. I'll just let my old relatives do it next time, they have an easy time checking emails and such.. that would work out fine :slight_smile: How do you turn on windows 98 again? Need to get past this blue screen of death.. It's cool if others know how to do this though, but i did not get a screen or connection with putty so i don't know where i failed. Fail. This day was a waste..

edit: I bought it in a hurry and read this part.. so eeasy it said. haha.

"NOR flash on this board is stored in 128k blocks. Full flash can be dumped and copied out from within stock firmware using “dump_nor_flash.sh”. Second stage U-boot is stored within the first block and has its autostart/ default settings built-in as “read only” - at the end of a so called legacy image - which happens to be lzma compressed… So all what's needed is just to uncompress the image, change the settings, repack full binary block and flash it, easy as that :-D

Flashing firmware

  • Download xway target “initramfs” image of zyxel_p-2601hn first link

  • Have TFTP server ready

  • Connect serial and interrupt boot by pressing “z”, followed by ZLGU to get U-boot cli prompt AMAZON_S # "

Yeah dude.. veeery easy! VeeRRY easy. =) hehe
Maybe if you're an elecrical engineer or a hardware hacker..
veeery funny... veeeeryy funny.

Good try though. Good job hacking the router though.

You are best to know your serial cable. When connected properly, you see output on your screen. You must set line speed and other settings.

???

Wtf?

Was this a joke?

You also deleteed refrences about Ethernet. I assumed you knew that. That has to be like the instructions.

Yea...you may wanna wait til somene drops a video...

I don't know anything about this.. I can follow guides.. I have never serial flashed a router with pins before. hehe..
So i have no idea how that works.. But i might have installed the wrong drivers or something.. I was close, lets leave it at that. :wink: Kinda.. probably. Just dont have any patience now. Thanks for the help. Peace out

Omg...yea...I think you should wait for a video...you're forgetting everything we covered above.

I guess it's nervousness.

No joke.. I'm a newbie on this.. So yeah. It was harder then i thought. :wink: I tried though.
yeah a video or a full guide could work. Not that guide. Not for me haha. I don't know how to do stuff like this. It's not a hobby or anything.. Just want to get open source on the router. :wink: Take care peace out
edit: I joked about eddie murphy and windows 98 though of-course.. you got that :wink:
But no i don't know stuff like this..

1 Like

hehe what? I did try.. If i connected the pins wrong that would be wierd.. Nothing popped up with putty. No i'm not nervous im annoyed.. Lack of knowledge and instructions. (or some linux driver i installed or maybe the pins, don't think so though.. ) Not your fault. Thanks for the help though.

1 Like

The instructions don't mention Windows 98...

???

I'm not sure what you mean, since it's possible to wire improperly.

This is normal with wiring a serial connector for the first time. But ok. It's cool you tried!

I'm not sure what video would say wire Tx to Rx...Rx to Tx and Grd to Grd...we covered thay already.

That part was a joke ofcourse.. Like my grandmother trying to open email on windows 98.. They would find that hard! Flashing a router like this could be like them trying to open a browser and open an email in windows 98... 20 years ago. That part was a joke, yes. Good you got that. :wink:
Got that. :wink: That last part was not sarcasm. hehe

I did connect both ways.. so either the linux driver i found on github.. i don't know what the issue is. Should putty have popped up with a screen if successful? I might try this again in 5 years after this trauma of trying to install openwrt hehe. Kidding. Peace out.

No...

  • first, I understood you were running Debian (per your statements), so where did PuTTY come from?
  • your terminal program should already be running when you begin this process (so you see output ASAP), it will not open automatically

Like.. i did run tftp> if that's what you mean? Be more specific please.