Newbie DDWRT to LEDE Project (VirtualBox Test Drive)

Hi Folks,

Many years, I have been using DDWRT on several routers. Now I have WRT1900AC v1 router. I want to change my firmware to LEDE Project. I research a lot but I couldn't find Live Demo. For this reason I tried to run LEDE as a VirtualBOX Virtual Machine. I follow the steps:

But I stuck in "uci show network" step. You can see my VirtualBox configuration here:

When I type uci show network it says Uci: Entry not found.

Can you help me? Just I want to test LEDE before I install on WRT1900ACV1

Instead of waiting reply for my topic, I installed LEDE on my WRT1900ACv1

First I erased nvram on DDWRT than change boot partition
Second I did Factory Default on stock firmware.
Third I installed recommended LEDE release for my router.

Currently I use LEDE, but it is a little bit complicated. It has very nice interface but I need USB support NAS support FTP support. OpenVPN support. I hope somebody can help me to find. I do not want to install wrong package.

Looks like nobody will help me. Anyway I am trying to mount my NTFS USB Harddisk. It is very hard to mount if you dont know. DD-WRT was auto detect my HDD. I think I am going back to DDWRT soon.

After spending 6 hours, I decided to go back to original firmware (stock) fo Linksys 1900AC v1. But this is not easy. You can easily brick your router if you don't what are you doing. I downloaded Putty for SSH access. After I login to LEDE via SSH. I follow these commands:

cd /tmp (ENTER)
wget (ENTER)
sysupgrade -F -n -v FW_WRT1900AC_1.1.10.167514_prod.img (ENTER)

Currently, I reverted to stock firmware. I will install latest version of DD-WRT. Sorry guys but looks like LEDE for Linux gurus. I need all in one package. LEDE has very nice interface but it is not user friendly like DD-WRT. I tried but I don't like it. I hope this little jurney can help the people who want to try LEDE. Bye guys..

root@LEDE:/tmp# sysupgrade -F -n -v FW_WRT1900AC_1.1.10.167514_prod.img
Image metadata not found
Image check 'fwtool_check_image' failed but --force given - will update anyway!
killall: watchdog: no process killed
Sending TERM to remaining processes ... logd rpcd netifd odhcpd crond uhttpd ntpd dnsmasq ubusd askfirst
Sending KILL to remaining processes ... askfirst
Switching to ramdisk...
Performing system upgrade...
Unlocking kernel1 ...

Writing from to kernel1 ...
Upgrade completed
Rebooting system...
umount: can't unmount /dev/pts: Resource busy
umount: can't unmount /dev: Resource busy
umount: can't unmount /tmp: Resource busy

you need to be a little more patient, discarding a project because you do't get
an answer in 6 hours (in the middle of the night in the US) will lead you to
abandon most things.

LEDE has the LUCI GUI for configuration, you don't have to be a linux guru to
run it, but it does give you a lot of options that you don't have with dd-wrt,
and as a result, it's configuration can be more complicated

If you're not willing to put effort into learning the system or waiting for
people to help you, we aren't going to be able to help.

have fun.

David Lang

Old thread, but going to write to it anyway as the OP has a non legit claim IMHO.

I had and still have questions myself on openWRT/LEDE

There is NOT ONE question I got no answer to! Seriously, there is NO BETTER community as the LEDE/openWRT! Also I never got the:'already asked, bye!" answer either. Which I got a lot in DD-WRT and other communities.

This community is really extremely tolerant, helpful and gentle to people who love to learn!

But, as with all learning, you have to be patient. I live in Asia now, so when I ask something, it might take a while before Europeans or Americans answer. But even so, they answer faster as my searching for hours using google in the hope to get answers. I still search online and try a lot myself, but the support here in this community is beyond compare!

Seriously, complaining about not getting help in this community is totally wrong and IMHO insulting.

As for your problem, there are TONS of pages to avoid bricking your router, going back and forth between LEDE, openWRT and DD-WRT as well as stock firmware.

Personally, I don't see the point of leaving openWRT/LEDE.

If your device is supported, you have tons more options and features using openWRT, I'll skip the LEDE from here on as it's merged now into 1 anyway (THANK YOU FOR THAT!!!)

also the openWRT runs stable on my virtual box, Asus, Linksys and some other older routers I have.

IF you find a bug, you should know you can just report it and usually within 1 working day it's fixed!

Unless your bug isn't consistent and related to specific settings, then it might take a while for them to find your bug, but the more info you give, the easier and faster the devs find the bug and know this: they are trying to help you out and tackle the bug.

I never had a openWRT dev telling me:"I don't care!"

It's a living and great community, so if you find bugs: don't leave because of a bug. Make a proper documentation, file it, watch for a dev to contact you for more information if they need it, help the devs with debugs, outputs, log files, ...

to get good releases, you also need good users with good feedback! And users taking the time to write down good feedback as well!

Short side note: Rome wasn't build in 1 day!

I take this as a hint that this old topic can be closed.