Newbie can't pass go

There is a lot of stuff here... But I am at an impasse.

I have a Tripmate nano HT-TM02. Got OpenWrt 19.07.1 r10911 on board and can get to Luci on 192.168.1.1

I'd like to set this up to share a USB hard drive on my local network.

My secondary possible need would be as a wireless repeater for range extension and if possible openvpn?

But I can't even get past go.. I tried several times to turn off dhcp and change the IP to 192.168.1.200 and it just goes into some "failed to confirm .. waiting for rollback..."

Actually I can't update the software packages either. Is there some sort of "stupid beginners" area for folks like me?

Any pointers appreciated!
Thanks in advance
TC

Oh and I can ssh into the tripmate. I am pretty comfortable on the cli too.

I am trialing some common commands but not finding what I am looking for. But I will keep trying

First off that unit isn't the best for OpenWrt since there's only 32 MB of RAM it's easy to run out. With the small RAM it should be kept to basic applications.

To save RAM, I'd disable uhttpd (the web server) and use the CLI exclusively. Configuring OpenWrt via CLI consists mostly of editing the files in /etc/config. The CLI itself is a Linux shell not so much a configuration interface.

1 Like

Thanks mk24

I read many places that the unit is undersized. Understand I didn't buy this for this project. Simply dusted it off from my box of past tech - trying to give it a new job.

But is there any chance that you have hints on simply changing the IP address? Reading this forum I just can't seem to find the super newbie section.

Or how to disable uhttp even. I have no troubles with the CLI. I did have troubles getting vi to save my edits - even hitting esc first... I am more familiar with nano - but I realize that will eat into my available RAM.

BTW - Luci shows I have 10.92MB total available.

Any hints are appreciated.

in /etc/config/network just change the IP address under the LAN interface.

or use ipv6 :nerd_face:

Or if you have not disable LuCI yet, you can choose apply unckecked when you change the IP. Other solutions without be to set a second IP address on your PC (let that be as a secondary IP on the same network card, or as a second card such as Ethetnet card) so that the new address is on the desired router's subnet. And then when you change the IP on the router, and within the 30 seconds period, you access your router via the new IP in a browser window. That way the router knows you have access to the new IP network and will not roll back.

1 Like

If you edit from CLI at /etc/config/netwok - then you won't even come across this issue with the rollback.

Okay - I now have the ip addressed changed - So thanks everyone.

But moving along here. Looking to add wireless bridging?
OpenVPN?
Samba share of USB drive?

Any dummies guides for any of these tricks?
Any tips appreciated.
TC

So moving along I have my next hurdle. I thought I would focus on the wireless repeater function. Looking for the packaged "relayd" I find it is not in my current software.

So In Luci - clicking on Update Lists results in:

Downloading http://downloads.openwrt.org/releases/19.07.1/targets/ramips/rt305x/packages/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.1/targets/ramips/rt305x/packages/Packages.gz

Downloading http://downloads.openwrt.org/releases/19.07.1/targets/ramips/rt305x/kmods/4.14.167-1-9a90d552f1e8ed4f201155596f60004e/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.1/targets/ramips/rt305x/kmods/4.14.167-1-9a90d552f1e8ed4f201155596f60004e/Packages.gz

Downloading http://downloads.openwrt.org/releases/19.07.1/packages/mipsel_24kc/base/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.1/packages/mipsel_24kc/base/Packages.gz

Downloading http://downloads.openwrt.org/releases/19.07.1/packages/mipsel_24kc/luci/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.1/packages/mipsel_24kc/luci/Packages.gz

Downloading http://downloads.openwrt.org/releases/19.07.1/packages/mipsel_24kc/packages/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.1/packages/mipsel_24kc/packages/Packages.gz

Downloading http://downloads.openwrt.org/releases/19.07.1/packages/mipsel_24kc/routing/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.1/packages/mipsel_24kc/routing/Packages.gz

Downloading http://downloads.openwrt.org/releases/19.07.1/packages/mipsel_24kc/telephony/Packages.gz
*** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.1/packages/mipsel_24kc/telephony/Packages.gz

Errors

Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.1/targets/ramips/rt305x/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.1/targets/ramips/rt305x/kmods/4.14.167-1-9a90d552f1e8ed4f201155596f60004e/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.1/packages/mipsel_24kc/base/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.1/packages/mipsel_24kc/luci/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.1/packages/mipsel_24kc/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.1/packages/mipsel_24kc/routing/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.1/packages/mipsel_24kc/telephony/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

The opkg update command failed with code 7.

So I picked the first package it was trying to download
http://downloads.openwrt.org/releases/19.07.1/targets/ramips/rt305x/packages/Packages.gz

Manually downloaded it and then tried to upload and install the package and then got these errors.


#### Executing package manager

##### Errors

Collected errors: * pkg_init_from_file: Malformed package file /tmp/upload.ipk.

The *opkg install* command failed with code `255` .

So anyone with hints on what to try next would be appreciated.

Regards,
TC

It is much easier to install packages directly through an Internet connection.

I assume since you made the LAN IP 192.168.1.200, that you have connected it to a lan network that has a main router and Internet service. You need to add options gateway and dns to the LAN configuration (with the IP of the main router) then OpenWrt can download from the Internet.

relayd is usually not the best way to build a bridge / extender. Either set up a routed client or if your main router is also OpenWrt use WDS or a mesh.

The LAN IP is 192.168.1.200 now. I can login there to Luci.

I added a wireless SSID and I can login to that and it connects to the internet. So the device sees the internet.

So how do I add options gateway and dns?

Do I need to add a custom DNS for any reason?

I practiced a bit getting used to VI - so if you want tell me how to kill uHttpd if I still need to free up memory?

Or I am also ready to edit config files directly.

Here is the current contents of my /etc/config/network file:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fda6:23a6:642c::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.200'

config device 'lan_eth0_dev'
        option name 'eth0'
        option macaddr '00:1c:c2:36:7c:2b'

config switch
        option name 'switch0'
        option reset '1'                  
        option enable_vlan '0'            
                                          
config interface 'TM_Nano'                
        option proto 'dhcp'               
                                          
config interface 'wwan'                   
        option proto 'dhcp'               
                                          
config interface 'wwan2'                  
        option proto 'dhcp'               
                                          
config interface 'wwan3'      
        option proto 'dhcp'   
                             

I have been dinking around trying to learn - so there might be some junk already there.

Anyway - any tips appreciated.
TC

Okay - I updated my packages in Luci

To clarify what mk24 was telling me:
In Luci - network/interfaces/LAN
I clicked edit and added my gateway and my ISP's dns servers under "Use custom DNS servers"

Writing this here to help me remember :rofl: :rofl: and anyone following me that hasn't learned the OpenWRT shorthand yet (just like me).

Okay - so I am ready for the next step. I see I could add relayd at this point but mk24 - advises against and suggests setting up a routed client. Searching google more right now - but not finding enough to gleen from. Oh and - my main router is the ISP provided locked down router btw. Plus my plan is to bring this as a travel router.

I found this here - sounds a bit like what I am looking to do:
https://openwrt.org/docs/guide-user/network/routedclient

But trying step 1 results in:

root@OpenWrt:~# uci del wireless.@wifi-device[0].disabled
uci: Entry not found

Thinking I might not exactly know enough...
Any hints and pointers appreciated.
Thanks again!
TC

Hi tcatone,
seems I'd the same problem with "code 7" message. I'd tried to set a static network address under "Network/Interfaces/WAN", but I think I'd forgotten something. After switching back to "DHCP client" in the "WAN General Settings" the software update list worked and Stubby was found ...

Did you ever find the super newb-non IT part of the forum? I could sure use it since I know none of the IT lingo.

@wingdlvrd - I'm sure that the volunteers who help on this forum would be happy to help you with whatever issues you are experiencing (please start a new thread for that). OpenWrt is used by people of all levels of IT skillsets, and the forum (and volunteers who often provide assistance) can be helpful to users of all abilities. These forums are inherently technical/IT because of the subject matter, but just be up-front about your level of experience and hopefully you'll get help without too much jargon (or at least some help understanding the jargon if it is necessary). What's most important is that you describe your objectives and as much detail as possible about the problem(s) you've encountered.

1 Like