New Xiaomi router AC2100

What is your region? Try changing that, many countries restrict allowed channels.

Looks like my problem was that I was using a 80 mhz channel that includes channel 144, which seems to be "special"... It should be allowed in Europe, but the firmware does not seem to support it... The other channels in the range actually work, that was my mistake :slight_smile:

Hello, can any one provide the stock firmware, I'm unable to download it from the web site and I need to recover by tftp.
Thank you

Hey. You simply need to replace the server address: instead of For the black version, that's:


Btw: Still looking for the stock bootloader. Can anyone please dump it for me?

High vulnerability Xiaomi AC2100 (firmware version 2.0.376) is detected according IoT Inspector Report.

Have you any ideas to avoid it?

May I ask where you got English breed? :laughing:

Of course. Here is the download link. I don't have Baidu account if you manage to download and share to here will be awesome.

Link: Extraction code: 5xsk

Btw you tagged me wrong. I wasn't see your ping thats why. Should be @emirefek. not @ermirefek :smiley:

I have a very strange phenomenon I wonder if anyone has experienced before.

I got the RedmiAC2100, flashed it to OpenWRT as described in the tutorials and able to login via ssh.

BUT --
It seems that the internet is connected in bursts as can be seen in this ping example:

root@OpenWrt:~# ping
PING ( 56 data bytes
64 bytes from seq=15 ttl=56 time=80.508 ms
64 bytes from seq=16 ttl=56 time=65.414 ms
64 bytes from seq=17 ttl=56 time=66.069 ms
64 bytes from seq=18 ttl=56 time=65.253 ms
64 bytes from seq=19 ttl=56 time=64.425 ms
64 bytes from seq=20 ttl=56 time=65.845 ms
64 bytes from seq=21 ttl=56 time=68.307 ms
64 bytes from seq=22 ttl=56 time=64.791 ms
64 bytes from seq=50 ttl=56 time=2060.722 ms
64 bytes from seq=51 ttl=56 time=1056.855 ms
64 bytes from seq=52 ttl=56 time=64.050 ms
64 bytes from seq=53 ttl=56 time=63.906 ms
64 bytes from seq=54 ttl=56 time=70.360 ms
64 bytes from seq=55 ttl=56 time=64.758 ms
64 bytes from seq=56 ttl=56 time=69.929 ms

Note the jump in the sequences
This effects me in every way - downloading luci required to run opkg install luci multiple times until it was downloaded.

I wonder if there's any solution to it.
Should I configure something on the "main" router - the one the AC2100 connects to?

Also - Is there a way to restore AC2100 original firmware via OpenWRT? Didn't quite got it from the tutorials...

Something went wrong with the Philipp Schuster's rom on Xiaomi AC2100.

I just configured it as a dumb ap (cf. At first I found that the wireless would disappear from time to time. Latter, I looked into the system and found that the time synchronize does not work, no network is detected.

it works perfectly as a dumb AP for me since a month now.

did you set your timezone correctly ?
System > System > General settings : Timezone
System > System > Time Synchronization : Enable NTP Client Set

Best regards

yes,I did all that. Synchronization works well when as a coommon router, but when bridges eth0.1 eth0.2, and configures all ports to one switch, synchronization stops. when you start the system time starts at a fixed point, then begins to count.

However, it can synchronize time to the web page.

the net setting:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr ''
option netmask ''

config globals 'globals'
option ula_prefix 'fdb0:bbb1:45ba::/48'

config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr ''
option netmask ''
option ip6assign '60'
option ifname 'eth0.1 eth0.2'

config device 'lan_eth0_1_dev'
option name 'eth0.1'
option macaddr '88:c3:97:e1:a7:41'

config interface 'lan6'
option proto 'dhcpv6'
option ifname '@lan'
option reqprefix no

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 2 3 4 6t'

there are some weak points compared to mir3g. As a normal router, when access the upper samba, the speed is only 40-50mb/s, <100-110mb/s. only in dumb ap mode, the speed will reach 100-110mb/s.

In the dumb AP setting, it does not ping through "" from Network>Diagnostics:

PING ( 56 data bytes
ping: sendto: Network unreachable

Firewall is closed. what prevent the the connection?

root@Miac2100:~# ping
PING ( 56 data bytes
ping: sendto: Network unreachable

I also tried Emir Efe Küçük's rom (on the list here), the same behavior. when converted to a dumb AP, there is no net to the machine.

That looks like a configuration error to me, you haven't given your dumb ap a gateway and dns?

Thanks. That's solved. It need a gateway as well as a dns.
The question is before the coversion to the dumb ap, it doesn't need to.

Hey all, need your assistance.
I want to upgrade the router (configured as dumb ap) to the new master snapshot, sysupgrade shows this warning:

root@OpenWrt:/tmp# sysupgrade -v -n ./openwrt-ramips-mt7621-xiaomi_redmi-router-ac2100-squashfs-sysupgrade.bin
Device xiaomi,redmi-router-ac2100 not supported by this image
Supported devices: xiaomi,redmi-router-ac2100 - Image version mismatch: image 1.1, device 1.0. Please wipe config during upgrade (force required) or reinstall. Reason: Config cannot be migrated from swconfig to DSA (early adopters with DSA already set up may just force-flash keeping existing config)
Image check failed.

how do you recommend to upgrade?

If you were already on a DSA based snapshot (all of the snapshots for this device were) , you can just force it with -F

If you were on one of the unofficially backported 19.07 builds, you will need to tell it not to retain configuration in addition to forcing it. (ie. -n -F)

Subsequent upgrades after shouldn't complain.

1 Like

Yes, please! I would like to obtain the english version as well. Anyone?

I'm experiencing strange ping issues too. But I didn't manage to fix it. But I'm now using @scp07's builds. Without too many additional tools. Looks like fine for couple days. I just don't have a mood to deal with openwrt these days. If you find a fix share please....

I don't have any idea about dumbap. But I'm suggesting you to not use my builds. They are outdated. My builds are migrated with @scp07 and openwrt:master@github. And thanks to @scp07 he is maintaining 19.07 perfectly for AC2100 family. And if you wanna test snapshot you can compile from latest version at GitHub our source is migrated with it...