New Xiaomi router AC2100

I did a backport to 19.07.3 from the new commit for the master branch. Everything is working fine (in contradiction to ilyas I left mt76 in place in the dts file and I didn't replace it by pci14c3). I also tried more unusual stuff like 802.11s mesh with sae encryption and it's working without any issues.

Sadly I'm experiencing a strange issue with the mt7530 switch. I can only reach 100 Mbit/s instead of 1 Gbit/s. I can remember that there were some mdio issues in the past so maybe it has some correlation with these issues.

Those of you who tried ilyas firmware version 19.07: Do you also experience the same issue?

@ilyas : I could also upload a staging tree with my modifications for the 19.07 tree. Maybe we can continue testing your or my backport and then doing a PR to get this integrated into 19.07 officially.

Sample bandwidth output from LUCI:

Hi, I upddated with firmware from https://github.com/iscilyas/openwrt/releases and it broke all networking. To restore, I connected via UART to it and I got root shell. It seems thet there is config conflicts betwean master snapshort I used before and 19.07. I made few fixes in /etc/config/network and I was able to up link (I see packets on ethernet level) However TCP/IP is not working at all. WAN can not connect to the internet. And router is not accessible via ethernet. Finally I runed firstboot that made settings reset. But it did not fix networking.
I stuck In that state that I can not copy other firmware without networking. It would be really nice if anybody can give me a hint how to fix it.

They don't typically accept device backports.

master is DSA, 19.07 is swconfig.

Please factory reset when moving between these builds, if you choose to use them.

Please factory reset when moving between these builds, if you choose to use them.

I executed firtsboot (but I did it after instaling another version) that is a factory reset for OpenWrt, isn't it?
Do you mean that I should perform factory reset to stock firmware?

Maybe just try

umount /overlay && jffs2reset && reboot now

That should normally solve it.

well i don't even have an rm2100/ac2100 so i'd be perfectly happy for you to take over responsibility for 19.07 :wink: it's a pity they don't accept device backports though

yeah i was just curious if that would change anything... probably didn't :wink:

I got this

root@OpenWrt:/# umount /overlay
root@OpenWrt:/# jffs2reset
This will erase all settings and remove any installed packages. Are you sure? [N/y]
y
/dev/ubi0_1 is n[  119.440936] ubi0 error: ubi_open_volume.part.3: cannot open device 0, volume 1, error -16
ot mounted
/dev/ubi0_1 will be erased on next mount
writing /dev/ubi0_1 failed: Bad file descriptor

Ilyas's backport works fine. I'm using it daily. And I'm first tester of it. All my switch ports are FullDuplex1000mbps. Maybe you are doing something wrong.

You can try my precompiled firmware if you want. https://drive.google.com/folderview?id=13mTGEswOK_YABMWrE8TbLoKqCgCqTEmL
Maybe you have an hardware failiure.

hey sorry to hear that. i realized i should have given a warning that you should probably fresh install (instead of doing a sysupgrade)... or at least not save any configuration files.

i think a "fresh install" (moving from openwrt-snapshot to openwrt-19.07) should be something like this (taking into account the new partition names):

mtd write xiaomi-router-kernel1.bin kernel
mtd write xiaomi-router-rootfs0.bin ubi
reboot

if you're already using openwrt, keep in mind that the partition names are different (vs stock xiaomi)... kernel1 in stock becomes kernel in openwrt, and rootfs0 in stock becomes ubi in openwrt.... so the commands above would become:

mtd write xiaomi-router-kernel1.bin kernel
mtd -r write xiaomi-router-rootfs0.bin ubi

i'm just making sure this is clarified

I know, that I am doing it on my own risk.
Thanks for hint. But currently I have issues with delivery new binaries, as far as standard ssh, scp, wget etc... doesn't work for me. I tried to copy it as base64 over UART but it was unsuccessful.

Could anyone dump me /etc/config/network from working 19.07 and output of uci show network please?

Here's an example from a working config:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde6:9ebf:3bc5::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option broadcast '192.168.1.255'
        option ip6assign '64'
        option ipaddr '192.168.1.1'
        option ip6ifaceid '::1'
        option mtu '1500'

config interface 'wan'
        option proto 'dhcp'
        option mtu '1500'
        option peerdns '0'
        option ifname 'eth0.2'
        list dns '127.0.0.1'

config interface 'wan6'
        option proto 'dhcpv6'
        option mtu '1500'
        option reqprefix 'auto'
        option reqaddress 'try'
        option peerdns '0'
        option ifname 'eth0.2'
        list dns '0::1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '0 6t'

same in uci syntax:

root@OpenWRT:/etc/config# uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fde6:9ebf:3bc5::/48'
network.lan=interface
network.lan.type='bridge'
network.lan.ifname='eth0.1'
network.lan.proto='static'
network.lan.netmask='255.255.255.0'
network.lan.broadcast='192.168.1.255'
network.lan.ip6assign='64'
network.lan.ipaddr='192.168.1.1'
network.lan.ip6ifaceid='::1'
network.lan.mtu='1500'
network.wan=interface
network.wan.proto='dhcp'
network.wan.mtu='1500'
network.wan.peerdns='0'
network.wan.ifname='eth0.2'
network.wan.dns='127.0.0.1'
network.wan6=interface
network.wan6.proto='dhcpv6'
network.wan6.mtu='1500'
network.wan6.reqprefix='auto'
network.wan6.reqaddress='try'
network.wan6.peerdns='0'
network.wan6.ifname='eth0.2'
network.wan6.dns='0::1'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].vid='1'
network.@switch_vlan[0].ports='2 3 4 6t'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].vid='2'
network.@switch_vlan[1].ports='0 6t'


Just as an idea: If the network ports aren't working (maybe due to switch issues as you downgraded from DSA to swconfig) did you try just to create a wifi network and check if TCP/IP is working via wifi?

Then you could upload the fresh install files via SCP and write it to mtd.

Could you maybe provide the according config.buildinfo file to see which packets you selected during the build process (it's included in bin/targets/ramips/mt7621)?

Here it is.

config.buildinfo

CONFIG_TARGET_ramips=y
CONFIG_TARGET_ramips_mt7621=y
CONFIG_TARGET_ramips_mt7621_DEVICE_xiaomi_redmi-router-ac2100=y
# CONFIG_FEED_luci is not set
# CONFIG_FEED_packages is not set
# CONFIG_FEED_routing is not set
# CONFIG_FEED_telephony is not set
CONFIG_LIBCURL_COOKIES=y
CONFIG_LIBCURL_FILE=y
CONFIG_LIBCURL_FTP=y
CONFIG_LIBCURL_HTTP=y
CONFIG_LIBCURL_MBEDTLS=y
CONFIG_LIBCURL_NO_SMB="!"
CONFIG_LIBCURL_PROXY=y
CONFIG_OPENSSL_ENGINE=y
CONFIG_OPENSSL_PREFER_CHACHA_OVER_GCM=y
CONFIG_OPENSSL_WITH_ASM=y
CONFIG_OPENSSL_WITH_CHACHA_POLY1305=y
CONFIG_OPENSSL_WITH_CMS=y
CONFIG_OPENSSL_WITH_DEPRECATED=y
CONFIG_OPENSSL_WITH_ERROR_MESSAGES=y
CONFIG_OPENSSL_WITH_PSK=y
CONFIG_OPENSSL_WITH_SRP=y
CONFIG_OPENSSL_WITH_TLS13=y
CONFIG_PACKAGE_6in4=y
CONFIG_PACKAGE_6rd=y
CONFIG_PACKAGE_6to4=y
CONFIG_PACKAGE_acme=y
CONFIG_PACKAGE_acme-dnsapi=y
CONFIG_PACKAGE_adblock=y
CONFIG_PACKAGE_banip=y
CONFIG_PACKAGE_ca-bundle=y
CONFIG_PACKAGE_cgi-io=y
CONFIG_PACKAGE_coreutils=y
CONFIG_PACKAGE_coreutils-sort=y
CONFIG_PACKAGE_ddns-scripts=y
CONFIG_PACKAGE_https-dns-proxy=y
CONFIG_PACKAGE_ip-full=y
CONFIG_PACKAGE_iperf3=y
CONFIG_PACKAGE_ipset=y
CONFIG_PACKAGE_iptables-mod-conntrack-extra=y
CONFIG_PACKAGE_iptables-mod-ipopt=y
CONFIG_PACKAGE_kmod-ifb=y
CONFIG_PACKAGE_kmod-ipt-conntrack-extra=y
CONFIG_PACKAGE_kmod-ipt-ipopt=y
CONFIG_PACKAGE_kmod-ipt-ipset=y
CONFIG_PACKAGE_kmod-ipt-raw=y
CONFIG_PACKAGE_kmod-iptunnel=y
CONFIG_PACKAGE_kmod-iptunnel4=y
CONFIG_PACKAGE_kmod-mtd-rw=y
CONFIG_PACKAGE_kmod-nfnetlink=y
CONFIG_PACKAGE_kmod-sched-connmark=y
CONFIG_PACKAGE_kmod-sched-core=y
CONFIG_PACKAGE_kmod-sit=y
CONFIG_PACKAGE_libcap=y
CONFIG_PACKAGE_libcares=y
CONFIG_PACKAGE_libcurl=y
CONFIG_PACKAGE_libelf=y
CONFIG_PACKAGE_libev=y
CONFIG_PACKAGE_libipset=y
CONFIG_PACKAGE_libiwinfo-lua=y
CONFIG_PACKAGE_liblua=y
CONFIG_PACKAGE_liblucihttp=y
CONFIG_PACKAGE_liblucihttp-lua=y
CONFIG_PACKAGE_libmbedtls=y
CONFIG_PACKAGE_libmnl=y
CONFIG_PACKAGE_libncurses=y
CONFIG_PACKAGE_libopenssl=y
CONFIG_PACKAGE_libopenssl-conf=y
CONFIG_PACKAGE_libpcre=y
CONFIG_PACKAGE_librt=y
CONFIG_PACKAGE_libubus-lua=y
CONFIG_PACKAGE_libustream-openssl=y
CONFIG_PACKAGE_libuuid=y
CONFIG_PACKAGE_lua=y
CONFIG_PACKAGE_luci=y
CONFIG_PACKAGE_luci-app-acme=y
CONFIG_PACKAGE_luci-app-adblock=y
CONFIG_PACKAGE_luci-app-banip=y
CONFIG_PACKAGE_luci-app-commands=y
CONFIG_PACKAGE_luci-app-ddns=y
CONFIG_PACKAGE_luci-app-firewall=y
CONFIG_PACKAGE_luci-app-https-dns-proxy=y
CONFIG_PACKAGE_luci-app-openvpn=y
CONFIG_PACKAGE_luci-app-opkg=y
CONFIG_PACKAGE_luci-app-qos=y
CONFIG_PACKAGE_luci-app-upnp=y
CONFIG_PACKAGE_luci-app-vpn-policy-routing=y
CONFIG_PACKAGE_luci-app-vpnbypass=y
CONFIG_PACKAGE_luci-base=y
CONFIG_PACKAGE_luci-compat=y
CONFIG_PACKAGE_luci-lib-ip=y
CONFIG_PACKAGE_luci-lib-ipkg=y
CONFIG_PACKAGE_luci-lib-jsonc=y
CONFIG_PACKAGE_luci-lib-nixio=y
CONFIG_PACKAGE_luci-mod-admin-full=y
CONFIG_PACKAGE_luci-mod-network=y
CONFIG_PACKAGE_luci-mod-status=y
CONFIG_PACKAGE_luci-mod-system=y
CONFIG_PACKAGE_luci-proto-ipv6=y
CONFIG_PACKAGE_luci-proto-ppp=y
CONFIG_PACKAGE_luci-ssl-openssl=y
CONFIG_PACKAGE_luci-theme-bootstrap=y
CONFIG_PACKAGE_luci-theme-material=y
CONFIG_PACKAGE_luci-theme-openwrt=y
CONFIG_PACKAGE_miniupnpd=y
CONFIG_PACKAGE_nano=y
CONFIG_PACKAGE_openssh-keygen=y
CONFIG_PACKAGE_openssh-server=y
CONFIG_PACKAGE_openssh-sftp-server=y
CONFIG_PACKAGE_openssl-util=y
CONFIG_PACKAGE_qos-scripts=y
CONFIG_PACKAGE_resolveip=y
CONFIG_PACKAGE_rpcd=y
CONFIG_PACKAGE_rpcd-mod-file=y
CONFIG_PACKAGE_rpcd-mod-iwinfo=y
CONFIG_PACKAGE_rpcd-mod-luci=y
CONFIG_PACKAGE_rpcd-mod-rrdns=y
CONFIG_PACKAGE_socat=y
CONFIG_PACKAGE_tc=y
CONFIG_PACKAGE_terminfo=y
CONFIG_PACKAGE_uhttpd=y
CONFIG_PACKAGE_vpn-policy-routing=y
CONFIG_PACKAGE_vpnbypass=y
CONFIG_PACKAGE_wget=y
CONFIG_PACKAGE_zlib=y

Yeah. I know. :slightly_smiling_face: I have both OpenSSL and MBedSSL. I should fix it in next makeup.

I replaced /etc/confic/network with one from @scp07, executed service network restart Switch started to work. Now I can ssh, scp in regular way :smile:. Thanks a lot to evryone for assistance.
Now I would like to perform clean 19.07 installation by

mtd write openwrt-ramips-mt7621-xiaomi_redmi-router-ac2100-squashfs-kernel1.bin kernel
mtd write openwrt-ramips-mt7621-xiaomi_redmi-router-ac2100-squashfs-rootfs0.bin ubi

There are available fat sysupgrade.bin from @emirefek and initramfs-kernel.bin, squashfs-kernel1.bin, squashfs-sysupgrade.bin from @ilyas github.
I can't find squashfs-rootfs0.bin It is not the same as squashfs-sysupgrade.bin, is it?
I know that you are working on backport and I would be grateful if anyone could share it.

You don't need re-flash all mtd stuff. Openwrt is already clearing all rootfs and kernel while upgrading. Just clear configs while downgrade or upgrade. You will be fine. Btw If you did data reset before all this headache. You must be already got uplink.

@ilyas 's images are not include Luci and some usefull plugins. I suggest you to use my image. Based on @ilyas 's source. Just update with my image "sysupgrade.bin" you'll be fine.

I now uploaded my backport to github. You can have a look here: https://github.com/phs07/openwrt/tree/openwrt-19.07_xiaomi_ac2100

The issue with 100 Mbps on the swicht ports wasn't configuration or device related. I just used the wrong cables. Now everything is running on 1000 Mbps also for me.

I included a few fixes:

  • Changed the port_mask of the WAN led to 0x01 (already tested, the previous value 0x10 wasn't working)
  • Added the amber LED of the WAN port in addition to the white LED to the LED definitions
  • The amber LED will light up if the link speed is unkonw (speed_mask '0x01') which may indicate a cabling problem
  • The white LED will light up if a link is detected and the link speed is recognized (no matter if it is 10, 100 or 1000 Mbps)

I will also upload a precompiled image for factory flashing and also for sysupgrade with a few basic addons on top of the regular basic image (luci-ssl, hostapd, iw-full and wpa-supplicant-mesh-openssl). Maybe that will be a little bit more convenient for beginners as they could use the GUI for everything. The more expierenced users can even use 802.11s mesh with this image if required.

For all of you who want to get smaller images with less packages or images with more packages being integrated: Feel free to clone the repo and test it on your own. Feedback is highly welcome.

I just made sysupgrade with image from @emirefek It end up with

[    5.436365] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[    5.443867] Please append a correct "root=" boot option; here are the available partitions:
[    5.452194] 1f00             512 mtdblock0
[    5.452199]  (driver?)
[    5.458730] 1f01             256 mtdblock1
[    5.458735]  (driver?)
[    5.465254] 1f02             256 mtdblock2
[    5.465258]  (driver?)
[    5.471759] 1f03             256 mtdblock3
[    5.471763]  (driver?)
[    5.478290] 1f04             256 mtdblock4
[    5.478295]  (driver?)
[    5.484814] 1f05             256 mtdblock5
[    5.484818]  (driver?)
[    5.491319] 1f06             256 mtdblock6
[    5.491323]  (driver?)
[    5.497855] 1f07            4096 mtdblock7
[    5.497860]  (driver?)
[    5.504381] 1f08            4096 mtdblock8
[    5.504385]  (driver?)
[    5.510886] 1f09          120320 mtdblock9
[    5.510890]  (driver?)
[    5.517417] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    5.527550] Rebooting in 1 seconds..

I am afraid I need to recovery it via stock firmware.

As promised here is a precompiled version from my backport (including luci-ssl, hostapd, iw-full and wpa-supplicant-mesh-openssl):

Another precompiled version including a lot more addons (useful things like OpenVPN, SothetherVPN, wireguard, socat, stunnel, ddns, wol, tcpdump, iperf3...) can be downloaded here:

That's my favorite feature set I've also used for other devices. If you use this image, please remember to disable the startup of services you don't need (e.g. SoftetherVPN). Otherwise you will waste resources for things you don't use (you can disable services easily by going to System-->Startup in LUCI). Be careful: watchcat is also included. By default a script is predefined to reboot the device if 8.8.8.8 is not reachable for 6 hours. If you don't want that to happen you have to disable the watchcat service or modify the settings (in Luci: Services --> Watchcat).

Full list of included packages in the bigger version:

CONFIG_TARGET_ramips=y
CONFIG_TARGET_ramips_mt7621=y
CONFIG_TARGET_ramips_mt7621_DEVICE_xiaomi_redmi-router-ac2100=y
CONFIG_BATMAN_ADV_BATMAN_V=y
CONFIG_BATMAN_ADV_BLA=y
CONFIG_BATMAN_ADV_DAT=y
CONFIG_BATMAN_ADV_MCAST=y
CONFIG_BATMAN_ADV_SYSFS=y
CONFIG_DROPBEAR_ECC=y
CONFIG_DROPBEAR_ECC_FULL=y
CONFIG_GETDNS_ENABLE_STUB_ONLY=y
CONFIG_LIBCURL_COOKIES=y
CONFIG_LIBCURL_FILE=y
CONFIG_LIBCURL_FTP=y
CONFIG_LIBCURL_HTTP=y
CONFIG_LIBCURL_MBEDTLS=y
CONFIG_LIBCURL_NO_SMB="!"
CONFIG_LIBCURL_PROXY=y
CONFIG_OPENSSL_ENGINE=y
CONFIG_OPENSSL_PREFER_CHACHA_OVER_GCM=y
CONFIG_OPENSSL_WITH_ASM=y
CONFIG_OPENSSL_WITH_CHACHA_POLY1305=y
CONFIG_OPENSSL_WITH_CMS=y
CONFIG_OPENSSL_WITH_DEPRECATED=y
CONFIG_OPENSSL_WITH_ERROR_MESSAGES=y
CONFIG_OPENSSL_WITH_PSK=y
CONFIG_OPENSSL_WITH_SRP=y
CONFIG_OPENSSL_WITH_TLS13=y
CONFIG_OPENVPN_openssl_ENABLE_DEF_AUTH=y
CONFIG_OPENVPN_openssl_ENABLE_FRAGMENT=y
CONFIG_OPENVPN_openssl_ENABLE_LZ4=y
CONFIG_OPENVPN_openssl_ENABLE_LZO=y
CONFIG_OPENVPN_openssl_ENABLE_MULTIHOME=y
CONFIG_OPENVPN_openssl_ENABLE_PF=y
CONFIG_OPENVPN_openssl_ENABLE_PORT_SHARE=y
CONFIG_OPENVPN_openssl_ENABLE_SERVER=y
CONFIG_OPENVPN_openssl_ENABLE_SMALL=y
CONFIG_PACKAGE_TAR_BZIP2=y
CONFIG_PACKAGE_TAR_GZIP=y
CONFIG_PACKAGE_TAR_XZ=y
CONFIG_PACKAGE_batctl-default=y
CONFIG_PACKAGE_bzip2=y
CONFIG_PACKAGE_ca-bundle=y
CONFIG_PACKAGE_ca-certificates=y
CONFIG_PACKAGE_cgi-io=y
CONFIG_PACKAGE_curl=y
CONFIG_PACKAGE_ddns-scripts=y
CONFIG_PACKAGE_etherwake=y
CONFIG_PACKAGE_ethtool=y
CONFIG_PACKAGE_getdns=y
CONFIG_PACKAGE_gzip=y
CONFIG_PACKAGE_hostapd=y
CONFIG_PACKAGE_iftop=y
CONFIG_PACKAGE_ip-tiny=y
CONFIG_PACKAGE_iperf3=y
# CONFIG_PACKAGE_iw is not set
CONFIG_PACKAGE_iw-full=y
CONFIG_PACKAGE_kmod-batman-adv=y
CONFIG_PACKAGE_kmod-crypto-crc32c=y
CONFIG_PACKAGE_kmod-crypto-hash=y
CONFIG_PACKAGE_kmod-lib-crc16=y
CONFIG_PACKAGE_kmod-lib-crc32c=y
CONFIG_PACKAGE_kmod-tun=y
CONFIG_PACKAGE_kmod-udptunnel4=y
CONFIG_PACKAGE_kmod-udptunnel6=y
CONFIG_PACKAGE_kmod-wireguard=y
CONFIG_PACKAGE_libbz2=y
CONFIG_PACKAGE_libcurl=y
CONFIG_PACKAGE_libgd=y
CONFIG_PACKAGE_libiwinfo-lua=y
CONFIG_PACKAGE_libjpeg=y
CONFIG_PACKAGE_liblua=y
CONFIG_PACKAGE_liblucihttp=y
CONFIG_PACKAGE_liblucihttp-lua=y
CONFIG_PACKAGE_liblzma=y
CONFIG_PACKAGE_liblzo=y
CONFIG_PACKAGE_libmbedtls=y
CONFIG_PACKAGE_libmnl=y
CONFIG_PACKAGE_libncurses=y
CONFIG_PACKAGE_libopenssl=y
CONFIG_PACKAGE_libopenssl-conf=y
CONFIG_PACKAGE_libpcap=y
CONFIG_PACKAGE_libpcre=y
CONFIG_PACKAGE_libpng=y
CONFIG_PACKAGE_libreadline=y
CONFIG_PACKAGE_librt=y
CONFIG_PACKAGE_libsmartcols=y
CONFIG_PACKAGE_libtirpc=y
CONFIG_PACKAGE_libubus-lua=y
CONFIG_PACKAGE_libustream-openssl=y
CONFIG_PACKAGE_libyaml=y
CONFIG_PACKAGE_lscpu=y
CONFIG_PACKAGE_lsof=y
CONFIG_PACKAGE_lua=y
CONFIG_PACKAGE_luci=y
CONFIG_PACKAGE_luci-app-ddns=y
CONFIG_PACKAGE_luci-app-firewall=y
CONFIG_PACKAGE_luci-app-ntpc=y
CONFIG_PACKAGE_luci-app-openvpn=y
CONFIG_PACKAGE_luci-app-opkg=y
CONFIG_PACKAGE_luci-app-vnstat=y
CONFIG_PACKAGE_luci-app-watchcat=y
CONFIG_PACKAGE_luci-app-wireguard=y
CONFIG_PACKAGE_luci-app-wol=y
CONFIG_PACKAGE_luci-base=y
CONFIG_PACKAGE_luci-compat=y
CONFIG_PACKAGE_luci-lib-ip=y
CONFIG_PACKAGE_luci-lib-ipkg=y
CONFIG_PACKAGE_luci-lib-jsonc=y
CONFIG_PACKAGE_luci-lib-nixio=y
CONFIG_PACKAGE_luci-mod-admin-full=y
CONFIG_PACKAGE_luci-mod-network=y
CONFIG_PACKAGE_luci-mod-status=y
CONFIG_PACKAGE_luci-mod-system=y
CONFIG_PACKAGE_luci-proto-ipv6=y
CONFIG_PACKAGE_luci-proto-ppp=y
CONFIG_PACKAGE_luci-proto-relay=y
CONFIG_PACKAGE_luci-proto-wireguard=y
CONFIG_PACKAGE_luci-ssl-openssl=y
CONFIG_PACKAGE_luci-theme-bootstrap=y
CONFIG_PACKAGE_ntpclient=y
CONFIG_PACKAGE_openssl-util=y
CONFIG_PACKAGE_openvpn-easy-rsa=y
CONFIG_PACKAGE_openvpn-openssl=y
CONFIG_PACKAGE_perl=y
CONFIG_PACKAGE_perlbase-base=y
CONFIG_PACKAGE_perlbase-bytes=y
CONFIG_PACKAGE_perlbase-class=y
CONFIG_PACKAGE_perlbase-config=y
CONFIG_PACKAGE_perlbase-dynaloader=y
CONFIG_PACKAGE_perlbase-errno=y
CONFIG_PACKAGE_perlbase-essential=y
CONFIG_PACKAGE_perlbase-fcntl=y
CONFIG_PACKAGE_perlbase-filehandle=y
CONFIG_PACKAGE_perlbase-getopt=y
CONFIG_PACKAGE_perlbase-io=y
CONFIG_PACKAGE_perlbase-list=y
CONFIG_PACKAGE_perlbase-net=y
CONFIG_PACKAGE_perlbase-posix=y
CONFIG_PACKAGE_perlbase-scalar=y
CONFIG_PACKAGE_perlbase-selectsaver=y
CONFIG_PACKAGE_perlbase-socket=y
CONFIG_PACKAGE_perlbase-symbol=y
CONFIG_PACKAGE_perlbase-tie=y
CONFIG_PACKAGE_perlbase-time=y
CONFIG_PACKAGE_perlbase-xsloader=y
CONFIG_PACKAGE_relayd=y
CONFIG_PACKAGE_rpcd=y
CONFIG_PACKAGE_rpcd-mod-file=y
CONFIG_PACKAGE_rpcd-mod-iwinfo=y
CONFIG_PACKAGE_rpcd-mod-luci=y
CONFIG_PACKAGE_rpcd-mod-rrdns=y
CONFIG_PACKAGE_snapshot-tool=y
CONFIG_PACKAGE_socat=y
CONFIG_PACKAGE_softethervpn-base=y
CONFIG_PACKAGE_softethervpn-server=y
CONFIG_PACKAGE_stubby=y
CONFIG_PACKAGE_stunnel=y
CONFIG_PACKAGE_tar=y
CONFIG_PACKAGE_tcpdump=y
CONFIG_PACKAGE_terminfo=y
CONFIG_PACKAGE_uhttpd=y
CONFIG_PACKAGE_unzip=y
CONFIG_PACKAGE_vnstat=y
CONFIG_PACKAGE_vnstati=y
CONFIG_PACKAGE_wakeonlan=y
CONFIG_PACKAGE_watchcat=y
CONFIG_PACKAGE_wget=y
CONFIG_PACKAGE_wireguard-tools=y
CONFIG_PACKAGE_wpa-supplicant-mesh-openssl=y
# CONFIG_PACKAGE_wpad-basic is not set
CONFIG_PACKAGE_xz=y
CONFIG_PACKAGE_xz-utils=y
CONFIG_PACKAGE_zlib=y
CONFIG_PERL_NOCOMMENT=y
CONFIG_PERL_THREADS=y
CONFIG_SOCAT_SSL=y
CONFIG_STRIP_KERNEL_EXPORTS=y

Both versions compiled from this repo