New user Edgerouter X installation

A long time DrayTek Vigor user, I wanted to check out OpenWrt. I have a couple of Edgerouter X's lying around so thought I would try the install on one of those. I don't have a suitable machine on which I can build the image myself (I tried on a Pi3....) so used the pre-built image on the stman GitHub.

I must have done something wrong as the resultant install is unusable. When I try to install anything it tells me I have 0kb available to install anything and this is the df output:

Filesystem 1K-blocks Used Available Use% Mounted on
tmpfs 127104 780 126324 1% /tmp
tmpfs 512 0 512 0% /dev

...which doesn't look at all right to me.

I am also getting the "SSL support not available" error, but can't do anything about it given that I can't install anything.

It sort of feels like I am in a "semi-bricked" state....but I am very sure I have done something daft, so hoping someone can lead me towards the light...

tmptfs (and by extension /tmp) is RAM based. If that's all you see, my guess is that you've got the initramfs version running but not yet a normal/persistent install.

Run an upgrade with the proper sysupgrade firmware image and it should install completely.

I tried that before posting, but I can't see how to get the upgrade image onto the router. I can't scp to it and can't wget.....
I fully appreciate that I am definitely missing something fundamental here....

are you using ssh right now to get into it? scp should work if ssh does.

This is s a fully supported model; there are official builds at the OpenWrt site. No need for a third-party build.

In the light of what @mk24 just mentioned, I would restore the stock firmware (that can easily be done via TFTP, see here) and then install an official OpenWrt build. Back to stock as well as OpenWrt installation worked fine the last two times I tried it (about a year ago or so).

This is what I am working on right now...bit of a faff but doable.