New Ubiquiti UAP-LRv2 not supported, 'Invalid version' issue - please help for support on this new device?

I have bought a new Ubiquiti UAP-LR v2 wifi device. I have tried flashing the following:

  1. The software on this page from openwrt:
  2. The software on this page from latest LEDE:

following the instructions, I flashed lede-17.01.0-r3205-59508e3-ar71xx-generic-ubnt-unifi-squashfs-factory.bin with, after i type "cat nohup.out" i get the error:
Invalid version 'BZ.ar934x.v6.0.0-OpenWrt-r3205-59508e3'

Please can any developer help with this issue? If im not mistaken, it seems as if this latest software is not supported for the new UAP-LR v2 - is it possible to make a small adjustment and repackage .bin file so that it works on UAP-LR v2 ??

According to Ubiquiti website UAP-LR v2 is code U7E, and not BZ.


Can I ask you, did you find a solution how to install OpenWRT on UAP LR v2 ?
I have the same problem, before it had firmware version 3.2.6 by default, now they released V2 with version 3.7.*

And I am getting same issue

Can you please let me know if you found solution. Also I am interested to install OpenWRT on UAP AC range.



Hi @rnicolaev

I knew i wasnt the only one with this issue. Unfortunately i took the device back. Im going to purchase a device with less complications, most probably NOT from ubiquiti.

Also, i tried almost everything i knew or could to flash this device. I even tried flashing it with OLD firmware taken from so that i can be able to flash with LEDE or OpenWRT but unfortunately they have blocked this due to signature checks.

Did you see this thread ?

and this one