New TP-LINK Router: TL-WR949N(BR) Ver 5.0 - Please Identify

Hi everyone, I'm posting here some pics of this new router model that is being sold in Brazil just hoping that it is a rebranded TL-WR940N or similar since there is no official reference to this model anywhere on the tp-link website at the moment I'm writing this.

You can right click on the images and open them in a new tab to view it in full size.

Please let me know what are your thoughts.




What is the number on the flash chip? It looks like the tin shield cover is the type that can be pried off, then you can identify the SoC and RAM. Also hook up a serial cable and obtain the boot log.

If it is yet another 4/32 flash/ram size, and not sold worldwide, there won't be a lot of interest by developers. But if it is almost identical to an existing model you can often flash it by serial.

Usually they are generic worldwide HW version just with different firmware.
You just gotta figure out which one

Thanks guys, I was able to remove the thin shield cover and here are some pics.



Just like I thought it is basically WR940N v6 with different firmware

Awesome!!! Does that mean that I can flash it via the web interface or does it have to be via serial interface (I have no experience with that)?

Found this:;a=commit;h=7f75961e381540aa0434a12732908475de946cdf

Wrong thing,I have a PR for WR940N v6 but it is not yet merged.
You can try images I built here:

I dont think that flashing from WEB UI will work as most likely TP Link changed all IDs

I can't seem to rename one of your images to the correct naming convention that the router expects.
Since there is no reference at all of this model on the international or local tp-link website there is no way for me to figure out what it should be called, I keep getting error 18005, any advise?


That means that image is rejected by device.
No renaming will help.
TP Link changed hardware id and probably other stuff.

Is there GPL available?

The WR949N isn't listed anywhere on all tp link websites worldwide that I checked, is there anything that I can do to help you out on prepping an image for this router?

The only thing close to the WR949N that could help out.

Well,you can contact TP Link.
I can try couple of combos for hwid but its hard to guess

Will do and get back to you as soon as I hear from them.
Thank you

Have you tried TFTP flashing?

Just tried a few times but can't get the router to boot in download mode for the life of me (first timer here).
Tried to start it pressing the reset for 3 seconds, pressing reset for a while, holding the WPS button, no matter what it always starts in "normal" mode and thus doesn't trigger the firmware download, tftpd shows no activity at all, any tips?
Thank you


You gotta hold reset button,not WPS one.
Also,it would be much easier to use serial console for debugging purposes

Try this tutorial, which works for several TP-Link routers -

Use the wr949v5_tp_recovery.bin file.

Common issues I see when it doesn't work...

  1. TFTP server running on the attached computer does not have permissions through the firewall.

  2. Router not powered off first.

  3. Reset button not held in for at least 10 seconds after the router is powered on.

Correct, I did try with the reset button many times as well.

Thanks, that's exactly what I was doing but I'm having no such luck, even saw youtube videos and I'm doing the same thing people do but my router does not trigger the tftp server and boots up in normal mode.

  1. Open TFTP.
  2. Pick dir with firmware.
  3. Choose my LAN interface with ip ending .66.
  4. App is unblocked on the firewall.
  5. Use a pick to push the reset button.
  6. Plug the power cord.
  7. Router starts.
  8. At this point on each shot I tried holding the reset for 3, 4 seconds and forever, none made a difference.

Now here's what happens after this standard procedure, in my case:

  1. LAN connection says identifying.
  2. After a few seconds LAN connection says connected to unidentified network.
  3. After a few more seconds LAN says cable unplugged.
  4. Then again goes through the process of identifying the network.
  5. TFTP app changes the interface from the ".66" interface to "::1 Software Loopback Interface 1", by itself.
  6. Router is up and running in "normal" mode.

If TFTP activates, the LEDs on the router usually blink differently.

You can avoid the PC going from disconnected to connected by putting an Ethernet switch between the router and the PC, so the PC always has an Ethernet carrier, and Windows doesn't try to reconfigure the port while the router is booting.

If you only want to flash one of these routers (i.e. you're not trying to develop a new "factory" firmware), hook up serial(*) and flash a WR940 sysupgrade from the bootloader. It should boot being the same hardware. Then treat it as if it were a WR940 from now on.

  • From your picture it looks like as TP-Link does on many models, the connection from the RX pin (data into the router) to the CPU has been interrupted. In this case R164 makes that conection and it is missing. You probably will need to bridge the R164 solder points.

Will get a router to see if it helps on the tftp procedure, if that doesn't work I'll google about the soldering and serial method, never done anything similar before.

Will report back here, thanks!