New to OpenWrt problem assigning new IP to WD N750

This seems to be an easy issue to resolve but I am new to OpenWRT mainly work with routers on DDWRT.

I have a WD N750 that I want to set it up as a Wireless AP with VLAN support. But I can't even get past the part on changing the IP. I have done it via the web GUI 3 times and twice now in SSH, changing the /etc/config/network file. Every time I change the IP from to I lose all access to router. I am TIRED of reflashing this thing.

After changing to, I CAN ping it. I can't get the GUI nor can I SSH back in to the router.

Suggestions please! Firmware is 18.06.2

@mbze430, welcome to the community!!!

What happens when you hit "APPLY UNCHECKED" and immediately browse to the new page?

  • If you loose network connectivity, you also have to get a new IP within 30 seconds or use a static address for this procedure

(BTW, I own the same device)

1 Like

It refuses to load the page. And as I have mentioned on the OP. Even trying to access it through SSH it refuses to connect.

I read your OP...I also noted to you that I own the same device, so that you know I am aware of the issue - from experience.

Since you don't wish to clearly answer my question, try this:

  • Edit and save /etc/config/network
  • Exit the editor
  • Reboot, do not attempt to apply configs
  • Restart networking on the laptop used

This should ensure that the Ethernet is returned to the laptop, and that it's getting DHCP, from a router with a new local IP.

  • I also surmise that you are aware - when you changed the IP to, that you'd now access the router at
1 Like

As they say, pictures are worth of thousand words. Hopefully, this is enough so I don't have to keep repeating myself

  • Can you explain how an eth0.3 got defined?
  • Can you explain why you've changed MAC addresses?
  • You have an odd setup, where you define a VLAN 2, but then tag it as 3
  • You also seem to have edited tagging on the Switch

Can you reset the router to defaults, then retry?

Then, if you have a VLAN tagging use case, we can handle it after your renumbering of the router IP on VLAN 1.


Also there is wan_dev on eth0.2 for some reason.

After you reset as @lleachii advised, I suggest that you stick to editing VLANs through the GUI to avoid incoherent configuration, until you are more familiar with the settings.

Screenshots are good, but when the content is essentially text, I think copying the text and formatting it with the Pre-formatted text tool is better; it's easier to read, searchable, possible to quote, and it also helps with saving the storage resources.

1 Like

Actually I already have configured the router to a Wireless AP. I took an hour break from the N750, cause I was about to throw it against the wall. But after I came back to it, I tried to access the web GUI from, it just magically worked. (SSH also magically worked)

As to why there is a 'eth0.3' I was preparing to make two VLANs vlan1 and vlan3 and I already had all that setup. The only thing I couldn't get to work was setting the IP to that was either before I even started to set up the VLANs. I'd figure eventually I would get it to change and work.

Now I just have to learn how to disable port 2/3/4 and the WAN port and then just setup firewall rules so the two bridged VLANs don't accidentally talk to each other.

But yeah once I got the IP working it only took me like 10mins to configure the VLANs to work.

1 Like

Well, @lleachii mentioned, you have

config switch_vlan
    device 'switch0'
    option vlan '2'
    option ports '0t 1t 5'
    option vid '3'

See, for the same vlan, you have vlan 2 and vid 3.

Also for option ports, you have 1 untagged for vlan1 and tagged for vlan2. It was unclear what you were trying to do.

Also you have interface 'wan' with option ifname 'eth0.3' and interface 'wan_dev' with option ifname 'eth0.2'. The number after the dot refers to the VLAN, so if you have 2 and 3 for WAN, then you better avoid using the same number for your LAN VLANs.

That can be conveniently done from


Note that the numbering of the LAN ports in /etc/config/wireless don't necessarily match the port number indicated on the body of the router. If you are going to turn them off, it's safer for you to do that through the GUI so that you see which ports you are actually turning off and avoid locking yourself out.


(I forgot to post this saved draft.)

@Hegabo covered most of it:

Looking more closely, it seems you may wish to make LAN on the N750 to be numbered VLAN 3 instead of VLAN 1. And, per another thread, create a trunk port to a Netgear device.

If so:

  • Edit /etc/config/network so that all instances of LAN as eth0.1 are eth0.3
  • From there in the same file, change switch settings of VLAN 1 to VLAN 3
  • Reboot
  • Then you can easily create a tagged port in LuCI in Network > Switch (NOTE: the ports may be numbered in reverse, use the GUI connected/disconnected icon to verify the port in real-time) by changing it from untagged to tagged

I couldn't actually tell if you are replicating the configs of a Netgear, or trying to trunk to it.

  • If you simply want to make different SSIDs, you'd make a copy of the LAN, rename it and use (e.g.) eth0.3. Then proceed for each SSID. Add to correct Firewall Zones (as desired).
  • If you simply want to make different SSIDs, you'd make a copy of the LAN, rename it and use (e.g.) eth0.3. Then proceed for each SSID. Add to correct Firewall Zones (as desired).

That's exactly what I just need. As soon as I get back in the office I will add the firewall and turn off the additional ports. Sent from MailDroid

1 Like

No problem, I would be remiss if I didn't note that, you also need to make a copy/duplication of the LAN section of /etc/config/dhcp too - in order to hand out dynamically-assigned IPs on the new Local Networks/Guest SSIDs.

all the DHCP/DNS is handled by Windows Server 2018. This N750 is just a "dumb" AP.

1 Like

To set up an additional guest AP that is completely detached from the OS, make a bridge interface with proto Unmanaged (or 'none' in the config file). Place the wifi AP and the Ethernet VLAN in this bridge. Traffic on that network can't interact with any IP-based router services since it has no IP address.

@mk24 yes I already know that