New to OpenWrt: OK to install Snapshot build on Netgear WAX206?

Hi folks! I've migrated from dd-wrt and have a Netgear WAX206 arriving tomorrow. I confirmed it was supported on the hardware board before purchasing. However, it appears the only (?...or, current?) supported firmware is "snapshot" (i.e., dev version).

Would somebody please advise if there's an older version of the published firmware that I could use instead? Or must I use the dev builds on my WAX206 device? On that note, would somebody advise which Phase is available for this equipment?

PS: I'm OK with minimal to ~moderate coding but prefer a GUI. I anticipate needing to adjust only a few features.

Thanks!! :slight_smile:

1 Like

Snapshots don't include the LuCI web interface, but you can easily install it...Read the link for instructions how to install Luci, which is not installed by default in snapshots.

Also keep in mind that snapshots are 'moving targets' in terms of installing packages. In some cases, you may be unable to install new packages as early as 24-48 hours after you've downloaded the snapshot (depending on what changes). More info about that here:

When you get the message “Cannot satisfy the following dependencies for…” it is most likely because you installed a snapshot version of OpenWrt.
Read here for possible solutions.

Finally, you can actually request a snapshot image with LuCI and/or other packages installed using the online image builder that is part of


Nice choice the Netgear WAX206. Mine is running perfectly with latest snapshot (as an AP)
There's a lot of help from all these knowledgeable OpenWrt'ers around the Forum if needed.

I believe the WAX206 will be part of the next major release of OpenWrt 23.x.x .


Unfortunately, the latest snapshot softbricks the device.

I got my wax206 yesterday, uploaded the latest factory.img (see below) over the stock webUI, rebooted... and can't communicate with the device whatsoever.
I expected the device to have with an open ssh port, but:

The power led goes solid green after a while and lan1 led flashes occasionally, but I can't connect via dhcp nor static address.

Had to nmprflash stock image back.
Hoping for stable release soon...

The faulty image is:
openwrt-mediatek-mt7622-netgear_wax206-squashfs-factory.img sha256=674cb829c1df458a337eabd709092392905e840ec74a824a42a738b9834eaca9 size=11264.5 KB date=Sun Apr 23 04:31:55 2023

I didn't get a soft brick, but my WAN connection died on the latest sysupgrade -
SNAPSHOT (r22623-e1242fc339).

Someone has just committed a fix here;

I think this will fix it, but the firmware selector link above is not building using that fix yet. Wait for a newer snapshot than the r22623 I mentioned above and you should be OK.

What I normally do to get the GUI is click on the "Customize installed packages and/or first boot script" and just add "luci", or preferably also "luci-app-attendedsysupgrade", which means after installing that image, you should be able to do an attended-sysupgrade from the option in the System menu, and it will build you an image with all current packages installed.

To keep yourself out of trouble while this model is in snapshot, make sure you save versions of the factory and sysupgrade images and note whether they work or not - perhaps only keep the working ones. It is hard to go back to a previous version if you have none saved. I recently had to revert to one of the early snapshot versions manually built from the developers forum topic where the earliest builds were discussed, although things changed a bit after that so if you use one of those early builds, you probably can't keep all your settings in place when upgrading to a newer build from the last month or so.

Thanks for the info and the heads up !
I'll make sure to keep an archive of snapshots ... guess I learned this the hard way :grin:

I flashed snapshot r22649-1129b226f7 via the stock webUI today, but got still the same result - no ip connectivity on lan nor wan ports.
Wireshark only shows me some ipv6-link-local traffic, I can ping fe80::81ed:<...>%eno1 successfully, so the router isn't bricked, I just can't get any useful connectivity.

I tried resetting the router via the Reset button on the back, but no change there.
There is no difference in flashing the r22649-1129b226f7 factory.img via nmprflash or stockWebUI.
Is it possible that (mis)configuration data persists across factory.img flashes ?
Would flashing the kernel.itb image get me somewhere ?

I got root telnet access on stock firmware by using the method on the wiki.
Now I can also access luci on stock firmware.

I can also confirm that the latest snapshot does not work either. r22657-1e8b318eb
Had to restore the vendor firmware.

Update: I did get it to work. Used nmrpflash instead of the stock GUI to install OpenWRT.


hi, how does one revert to the stock firmware? I installed openwrt a couple of weeks ago, expecting something like dd-wrt, but I'm way over my head and I'm having a lot of connectivity problems lately.

is the TFTP the only way?

use the nmrpflash tool. It acts like a TFTP.

1 Like

I just bought the WAX206, but it seems I need to wait a bit still before I deploy it....

By the way, the snapshot images, are those basically 23.0x.x?

Master snapshot will be forked (soon?) into next major release 23.xx.

1 Like

Tried the latest sysupgrade snapshot from firmware builder 6 hours ago and it seems to be having problems with the WAN drivers again.

Just reverted to a build from 2023-04-14 (SNAPSHOT r22569-b8e1fcad38) that seems to work OK.

Just to get people out of trouble, I have attached a google drive link below that has that sysupgrade build and an earlier factory build. These are straight from the firmware builder page, but you are obviously trusting me to have not altered these.

The sysupgrade (SNAPSHOT r22569-b8e1fcad38) includes Luci and luci-app-attendedsysupgrade as those are the two packages I routinely get the firmware builder to add.

I believe the factory build from 2023-04-01 works OK, but I can't remember the build. The factory build definitely includes Luci but I don't remember if it includes luci-app-attendedsysupgrade. I highly doubt it includes anything else. Even if this build doesn't work 100% you can use the sysupgrade after to get to a working build.

The latest snapshots seem to be working properly due to a recent bugfix;

Fixed by;

I have left my previous Google Drive link active just in case things go wrong with snapshot builds again, as several other routers use the same chipset for the 2.5G WAN and people have been making changes frequently that have been breaking the WAX206 2.5G WAN.

I have deleted the previously mentioned files and added the latest factory and sysupgrade images from 2023-05-05 SNAPSHOT (r22734).

I have added luci and luci-app-attendedsysupgrade to both the factory and sysupgrade images.

The builder page gave me the following SHA256 sums, but you are still trusting me to have not altered them and given you bad SHA256 sums. Anyone can verify these SHA256 sums (and hence the packages in the link) are unaltered while the r22734 build is still up by adding the same two packages mentioned above and doing a build, but as the build number will increment soon, the contents and sums will change on the build page compared to these.

Factory SHA256: 93ceb20065411b1ccd141421ea9c8f07f0692b12cbd56c9f2d92d5d641dc41e6

Sysupgrade SHA256: 9482ad6bd849d496b803afe17c61d3e3872fe87be5a2f4e320bf3d7d34ca40d8


Snapshot r22746 seems to be working OK
Added r22746 Factory and Sysupgrade with Luci and Luci-app-attendedsysupgrade to GDrive link

Just installed SNAPSHOT - r22878 this morning (15/5/23). Works great!

I've had no problems with snapshots for weeks and I keep reading that 23.x is just around the corner, so stable images for WAX206 should be here within weeks or at worst a month if I'm reading things correctly.

I'm deleting the Google drive link with slightly older snapshots today as they should no longer be needed. Those builds should continue running fine for now if you are using any of them and happy to leave it running, or feel free to upgrade to the last snapshot (don't forget to add luci), or wait for stable.