New STA doesn't stay associated more than 10 secs

New IOT (Smart Dimmer Switch, FEIT) associates but disassociates 10 secs later. Any suggestions on a solution, or how to further debug? Here's the log:

Fri Jun 16 19:01:29 2023 daemon.info hostapd: wlan1: STA 70:03:9f:91:e5:88 IEEE 802.11: associated (aid 11)
Fri Jun 16 19:01:30 2023 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 70:03:9f:91:e5:88
Fri Jun 16 19:01:30 2023 daemon.info hostapd: wlan1: STA 70:03:9f:91:e5:88 WPA: pairwise key handshake completed (RSN)
Fri Jun 16 19:01:31 2023 daemon.info hostapd: wlan1: STA 70:03:9f:91:e5:88 IEEE 802.11: authenticated
Fri Jun 16 19:01:39 2023 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 70:03:9f:91:e5:88
Fri Jun 16 19:01:39 2023 daemon.info hostapd: wlan1: STA 70:03:9f:91:e5:88 IEEE 802.11: disassociated
Fri Jun 16 19:01:39 2023 kern.debug kernel: [ 2788.249489] ieee80211 phy1: staid 11 deleted
Fri Jun 16 19:01:40 2023 daemon.info hostapd: wlan1: STA 70:03:9f:91:e5:88 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Fri Jun 16 19:01:41 2023 daemon.info hostapd: wlan1: STA 70:03:9f:91:e5:88 IEEE 802.11: associated (aid 11)
Fri Jun 16 19:01:42 2023 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 70:03:9f:91:e5:88
Fri Jun 16 19:01:42 2023 daemon.info hostapd: wlan1: STA 70:03:9f:91:e5:88 WPA: pairwise key handshake completed (RSN)
Fri Jun 16 19:01:43 2023 daemon.info hostapd: wlan1: STA 70:03:9f:91:e5:88 IEEE 802.11: authenticated
Fri Jun 16 19:01:54 2023 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 70:03:9f:91:e5:88
Fri Jun 16 19:01:54 2023 daemon.info hostapd: wlan1: STA 70:03:9f:91:e5:88 IEEE 802.11: disassociated
Fri Jun 16 19:01:54 2023 kern.debug kernel: [ 2802.721149] ieee80211 phy1: staid 11 deleted

Let's see your configuration:

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Update: Being desperate, on my WRT3200ACM tried configuring Radio2's wifi-iface with same options as Radio1, but with unique SSIDs - and it worked. STA stayed connected, received DHCP association and device communicates. While promising, I've heard the 3rd radio on this platform is not recommended for use. Thus still interested in the original post here, getting STA to connect to Radio1.

That being said, here is my current configurations with the working Radio2 configuration. Any ideas why Radio1 fails, while Radio2 works? Conflicts between existing STAs?

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix '<REDACTED>'

config interface 'lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option type 'bridge'
        option ifname 'eth0.1'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'
        option auto '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

root@OpenWrt:/etc/config# cat wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option country 'US'
        option legacy_rates '1'
        option channel '100'
        option htmode 'VHT160'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid '<REDACTED-5>'
        option network 'lan'
        option encryption 'psk2'
        option key '<REDACTED>'
        option wpa_disable_eapol_key_retries '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option country 'US'
        option legacy_rates '1'
        option channel 'auto'
        option htmode 'HT40'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid '<REDACTED-2.4>'
        option network 'lan'
        option key '<REDACTED>'
        option encryption 'psk2'
        option wpa_disable_eapol_key_retries '1'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option hwmode '11g'
        option channel 'auto'
        option country 'US'
        option legacy_rates '1'
        option htmode 'HT40'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option mode 'ap'
        option ssid '<REDACTED-temp2.4>'
        option network 'lan'
        option encryption 'psk2'
        option wpa_disable_eapol_key_retries '1'
        option key '<REDACTED>'

config wifi-iface
        option device 'radio1'
        option mode 'ap'
        option ssid '<REDACTED-2.4>'
        option network 'lan'
        option encryption 'psk2'
        option wpa_disable_eapol_key_retries '1'
        option key 'dontyouwish2'
        option disabled '1'

root@OpenWrt:/etc/config# cat dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option name '<REDACTED-Host1>'
        option dns '1'
        option mac '<REDACTED>'
        option ip '192.168.1.102'

root@OpenWrt:/etc/config# cat firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

root@OpenWrt:/etc/config#

The Marvell chip in the WRT3200 is known to have problems with IOTs. There are numerous wifi issues with that chip and the WRT3200 is perhaps best used in a wired only role with separate APs. Any old ath9k device will work well with IOTs.

I see you're still running swconfig which means its an old version.

@mk24 - I see WRT3200 uses two different Marvell chip, with Radio2 being the 2nd one. Perhaps that explains why it behaves differently (better) than Radio1.

Yeah, running an old version - do you think that would improve Radio1?

According to others, newer OpenWRT may be worse for me, Radio2 is "hidden". (see https://www.reddit.com/r/openwrt/comments/adgsnr/wrt3200acm_wifi_radios/)