New router test for bufferbloat

hello everybody i test at the moment a new router for bufferbloat

linksys E8450

or rt 3200

Capture d’écran 2021-03-28 à 14.47.08

this is my bufferbloat without sqm for the moment

1 Like

and the question is ..... ?

the speed of your internet could be useful too.

1 Like

i have unfortunatly 70/20 max troughput in vdsl2

not fiber for the moment 1000/1000...

So the test does not look terrible. Sure, in upload direction there seems some low hanging fruit to harvest, so I probably would still use SQM, but I am hardly unbiased :wink:

1 Like

:wink: hello yes you are right

this a test with sqm

i'm use two instance basic on sqm like this

config queue 'eth1'
        option qdisc 'cake'
        option script 'piece_of_cake.qos'
        option enabled '1'
        option debug_logging '0'
        option verbosity '5'
        option linklayer 'ethernet'
        option overhead '44'
        option download '0'
        option upload '16000'
        option interface 'wan'

config queue
        option enabled '1'
        option interface 'br-lan'
        option download '0'
        option upload '62000'
        option debug_logging '0'
        option verbosity '5'
        option qdisc 'cake'
        option script 'piece_of_cake.qos'
        option linklayer 'ethernet'
        option overhead '44'

root@OpenWrt:~#

and my result is http://www.dslreports.com/speedtest/67844456 :stuck_out_tongue:

1 Like

if i want personalise interface i put eth0 ?

Capture d’écran 2021-03-28 à 15.46.06

or i put lan 1 lan 2 lan 3 and lan 4 like this

config interface 'lan'
        option type 'bridge'
        option ifname 'lan1 lan2 lan3 lan4'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'wan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'

root@OpenWrt:~#

because i would like test script of @dlakelan n in the future and the packet sqm work better with untick bridge interface

The DSA system makes this all more complicated. If you put eth0 it will affect all packets being transmitted whether they are transmitted towards the internet or towards the LAN.

That's not what you want. The only way to get what you want as far as I can see is to use an external switch and plug into a single port on your new device.

2 Likes

For my script one thing you can do is use WAN as your wan interface and then use veth method to connect to br-lan.

1 Like

ah ok i'm never test your method veth

because i'm playing wired

you say than play with wired in use the veth method is right ?

the script has a mini bug at the moment no ? double line with reboot i think no ?

i can test now if you want i'm download the package

and last thing my ps5 has a ipv6 but i 'm not capable obtain a ipv6PD (wan6) on openwrt and ps5
what is wrong in my config

in my box livebox 4 i have deleguation prefixe /56

thanks

(ps i can surely obtain a better translate if you want ) ^^

Yes it needs a little work but shouldn't be a deal breaker. I can probably fix that bug today as the new dog is much more relaxed these days. Thanks for reminding me.

1 Like

i don't need ipv6 for ps5 it' right , so

i disable ipv6 all in box and openwrt if i understand ?

bufferbloat magic :wink:

Capture d’écran 2021-03-28 à 16.21.00

No need to disable. IPv6 and IPv4 work at the same time just fine.

1 Like

ok same for gaming ?

just when connect my ps5 to box directly i'm obtain a ipv6 all in my console

after connect the router ipv6 is just write automatic why ?

The ps5 will get IPv6 and IPv4 and will use whatever it needs to use. Since the gaming network still uses only v4 it will use v4 but if in the future some games start to use v6 that will be good. No NAT problems!

1 Like

dak I understand but what I mean by this is that the router prevents having ipv6 when I connect to orange my pc also gets ipv6 on this site

once the openwrt router is connected i no longer have ipv6 is this a configuration problem on my part?

https://ipv6-test.com/
ipv6 orange openwrt

just i see '?' in memory is normal ?

Capture d’écran 2021-03-29 à 02.59.30

I'm lost, the OP is getting nearly 100% and A's on the test...what's the issue?

Is it assumed the user wants to enable SQM?

What happens on 19.07.7?

I haven't looked to confirm but I think this is a brand new device only supported by snapshot

Does Orange provide something bigger than /64 prefix? Does the router itself get job6?

1 Like

Yes it's a new router supported

Orange prefixed is /56

The router has ipv6upstream

So it sounds like prefix delegation isn't working for you. Maybe open a new topic for this question, or search the forum to see if you can find someone with similar issues

1 Like

hello everybody i have compared my hap ac2 with my new router rt3200 the result is amazing

let me know than you think :wink:

1 Like