New NetGear R7800 - Where to start

That appears normal. I get that same message with a successful login.

Indeed. I didn't noticed that before.

I have just installed luci-app-sqm but I got some warning but it was called an error. Should I take any action on this error/warning:

Collected errors:
* resolve_conffiles: Existing conffile /etc/config/sqm is different from the conffile in the new package. The new conffile will be placed at /etc/config/sqm-opkg.

Just look at the files in /etc/config.
You already had there a "sqm" config file, probably from trying my build, where SQM was installed. Now, when you installed it to the release build (?), opkg kindly preserved your existing settings and placed new ones into "sqm-opkg" file just in case you want to compare "new defaults" to your existing settings. No need to do anything.

Ok, but 2 questions arise:

1 - when I flashed back the origianl OpwnWrt, shouldn't it just delete all settings to default? Why was an old sqm file there?

2 - In any case, files are a bit different. One kind of points to eth0 and new one points to eth1. Is this normal?

When you use the OpenWrt sysupgrade process, you can select if you want to keep your current settings in sysupgrade or lose them. The default is to keep settings.

  • If you flash via LuCI, there is a checkbox
  • If you flash via ssh console using sysupgrade command, you need to use "-n" switch to NOT keep settings. Note that my example above there included that "-n" so that you could start with a clean slate.

The correct wan interface depends on the router. Look at your interface settings. The global SQM package's default is "eth1", while in R7800 wan is normally "eth0.2", so my R7800 firmware presets SQM for eth0.2. That SQM interface setting is one the small changes that I implement in my build to make the included packages fit R7800 as well as possible.

But as you now use the default release and re-installed the SQM package with global defaults, those defaults show up in the "new file".

Ok, but in my case I don't have eth0.1 and eth0.2. I have eth0 and eth1.

My wan is on VLAN 12 which was what I had in my ISP router. Not sure if we're talking about the same thing.

Anyways, I ran a DSL report and for the first test I got like C F A and the last result was just a '-'. Then I tried to repeat the test several times but I couldn't get any more results. Now, at least the last 2 are '-'. The others are 'D'.

The it is likely eth0.12, or is it. ?
Just check from the interface settings for LuCI overview screen, or wherever.
Like this:

Sounds like you have not configured SQM at all, it is possibly either disabled, has totally wrong speed limits or points to wrong interface (eth1).

In VLAN settings, I configured it like this, accordidng to my ISP router:

But as I was saying, my 2 sqm files contents are:

config queue 'eth0'
option enabled '0'
option interface 'eth0.2'
option download '85000'
option upload '10000'
option qdisc 'fq_codel'
option script 'simple.qos'
option qdisc_advanced '0'
option ingress_ecn 'ECN'
option egress_ecn 'ECN'
option qdisc_really_really_advanced '0'
option itarget 'auto'
option etarget 'auto'
option linklayer 'none'


config queue 'eth1'
option enabled '0'
option interface 'eth1'
option download '85000'
option upload '10000'
option qdisc 'fq_codel'
option script 'simple.qos'
option qdisc_advanced '0'
option ingress_ecn 'ECN'
option egress_ecn 'ECN'
option qdisc_really_really_advanced '0'
option itarget 'auto'
option etarget 'auto'
option linklayer 'none'

And yes, for now SQM is yet disabled. I want to run a test before I enable it so that I can check differences.

This was my last test result but I've been trying testing over and over again until I get some grades.

Another test

Those lines need t match your wan interface and speeds.

Maybe eth0.12 (check settings, so far you have only shown .12 as the VLAN),
and speeds might be
185000 down
90000 up

(Currently you have horrible ping latency of some 50-250 ms)

Where do I find that IPv4 Upstream you show in the image you posted?

My internet speed should be 200Mbits/100Mbits. I have already re-rated in DSL reports site.

I just changed some settings in DSL reports as seen in a thread from this forum.
Test time: 30 sec
number of streams: 16

And the result couldn't be worse. lol

On the main status page. It should be eth0.12, which is what needs to be set as the interface in the SQM config. Also you need to change enabled from 0 to 1.

In the line config queue eth0, eth0 is just a friendly name you can change it to something that makes more sense like 'wan'

I still don't have SQM enabled. I'm only trying to figure out configurations prior to enabling the feature.


Edited 2;
The file being changed when I change any configuration for SQM is /etc/config/sqm. The other file that was created/downloaded when I installed luci-app-sqm is not being chnaged.

@HelloShitty You can name the interfaces whatever you want. :sunglasses: I’ve kept it to the default. This is what SQM setup looks like via GUI (just replace the interface name toggle with your WAN interface name - inputted 90% of your speed as a starting point):

image image

Yes, I have that too. I did some changes suggested in OpenWrt docs.

This is how I have my /etc/config/sqm

config queue
	option debug_logging β€˜1’
	option verbosity β€˜5’
	option squash_dscp β€˜1’
	option squash_ingress β€˜1’
	option ingress_ecn β€˜ECN’
	option egress_ecn β€˜NOECN’
	option interface β€˜eth0.12’
	option download β€˜180000’
	option upload β€˜90000’
	option qdisc β€˜cake’
	option script β€˜piece_of_cake.qos’
	option qdisc_advanced β€˜1’
	option qdisc_really_really_advanced β€˜0’
	option enabled β€˜1’
	option linklayer β€˜ethernet’
	option overhead β€˜44’

By the way, which file should I replace the default DNS servers? I want to try different ones other than ISP defaults. I can see in luCI DNS Forwardings and in Docs I see this option but also DNS Provider.

Which should be the file to change? I tried to add Cloudflare DNS to luCI in DNS Forwardings but it is not the result I expected. At least I tried to check in some site what was the DNS server in use and it still detected my ISP's one!

Here is a solid write up on the right way to do it:

1 Like


In fact I think I did it in much less steps. I don't question how it was done there but I don't want to change so many things at a time.

I just went to '/etc/config/network' and under wan I added:

list dns '<IPv4>'

And the same for 'wan6' with the mathing IPv6 ip's.

Then I added

option peerdns '0'

also for both 'wan' and 'wan6'.

Speed test get better with the tweaks?

Still haven't tested. Waiting for wife and daughter to head to bed and then I'll disconnect all devices from wireless and will test. That's how I conducted the first tests.

Well, after setting Download/Upload thresholds in SQM to 90/90 of what my ISP says that I should get (200/100), I get this result:


I'm a little disappointed with speed but that thing of bufferbloat seems to have improved.
Also, I'm should be checking latency. Where do I check that?


I guess I messed up previous tests.
Links are no longer available. Crap. Did anyone saved those images?

Edited 2;
I tried to install ddns-scripts to be able to use dynamic DNS services but I got this output from

opkg install ddns-scripts
# opkg install ddns-scripts
Installing ddns-scripts (2.7.8-12) to root...
Configuring ddns-scripts.
root@OpenWrt:~#  030047  WARN : Service section disabled! - TERMINATE
030047  WARN : Service section disabled! - TERMINATE

Expected output as long as you have not configured the ddns service.
Doing config manually by editing etc/config/ddns is possible, but might be easier in LuCI with luci-app-ddns installed.