New NetGear R7800 - Where to start

The speed is based on the top speed vs others on the same technology, in the same country:

top 2% - A+
top 10% = A
top 20% - B
top 50% - C
top 80% - D
otherwise : F

Note that whether the grade is "good" or "bad" is open to interpretation. Higher speeds and therefore higher grades generally cost more. You may get an "A" or "A+" and be paying too much. You may get an "F" and yet have a good value connection.


The chart on the results page is where it graphs the bufferbloat latency:

I would try out fq_codel + simplest and turn off the advanced settings. See how your results compare. With more aggressive CPU settings the r7800 I can get it to shape up to ~500mbps with fq_codel. I can only get ~low 200’s with cake.

1 Like

The latency is the bufferbloat timings we see in DSL reports? What about ping time we usually see in these kin of tests?

@ACwifidude I'll have to try that latter. I want to conduct all testing under the same conditions. Meaning, no wireless devices consuming bandwidth during the test. So, I'll run that later.

A post was split to a new topic: R7800 on 19.07.2 - LuCI running really slow

Previous response from ACwifidude is pretty well detailed and complete about speed, so just adding to that for my part.

I'm shaping very low bandwidth and for me, I don't think that it makes alot of changes from the base. But I subjectively find the router itself to be more responsive. Got me from A to steady A+ everywhere most of the time. Except when I post the results :wink: .


Since I did bad trying hnyman's firmware, I'm not very afraid of trying anything. I'm very afraid of losing internet access because of my daughter's classes in the morning. Anyway, I think these settings won't make me lose connectivity to the router, I hope. I mean the SQM settings and the setting - 35 for up_threshold and 10 for sampling_down_factor. Hope they don't make me lose wireless connectivity.

I'm going to read about that threshold and sampling down factor.

Ok peeps, I tried to configure ddns service but I'm not feeling confident that it is correctly configured.
Can you please give me a hand on this:

config ddns 'global'
option ddns_dateformat '%F %R'
option ddns_loglines '250'
option upd_privateip '0'
config service 'myddns_ipv4'
option lookup_host ''
option domain ''
option username ''
option password '******************'
option interface 'wan'
option ip_source 'network'
option ip_network 'wan'
option service_name ''
config service 'myddns_ipv6'
option update_url 'http://[USERNAME]:[PASSWORD][DOMAIN]&myip=[IP]'
option lookup_host ''
option domain ''
option username 'your_username'
option password 'your_password'
option use_ipv6 '1'
option interface 'wan6'
option ip_source 'network'
option ip_network 'wan6'

What else do I need to change? My ddns provider is (free)

I read a couple of things about not being able to use '-' in the config file. I'm not using one. But I feel a lot is missing here.

Ok, I gave up on because apparently it doesn't support IPv6. So from the available ones in the Docs, which one you guys recommend?

Is duckdns related to DuckDuckGo?

no-ip does support IPv6, just OpenWrt's ddns-scripts don't know about it.

hum, ok, so info in the Docs looks a bit misleading. At least to me!.

Anyways, I said I gave up on, but I guess I'll stick with it for now, until I don't get along with the setup.
Later, maybe I choose another one.

Also, I went to github for the latest /etc/config/ddns version and they say there to not use that file but a copy of it because all lines started with # and empty lines will be removed, as will be the options that I eventually set (uncomment) and they are already the default ones. I don't understand what they mean with "use a copy of this file". How will that change things? The content will be the same if I create a copy of the file.

Nevermind, I got it.

I have tried to install ddns-scripts_no-ip_com and the first time I got an error, then I tried again and looks like it installed with no problems.

What happened???

# opkg install ddns-scripts_no-ip_com
Installing ddns-scripts_no-ip_com (2.7.8-12) to root...
Configuring ddns-scripts_no-ip_com.
Parse error (invalid command) at line 84, byte 1
Parse error (invalid command) at line 85, byte 1
uci: Parse error (invalid command) at line 84, byte 1
root@OpenWrt:~# opkg install ddns-scripts_no-ip_com
Package ddns-scripts_no-ip_com (2.7.8-12) installed in root is up to date.

I finally managed to get this working. But I still have a question. I'll first state how I managed to make it work and then I'll ask the question.

1 - Install ddns-scripts

opkg install ddns-scripts

2 - Install additional package if needed ( needs)

opkg install ddns-scripts_no-ip_com

3 - Replace file /etc/config/ddns-scripts with the most recent version from OpenWrt Github here.
Also keep the original name, just in case. I'm not sure if you can change the name.

4 - Change the following lines containing the following settings accordingly (downloaded file from step 3 is from 30/04/2020)

  • Line 66
    config service "noip_ddns"
    (service cannot contain white-spaces or dashes "-" or "@" ":" "!" or other special characters).

  • Line 73

option enable "1"
  • Line 79
option use_ipv6 "0"
  • Line 86
option interface "wan"
  • Line 107
    Comment it out. This is only needed if an upate script is not provided by OpenWrt. NoIP script is provided, so not needed.
#option service_name ""
  • Line 115
    Remove hash symbol. Uncomment. This is the location of the update script for NoIP, provided by OpenWrt.
option update_script   "/usr/lib/ddns/"
  • Line 127
    This is where you place the "url" so to speak, that you chose in your NoIP account to be pointed to by the IPs your PC is assigned with. For instance ""
option domain ""
  • Line 131 and 135
    These are self explanatory. Your NoIP login credentials.

Last but not the least, restart ddns service with:

/etc/init.d/ddns restart

You can check it it is working by ping your from outside your local network and see if it gets 0% loss.

I hope I'm not alone already in this thread...

Is it possible to check if I have correctly setup SSL for my DDNS service?

I already have 'wget' and 'curl' installed, I suppose from the stock firmware. So I just enabled the option

option use_https "1"
inside /etc/config/ddns and restarted the service. The path to default certs.pem file was already in the config file.

Can I check somehow if my DDNS service is using SSL?

Are there any traces in the logs? Maybe it tells you where it connected?

If not then one way possible to check is to create a firewall rule to block tcp port 80 from any_zone to wan. Then I would trigger the DDNS service to see if it succeed updating your ip. Don't forget to unblock 80 afterwards.


Which log?

logread -f

And would that be right after restarting DDNS service or when? I want to avoid messing with the firewall because I don't feel comfortable with it and I can't afford to mess it up and lose internet connection.

@DjiPi, what logs should I look in and when? About the DDNS traffic?

There is a section about monitoring trough the logs in the Wiki. You need to enable the logs (if the doc is still up-to-date).

From your configuration file, standard logging should occur in /var/log/ddns/myddns_ipv4.log and /var/log/ddns/myddns_ipv6.log. These are your config service '***' entries.

Maybe you need to manually set option use_syslog '1' (in config service '***'), then set it to 3 after you are done debugging.

1 Like

Hello @DjiPi.

I have used the sample config file from github. It's supposedly a newer version of this file.

So It may be a little bit different than what I posted in post #68 you mentioned.

I have these files in /var/log/ddns:


But only the last one has today's date, so I think the other files are from previous failed attempts of me trying to configure the service as they have older dates.
In this last file this is what I can see with

tail -f /var/log/ddns/noip_ddns.log
220740       : Detect local IP on 'network'
220740       : Local IP '' detected on network 'wan'
220740       : Waiting 600 seconds (Check Interval)
221740       : Detect registered/public IP
221741       : #> /usr/bin/nslookup  >/var/run/ddns/noip_ddns.dat 2>/var/run/ddns/noip_ddns.err
221741       : Registered IP '' detected
221741  info : Rerun IP check at 2020-05-07 22:17
221741       : Detect local IP on 'network'
221741       : Local IP '' detected on network 'wan'
221741       : Waiting 600 seconds (Check Interval)

I can't see anything related to SSL being used. What else can I do?

Do you have these lines in your config:

option use_syslog  "1"
option use_logfile "1"

The second line, I have it since the very beginning the ddns service.
The first line I changed it today and reloaded ddns service. Should I restart the service instead?

Is there anything now in the system logfile?

I'm back here.

When am I supposed to find anything there related to DDNS with SSL? Do you have idea of what kind of lines I am supposed to find? I have no idea what to look for!