New Nanopi r1 OpenWrt 22.03.2 no ip

I have the same problem with my Nanopi R1.

The red system led is blinking (heart beat), but the green leds for LAN and WAN stay off. On the WAN interface there is no DHCP request for an IP and I can't get an IP on the LAN interface.

The sdcard image for 21.02.5 boots and works as expected, but not the sdcard image for 22.03.2. With the latter seems something fundamentally wrong. I tried the standard image and a customized version from the firmware selector - both fail to boot. Also the snapshot version fails to boot, too.

Is there any chance to get a working sdcard image for the Nanopi R1?

1 Like

There's a patch on the link below , if you can try it and add your experience to get it in official builds.

I haven't a build environment, so no chance to try it. Sorry.

In the meantime I tried the 22.03.2 images for the ZeroPi (very similiar to the NanoPi R1). Same results = no booting, no IP on the lan side.

It's a pity, I like both devices, because they have a low power consumption (less than 2 W/h for my 50/10 internet plan).

Can someone confirm that this this topics problem is fixed in 22.03.3?

nanopi r1 22.03.3