New Modem As Bridge with Linksys WRT1900ACV2 Router

Hey guys, my parents recieved a new modem from AT&T so I need to reconfigure their network.

The old setup was an Arris surfboard as a modem connected to a Linksys WRT1900ACV2 which had ip

The new modem is a AT&T Arris BGW210 combo modem/router. I had to manually configure it into bridge mode doing the following:

  • change modem ip to difference subnet setting it to originally from
  • disable both firewall and packet filtering
  • set IP Passthrough to the MAC of my router
  • disabled modems radios

I then plugged my router into the modem with factory settings (DHCP and an ip of While DHCP seems to work I cannot properly access or ping the modem in my network. So I checked the DHCP address and it was incorrect. The modems wan is (99.x.x.x).

So I flashed open WRT on the router but ran into snags. How do I configure OpenWRT with my setup?

Current OpenWRT Settings:
Lan: static ip at 192.168.1
Wan: DHCP client with correct MAC address (no ipv4 address but I believe this should show up as as I had configured before)

lan at target

nothing else. I believe route should have wan but I’m unsure what it should be. I know I can ssh into the router then vim into /etc/config/network and edit the route config there to something like

// in etc/config/network
config route
       option interface ‘wan’
       option target ‘’
       option gateway ‘’

Any suggestions welcome! Thanks in advanced

Nevermind I figured it out.

I had to change the WAN interface to the following:

static protocol
ipv4: (just a random number I picked)
ipv4 subnetmask:
ipv4 gateway:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.