New install - openwrt & GL.iNet GL-AR750

SYSTEM
hostname OpenWRT
Model GL.iNet GL-AR750
Architecture Qualcomm Atheros QCA9533 ver 2 rev 0
Target Platform ath79/generic
Firmware Version OpenWrt 23.05.0 r23497-6637af95aa / LuCI openwrt-23.05 branch git-24.073.29889-cd7e519
Kernel Version 5.15.134

Before I could get the VPN portion working, another saga thanks to my VPN provider. I had this working as a small travel router. Radio0 could connect to target network, in this case my home. Radio1 is what my device(s) connect to.

After dealing with the VPN provider, they supplied fully configured ovpn files, etc..

Now, I come to a routing issue,once I got the correct opvn/conf file(s) uploaded to the router, and was able to get the cpn to start.

From the router itself, I can ssh into it, and run "ping google.com" and "ping duckduckgo.com", and the routing seems okay.

With the VPN running, the connected device(s) no longer have access to the internet.

Not sure what info I would need to show here for assistance.

In searching the forums, I stumbled across this to get some outputs;

uci show network; uci show firewall; ip -4 addr; ip -4 ro; ip -4 ru

The vpn enabled link is; https://pastebin.com/BQY3nJYg

The non-vpn enabled link is; https://pastebin.com/kXiu9wqZ

Thank you for any assistance.

Hey m8,
See step 4. https://openwrt.org/docs/guide-user/services/vpn/openvpn/client-luci

You need to add your tun0 interface to the wan zone (in firewall config) so traffic can get forwarded out.

You can also look at step 6 the kill switch option.