Networking Issues on Itus Networks Shield

First, forgive the (probably) naive questions to follow. I've looked, but you know how it can be.

Some background:
I've never really used OpenWRT. Ubuntu tends to be my base of choice for Linux things. I've got an Itus Networks Shield box and have compiled, from source, a working and booting OpenWRT build.

However, I cannot get it to do anything. At this point, I'm only looking to get network connectivity and then I can move on to other issues. The box ID's eth0/eth1/eth2/br-lan/loop, assigns Eth1 to WAN and Eth0 to LAN. I can set the /etc/config/network (though the WAN link never does get a DHCP address) so that LAN link takes an IP (either via /etc/config/network or via ifconfig commandline).

I'm unable to ping either my upstream Gateway or the 8.8.8.8 Google DNS IP.

Any suggestions on how to address this?

ifconfig output:

br-lan    Link encap:Ethernet  HWaddr 2C:26:5F:80:04:A4                                                                                                         
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0                                                                                        
          inet6 addr: fd08:d337:9ce1::1/60 Scope:Global                                                                                                         
          inet6 addr: fe80::2e26:5fff:fe80:4a4/64 Scope:Link                                                                                                    
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                                                                                                    
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0                                                                                                    
          TX packets:17 errors:0 dropped:0 overruns:0 carrier:0                                                                                                 
          collisions:0 txqueuelen:1000                                                                                                                          
          RX bytes:0 (0.0 B)  TX bytes:2518 (2.4 KiB)                                                                                                           
                                                                                                                                                                
eth0      Link encap:Ethernet  HWaddr 2C:26:5F:80:04:A4                                                                                                         
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                                                                                                    
          RX packets:5 errors:0 dropped:2 overruns:0 frame:0                                                                                                    
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0                                                                                                 
          collisions:0 txqueuelen:1000                                                                                                                          
          RX bytes:481 (481.0 B)  TX bytes:2664 (2.6 KiB)                                                                                                       
                                                                                                                                                                
eth1      Link encap:Ethernet  HWaddr 2C:26:5F:80:04:A5                                                                                                         
          inet6 addr: fe80::2e26:5fff:fe80:4a5/64 Scope:Link                                                                                                    
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                                                                                                    
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0                                                                                                    
          TX packets:612 errors:0 dropped:0 overruns:0 carrier:0                                                                                                
          collisions:0 txqueuelen:1000                                                                                                                          
          RX bytes:0 (0.0 B)  TX bytes:203560 (198.7 KiB)                                                                                                       
                                                                                                                                                                
lo        Link encap:Local Loopback                                                                                                                             
          inet addr:127.0.0.1  Mask:255.0.0.0                                                                                                                   
          inet6 addr: ::1/128 Scope:Host                                                                                                                        
          UP LOOPBACK RUNNING  MTU:65536  Metric:1                                                                                                              
          RX packets:376 errors:0 dropped:0 overruns:0 frame:0                                                                                                  
          TX packets:376 errors:0 dropped:0 overruns:0 carrier:0                                                                                                
          collisions:0 txqueuelen:1000                                                                                                                          
          RX bytes:27184 (26.5 KiB)  TX bytes:27184 (26.5 KiB)

/etc/config/network output:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd08:d337:9ce1::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'     
        option ifname 'eth1'
        option proto 'dhcpv6'
  • Find which interface is eth1, that's WAN
  • Find which interface is eth0, that's LAN; and you can access the web GUI!
  • Then you can configure the other ports in a LAN bridge.

The ports are all labelled, so it isn't an issue with which wire goes where.

Link lights are on. Physical ports are working as they should. The box houses 3 firmware bin files, selected by the 3-position switch on the front. So the stock Router and Bridge positions (provided by Itus) work as intended. The Gateway position never did work correctly, so I've loaded the stock OpenWRT there. It has to be a software configuration issue, but I've not been able to track it down.

I appreciate the suggestions!

They could be reversed. They are on most devices (oddly).

OpenWrt didn't label em.

1 Like

If I pull the wire from eth1:
[ 5427.453741] eth1: Link down

Plug it back in:
[ 5439.741768] eth1: 1000 Mbps Full duplex, port 1, queue 1

That's the WAN port according to the /etc/config/network file.

config interface 'wan'
option ifname 'eth1'
option proto 'dhcp'

I should have probably mentioned that I'm getting into the box via Console cable. The box has no connectivity through the ports themselves (yet)

1 Like

To be clear:

  • You can get a LAN IP on eth0?
  • Do you have a cable modem or FTTx ISP on WAN?

To clarify:

  1. I have no connectivity on the ethernet ports - Connecting via Console Cable.

  2. Eth1 (WAN) is connected upstream to the house LAN 192.168.0.0/24 network, Eth0 (LAN) is connected to the laptop's ethernet port (and set to 192.168.1.2). I've tried to set the laptop connected to Eth0 to both Static or DHCP without connectivity.

  3. No conflict on the WAN side, since OpenWRT sets the LAN to 192.168.1.0/24 network.

  4. br-lan IP is showing 192.168.1.1, no ping connectivity on the WAN side to the edge router (192.168.0.1).

If I can get the connectivity to the ethernet ports, I could use luCi and dropbear, but until then, I'm riding the roll-over cable.

grommish@gribbits:~$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.2 icmp_seq=1 Destination Host Unreachable
From 192.168.1.2 icmp_seq=2 Destination Host Unreachable
^C
--- 192.168.1.1 ping statistics ---
4 packets transmitted, 0 received, +2 errors, 100% packet loss, time 70ms

Screenshot%20from%202019-05-05%2005-58-52

  • I cannot assist if you will not answer my questions.
  • Also, given you said you were connected via console, I'm completely lost as to what machine is depicted in the graphic above (or why you depicted it). But it was helpful in noticing something!
  • Lastly, I'm unable to find your device in the Table of Hardware - I was going to ask that you try flashing supported firmware from the downloads site. This means your device is likely not supported.
  1. Can you please explain how you compiled OpenWrt?
  2. Are you getting an IPv6 address from br-lan? (it appears so, try finding the IPv6 Neighbor and connect to LuCI that way!) The command is ip -6 neigh
  3. Also, can you provide the link to the OpenWrt Techdata or Hardware page for your device?
1 Like

The device is an Itus Networks Shield. It isn't on the list of devices because no one has made one officially. Itus Networks is no longer around, but they used OpenWRT in their OEM images. The device is a Cavium Octeon III processor.

I pulled the running kernel config from the Itus images (/proc/config.gz), used "make menuconfig", "make defconfig", "make kernel_menuconfig" and loaded the kernel config file. I compiled the MIPS64 toolchain and set the Linker and CrossCompile flags (make CC=x86_64-unknown-linux-gnu LD=mips64-openwrt-linux-ld -j9 V=s 2>&1 | tee ${TOP_DIR}/build.log), which creates the openwrt/bin/targets/octeon/generic files

-rw-r--r-- 1 grommish grommish     7110 May  5 06:48 config.seed
-rw-r--r-- 1 grommish grommish     1883 May  5 06:55 openwrt-octeon-default.manifest
-rwxr-xr-x 1 grommish grommish 13189136 May  5 06:55 openwrt-octeon-er-initramfs-kernel.bin
-rwxr-xr-x 1 grommish grommish 13189136 May  5 06:55 openwrt-octeon-erlite-initramfs-kernel.bin
-rw-r--r-- 1 grommish grommish  9144320 May  5 06:55 openwrt-octeon-erlite-squashfs-sysupgrade.tar
-rw-r--r-- 1 grommish grommish  9144320 May  5 06:55 openwrt-octeon-er-squashfs-sysupgrade.tar
-rwxr-xr-x 1 grommish grommish 13189136 May  5 06:55 openwrt-octeon-generic-initramfs-kernel.bin
drwxr-xr-x 2 grommish grommish     4096 May  5 06:55 packages
-rw-r--r-- 1 grommish grommish      720 May  5 06:55 sha256sums

I then load the openwrt-octeon-generic-initramfs-kernel.bin to the device and boot. The Shield has a mmcblk0p1 device that holds the on-board Flash and all of the image files. The device comes with 3 modes and 3 firmwares, depending on which mode you boot into: router, bridge, gateway. I boot the device into router mode, which works fine (on the original Itus Networks outdated image). I mount /dev/mmcblk0p1 /overlay and scp the bin file to the device, set the hardware switch to gateway mode (which is my testing build) and reboot -f. It then boots into the OpenWRT test build. Which is where I am as of this moment. In order to connect to the device, I use a USB3.0 Serial to Console RJ45 rollover cable thru /dev/ttyUSB0. I could probably build gkermit into the OpenWRT build and eliminate the need to bounce from router mode to test build, but I'm wanting to stick to the base build to help eliminate any other issues.

While I KNOW that OpenWRT isn't OFFICIALLY supported for the device, I also know that the OEM images were OpenWRT and that the device boots. This is a configuration issues and I'm not up to speed on OpenWRT (which is why I'm here).

Output from ip -6 neigh:

root@OpenWrt:/# ip -6 neigh
fe80::2e26:5fff:fe80:4a5 dev eth1 lladdr 2c:26:5f:80:04:a5 used 0/0/0 probes 0 STALE

eth1 is the WAN port under the stock OpenWRT image, with eth0 as the LAN port. Both are outlined under /etc/config/network.

Tech specs are here

I'm more than happy to get the device working with an updated OpenWRT and then send the configuration in for someone at OpenWRT to make Official, but for now, it's just me and any help I can get here :smile: The fact Itus Networks no longer exists means I can't get any help from them, so....

The screenshot is from my Ubuntu box's Network settings for wired network, which is connected to the eth0 (LAN) port on the Shield. I set the static IP to 192.168.1.2 because DHCP wasn't being set for it.

And the file -k output for the .bin:

grommish@gribbits:~/openwrt/bin/targets/octeon/generic$ file -k openwrt-octeon-generic-initramfs-kernel.bin
openwrt-octeon-generic-initramfs-kernel.bin: ELF 64-bit MSB executable, MIPS, MIPS64 rel2 version 1 (SYSV) (Lepton 3.x), scale 0-0, spot sensor temperature 0.000000, color scheme 0, calibration: offset 0.000000, slope 0.000000 (Lepton 2.x), scale 36483-29216, spot sensor temperature 0.001894, color scheme 0, calibration: offset 0.000000, slope 0.000000, statically linked, stripped\012- data

If you need something else, just let me know and I'll post/clarify as requested!

Anyone can hit me up on Google Hangouts at grommish(@)gmail(dot)com

Thank you!

I can't help if you won't be clear.

Some of your response seems as if you need to make a post about porting OpenWrt to the device, in the For Developers section. Regarding access to LUCI via IPV6 - you were supposed to run that command on your computer, not the router. If an address appears for the router, try browsing to it.

1 Like

ip -6 neigh on the Ubuntu laptop only shows the Wireless connection, nothing on the wired.

As to posting in the Dev section, I had originally considered doing that, but since the image builds and boots, the physical ethernet connections report up/down when plugged, etc, I saw this as a configuration issue rather than a build issue - hense the post here.

When I do a ifstatus wan I get the following:

root@OpenWrt:/# ifstatus wan                                                                               
{                                                                                                          
        "up": false,                                                                                       
        "pending": true,                                                                                   
        "available": true,                                                                                 
        "autostart": true,                                                                                 
        "dynamic": false,                                                                                  
        "proto": "dhcp",                                                                                   
        "device": "eth1",                                                                                  
        "data": {                                                                                          
                                                                                                           
        }                                                                                                  
}

So the physical link is there, but the configuration is borked somewhere.

When I do a logread -f and plug in the eth1 (wan) cable:

[  171.173034] eth1: 1000 Mbps Full duplex, port 1, queue 1                                                
Mon May  6 16:43:45 2019 daemon.notice netifd: Network device 'eth1' link is up                            
Mon May  6 16:43:45 2019 daemon.notice netifd: Interface 'wan' has link connectivity                       
Mon May  6 16:43:45 2019 daemon.notice netifd: Interface 'wan' is setting up now                           
Mon May  6 16:43:45 2019 kern.notice kernel: [  171.173034] eth1: 1000 Mbps Full duplex, port 1, queue 1   
Mon May  6 16:43:45 2019 daemon.notice netifd: Interface 'wan6' has link connectivity                      
Mon May  6 16:43:45 2019 daemon.notice netifd: Interface 'wan6' is setting up now                          
Mon May  6 16:43:45 2019 daemon.notice netifd: wan (1401): udhcpc: started, v1.30.1                        
Mon May  6 16:43:45 2019 daemon.notice netifd: wan (1401): udhcpc: sending discover                        
Mon May  6 16:43:48 2019 daemon.notice netifd: wan (1401): udhcpc: sending discover                        
Mon May  6 16:43:52 2019 daemon.notice netifd: wan (1401): udhcpc: sending discover 

It never gets a DHCP response. The cable is good. In the original image, it works fine, if I plug the cable into the laptop, it works fine. Could the packet be getting dropped at the interface?

Side note to tmomas: Got the message finally about the tags, I'll make sure I do that in the future. Thanks!

  • Are you connecting to both at the same time!?!?
  • If so, why?
  • Why are you showing WAN information?
  • My troubleshooting steps were for LAN (one step at a time)

This makes troubleshooting quite difficult when you're showing results from multiple things at once. Did you browse to the neighbor IP on your Ubuntu's screen?

First, let me again say Thank You for working with me on this. It's very much appreciated!

Yes, I was connecting both Wired and Wireless. The wireless connection is on the 192.168.0.0/24 network, and by default OpenWRT uses 192.168.1.0/24. So there aren't any collision domains to worry about. Of course I'm willing to drop the WiFi connection, but that cuts my connectivity entirely and they don't effect each other. The Itus OEM image uses 10.10.10.10 as the default IP, for example.

At this point, I'm looking for ANY connectivity on the box. The WAN link SHOULD be the easiest because it uses DHCP.

Something to keep in mind is that this is a Network Security Device with IPS. It's NOT an Internet-facing router. The entire point of this device is to act as a router/bridge from one network segment to another using snort and whatever firewall that gets installed. WAN link, in this context, is just a connection to the UPSTREAM router(s).

Laptop -> Itus Shield -> Mid-Network Router -> Edge Router -> Internet

So the Shield/OpenWRT just needs to pull a DHCP request on the WAN port so it can forward to the edge router (Mid-Network is just a relay on the same segment).

I'm more than willing to work exclusively on the LAN side and follow step-by-step what you want me to do.

Let me know!

As a first test:

  • Also try SSH.
  • As a second test, run Wirehark on this interface and see if you are getting DHCP Requests, etc.

:open_mouth:

Ummmmm...but there are metrics and routes added by Ubuntu, don't do this during testing.

1 Like

Wireless Off, Wired On.

ip neigh:

grommish@gribbits:~/openwrt$ ip neigh
grommish@gribbits:~/openwrt$ 

Wireshark Log:

No.     Time           Source                Destination           Protocol Length Info
      1 0.000000000    ::                    ff02::16              ICMPv6   110    Multicast Listener Report Message v2

Frame 1: 110 bytes on wire (880 bits), 110 bytes captured (880 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_16 (33:33:00:00:00:16)
Internet Protocol Version 6, Src: ::, Dst: ff02::16
Internet Control Message Protocol v6

No.     Time           Source                Destination           Protocol Length Info
      2 0.015994336    ::                    ff02::16              ICMPv6   110    Multicast Listener Report Message v2

Frame 2: 110 bytes on wire (880 bits), 110 bytes captured (880 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_16 (33:33:00:00:00:16)
Internet Protocol Version 6, Src: ::, Dst: ff02::16
Internet Control Message Protocol v6

No.     Time           Source                Destination           Protocol Length Info
      3 0.044188038    0.0.0.0               255.255.255.255       DHCP     342    DHCP Request  - Transaction ID 0x981b615e

Frame 3: 342 bytes on wire (2736 bits), 342 bytes captured (2736 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Internet Protocol Version 4, Src: 0.0.0.0, Dst: 255.255.255.255
User Datagram Protocol, Src Port: 68, Dst Port: 67
Bootstrap Protocol (Request)

No.     Time           Source                Destination           Protocol Length Info
      4 0.324064745    ::                    ff02::1:ff97:775a     ICMPv6   86     Neighbor Solicitation for fe80::48c6:1569:d897:775a

Frame 4: 86 bytes on wire (688 bits), 86 bytes captured (688 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_ff:97:77:5a (33:33:ff:97:77:5a)
Internet Protocol Version 6, Src: ::, Dst: ff02::1:ff97:775a
Internet Control Message Protocol v6

No.     Time           Source                Destination           Protocol Length Info
      5 1.344406313    fe80::48c6:1569:d897:775a ff02::16              ICMPv6   110    Multicast Listener Report Message v2

Frame 5: 110 bytes on wire (880 bits), 110 bytes captured (880 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_16 (33:33:00:00:00:16)
Internet Protocol Version 6, Src: fe80::48c6:1569:d897:775a, Dst: ff02::16
Internet Control Message Protocol v6

No.     Time           Source                Destination           Protocol Length Info
      6 1.356270852    fe80::48c6:1569:d897:775a ff02::16              ICMPv6   110    Multicast Listener Report Message v2

Frame 6: 110 bytes on wire (880 bits), 110 bytes captured (880 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_16 (33:33:00:00:00:16)
Internet Protocol Version 6, Src: fe80::48c6:1569:d897:775a, Dst: ff02::16
Internet Control Message Protocol v6

No.     Time           Source                Destination           Protocol Length Info
      7 1.664243517    fe80::48c6:1569:d897:775a ff02::16              ICMPv6   110    Multicast Listener Report Message v2

Frame 7: 110 bytes on wire (880 bits), 110 bytes captured (880 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_16 (33:33:00:00:00:16)
Internet Protocol Version 6, Src: fe80::48c6:1569:d897:775a, Dst: ff02::16
Internet Control Message Protocol v6

No.     Time           Source                Destination           Protocol Length Info
      8 1.860245677    fe80::48c6:1569:d897:775a ff02::fb              MDNS     202    Standard query response 0x0000 PTR, cache flush gribbits.local AAAA, cache flush fe80::48c6:1569:d897:775a

Frame 8: 202 bytes on wire (1616 bits), 202 bytes captured (1616 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_fb (33:33:00:00:00:fb)
Internet Protocol Version 6, Src: fe80::48c6:1569:d897:775a, Dst: ff02::fb
User Datagram Protocol, Src Port: 5353, Dst Port: 5353
Multicast Domain Name System (response)

No.     Time           Source                Destination           Protocol Length Info
      9 1.929718247    fe80::48c6:1569:d897:775a ff02::2               ICMPv6   62     Router Solicitation

Frame 9: 62 bytes on wire (496 bits), 62 bytes captured (496 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_02 (33:33:00:00:00:02)
Internet Protocol Version 6, Src: fe80::48c6:1569:d897:775a, Dst: ff02::2
Internet Control Message Protocol v6

No.     Time           Source                Destination           Protocol Length Info
     10 2.272439298    fe80::48c6:1569:d897:775a ff02::16              ICMPv6   110    Multicast Listener Report Message v2

Frame 10: 110 bytes on wire (880 bits), 110 bytes captured (880 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_16 (33:33:00:00:00:16)
Internet Protocol Version 6, Src: fe80::48c6:1569:d897:775a, Dst: ff02::16
Internet Control Message Protocol v6

No.     Time           Source                Destination           Protocol Length Info
     11 3.094318466    fe80::48c6:1569:d897:775a ff02::fb              MDNS     220    Standard query 0x0000 PTR _ipps._tcp.local, "QM" question PTR _nmea-0183._tcp.local, "QM" question PTR _ftp._tcp.local, "QM" question PTR _webdav._tcp.local, "QM" question PTR _webdavs._tcp.local, "QM" question PTR _sftp-ssh._tcp.local, "QM" question PTR _smb._tcp.local, "QM" question PTR _afpovertcp._tcp.local, "QM" question PTR _nfs._tcp.local, "QM" question PTR _ipp._tcp.local, "QM" question

Frame 11: 220 bytes on wire (1760 bits), 220 bytes captured (1760 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_fb (33:33:00:00:00:fb)
Internet Protocol Version 6, Src: fe80::48c6:1569:d897:775a, Dst: ff02::fb
User Datagram Protocol, Src Port: 5353, Dst Port: 5353
Multicast Domain Name System (query)

No.     Time           Source                Destination           Protocol Length Info
     12 3.239812279    0.0.0.0               255.255.255.255       DHCP     342    DHCP Request  - Transaction ID 0x981b615e

Frame 12: 342 bytes on wire (2736 bits), 342 bytes captured (2736 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Internet Protocol Version 4, Src: 0.0.0.0, Dst: 255.255.255.255
User Datagram Protocol, Src Port: 68, Dst Port: 67
Bootstrap Protocol (Request)

No.     Time           Source                Destination           Protocol Length Info
     13 3.918727559    fe80::48c6:1569:d897:775a ff02::fb              MDNS     202    Standard query response 0x0000 PTR, cache flush gribbits.local AAAA, cache flush fe80::48c6:1569:d897:775a

Frame 13: 202 bytes on wire (1616 bits), 202 bytes captured (1616 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_fb (33:33:00:00:00:fb)
Internet Protocol Version 6, Src: fe80::48c6:1569:d897:775a, Dst: ff02::fb
User Datagram Protocol, Src Port: 5353, Dst Port: 5353
Multicast Domain Name System (response)

No.     Time           Source                Destination           Protocol Length Info
     14 5.932372305    fe80::48c6:1569:d897:775a ff02::2               ICMPv6   62     Router Solicitation

Frame 14: 62 bytes on wire (496 bits), 62 bytes captured (496 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_02 (33:33:00:00:00:02)
Internet Protocol Version 6, Src: fe80::48c6:1569:d897:775a, Dst: ff02::2
Internet Control Message Protocol v6

No.     Time           Source                Destination           Protocol Length Info
     15 6.959235502    0.0.0.0               255.255.255.255       DHCP     342    DHCP Request  - Transaction ID 0x981b615e

Frame 15: 342 bytes on wire (2736 bits), 342 bytes captured (2736 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Internet Protocol Version 4, Src: 0.0.0.0, Dst: 255.255.255.255
User Datagram Protocol, Src Port: 68, Dst Port: 67
Bootstrap Protocol (Request)

No.     Time           Source                Destination           Protocol Length Info
     16 7.097652287    fe80::48c6:1569:d897:775a ff02::fb              MDNS     220    Standard query 0x0000 PTR _ipps._tcp.local, "QM" question PTR _nmea-0183._tcp.local, "QM" question PTR _ftp._tcp.local, "QM" question PTR _webdav._tcp.local, "QM" question PTR _webdavs._tcp.local, "QM" question PTR _sftp-ssh._tcp.local, "QM" question PTR _smb._tcp.local, "QM" question PTR _afpovertcp._tcp.local, "QM" question PTR _nfs._tcp.local, "QM" question PTR _ipp._tcp.local, "QM" question

Frame 16: 220 bytes on wire (1760 bits), 220 bytes captured (1760 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_fb (33:33:00:00:00:fb)
Internet Protocol Version 6, Src: fe80::48c6:1569:d897:775a, Dst: ff02::fb
User Datagram Protocol, Src Port: 5353, Dst Port: 5353
Multicast Domain Name System (query)

No.     Time           Source                Destination           Protocol Length Info
     17 9.932368035    fe80::48c6:1569:d897:775a ff02::2               ICMPv6   62     Router Solicitation

Frame 17: 62 bytes on wire (496 bits), 62 bytes captured (496 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_02 (33:33:00:00:00:02)
Internet Protocol Version 6, Src: fe80::48c6:1569:d897:775a, Dst: ff02::2
Internet Control Message Protocol v6

No.     Time           Source                Destination           Protocol Length Info
     18 12.197328594   0.0.0.0               255.255.255.255       DHCP     342    DHCP Discover - Transaction ID 0x5aa490a

Frame 18: 342 bytes on wire (2736 bits), 342 bytes captured (2736 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Internet Protocol Version 4, Src: 0.0.0.0, Dst: 255.255.255.255
User Datagram Protocol, Src Port: 68, Dst Port: 67
Bootstrap Protocol (Discover)

No.     Time           Source                Destination           Protocol Length Info
     19 15.102206096   fe80::48c6:1569:d897:775a ff02::fb              MDNS     220    Standard query 0x0000 PTR _ipps._tcp.local, "QM" question PTR _nmea-0183._tcp.local, "QM" question PTR _ftp._tcp.local, "QM" question PTR _webdav._tcp.local, "QM" question PTR _webdavs._tcp.local, "QM" question PTR _sftp-ssh._tcp.local, "QM" question PTR _smb._tcp.local, "QM" question PTR _afpovertcp._tcp.local, "QM" question PTR _nfs._tcp.local, "QM" question PTR _ipp._tcp.local, "QM" question

Frame 19: 220 bytes on wire (1760 bits), 220 bytes captured (1760 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_fb (33:33:00:00:00:fb)
Internet Protocol Version 6, Src: fe80::48c6:1569:d897:775a, Dst: ff02::fb
User Datagram Protocol, Src Port: 5353, Dst Port: 5353
Multicast Domain Name System (query)

No.     Time           Source                Destination           Protocol Length Info
     20 15.322147290   0.0.0.0               255.255.255.255       DHCP     342    DHCP Discover - Transaction ID 0x5aa490a

Frame 20: 342 bytes on wire (2736 bits), 342 bytes captured (2736 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Internet Protocol Version 4, Src: 0.0.0.0, Dst: 255.255.255.255
User Datagram Protocol, Src Port: 68, Dst Port: 67
Bootstrap Protocol (Discover)

No.     Time           Source                Destination           Protocol Length Info
     21 23.614690989   0.0.0.0               255.255.255.255       DHCP     342    DHCP Discover - Transaction ID 0x5aa490a

Frame 21: 342 bytes on wire (2736 bits), 342 bytes captured (2736 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Internet Protocol Version 4, Src: 0.0.0.0, Dst: 255.255.255.255
User Datagram Protocol, Src Port: 68, Dst Port: 67
Bootstrap Protocol (Discover)

No.     Time           Source                Destination           Protocol Length Info
     22 31.117657051   fe80::48c6:1569:d897:775a ff02::fb              MDNS     220    Standard query 0x0000 PTR _ipps._tcp.local, "QM" question PTR _nmea-0183._tcp.local, "QM" question PTR _ftp._tcp.local, "QM" question PTR _webdav._tcp.local, "QM" question PTR _webdavs._tcp.local, "QM" question PTR _sftp-ssh._tcp.local, "QM" question PTR _smb._tcp.local, "QM" question PTR _afpovertcp._tcp.local, "QM" question PTR _nfs._tcp.local, "QM" question PTR _ipp._tcp.local, "QM" question

Frame 22: 220 bytes on wire (1760 bits), 220 bytes captured (1760 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_fb (33:33:00:00:00:fb)
Internet Protocol Version 6, Src: fe80::48c6:1569:d897:775a, Dst: ff02::fb
User Datagram Protocol, Src Port: 5353, Dst Port: 5353
Multicast Domain Name System (query)

No.     Time           Source                Destination           Protocol Length Info
     23 44.192421671   0.0.0.0               255.255.255.255       DHCP     342    DHCP Discover - Transaction ID 0x5aa490a

Frame 23: 342 bytes on wire (2736 bits), 342 bytes captured (2736 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Internet Protocol Version 4, Src: 0.0.0.0, Dst: 255.255.255.255
User Datagram Protocol, Src Port: 68, Dst Port: 67
Bootstrap Protocol (Discover)

No.     Time           Source                Destination           Protocol Length Info
     24 44.992024970   ::                    ff02::16              ICMPv6   130    Multicast Listener Report Message v2

Frame 24: 130 bytes on wire (1040 bits), 130 bytes captured (1040 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_16 (33:33:00:00:00:16)
Internet Protocol Version 6, Src: ::, Dst: ff02::16
Internet Control Message Protocol v6

No.     Time           Source                Destination           Protocol Length Info
     25 45.027994889   ::                    ff02::16              ICMPv6   130    Multicast Listener Report Message v2

Frame 25: 130 bytes on wire (1040 bits), 130 bytes captured (1040 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_16 (33:33:00:00:00:16)
Internet Protocol Version 6, Src: ::, Dst: ff02::16
Internet Control Message Protocol v6

No.     Time           Source                Destination           Protocol Length Info
     26 45.072220061   0.0.0.0               255.255.255.255       DHCP     342    DHCP Request  - Transaction ID 0x2b5d6156

Frame 26: 342 bytes on wire (2736 bits), 342 bytes captured (2736 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Internet Protocol Version 4, Src: 0.0.0.0, Dst: 255.255.255.255
User Datagram Protocol, Src Port: 68, Dst Port: 67
Bootstrap Protocol (Request)

No.     Time           Source                Destination           Protocol Length Info
     27 45.664404314   ::                    ff02::16              ICMPv6   110    Multicast Listener Report Message v2

Frame 27: 110 bytes on wire (880 bits), 110 bytes captured (880 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_16 (33:33:00:00:00:16)
Internet Protocol Version 6, Src: ::, Dst: ff02::16
Internet Control Message Protocol v6

No.     Time           Source                Destination           Protocol Length Info
     28 45.696544620   ::                    ff02::1:ff97:775a     ICMPv6   86     Neighbor Solicitation for fe80::48c6:1569:d897:775a

Frame 28: 86 bytes on wire (688 bits), 86 bytes captured (688 bits) on interface 0
Ethernet II, Src: HewlettP_00:d4:df (ac:e2:d3:00:d4:df), Dst: IPv6mcast_ff:97:77:5a (33:33:ff:97:77:5a)
Internet Protocol Version 6, Src: ::, Dst: ff02::1:ff97:775a
Internet Control Message Protocol v6

It's blank...can you explain your wireless connection, it is the same device correct???

We're just trying to get into the router!!!

  • Hide your MACs next time...
  • Blank
  • And...did you compile dnsmasq and odhcpd too???
  • By checking the console, can you verify they are running?
  • Can you verify dnsmasq is listening? netstat -p | grep dnsmasq

The ip neigh was run on the laptop which is connected to the Shield via the lan port. The Shield doesn't have wireless; the laptop has both the wireless and wired ports. I made sure the laptop wasn't connected to the wireless network.

root@OpenWrt:/# netstat -p | grep dnsmasq                                                                  
unix  3      [ ]         STREAM     CONNECTED       1264 793/dnsmasq                                       
unix  2      [ ]         DGRAM                      1262 793/dnsmasq 
root@OpenWrt:/# netstat -p | grep odhcpd                                                                   
unix  2      [ ]         DGRAM                      1646 920/odhcpd                                        
unix  3      [ ]         STREAM     CONNECTED       1367 920/odhcpd 

The OpenWrt image is the default configuration for packages, with the exception of adding luCI to the build.

Zero RX doesn't look well.

ls -l /sys/class/net/*/device/driver
root@OpenWrt:/# ls -l /sys/class/net/*/device/driver
lrwxrwxrwx    1 root     root             0 May  7 20:30 /sys/class/net/eth0/device/driver -> ../../../../bus/platform/drivers/octeon_ethernet
lrwxrwxrwx    1 root     root             0 May  7 20:30 /sys/class/net/eth1/device/driver -> ../../../../bus/platform/drivers/octeon_ethernet
lrwxrwxrwx    1 root     root             0 May  7 20:30 /sys/class/net/eth2/device/driver -> ../../../../bus/platform/drivers/octeon_ethernet
lrwxrwxrwx    1 root     root             0 May  7 20:30 /sys/class/net/eth3/device/driver -> ../../../../bus/platform/drivers/octeon_ethernet
lrwxrwxrwx    1 root     root             0 May  7 20:30 /sys/class/net/eth4/device/driver -> ../../../../bus/platform/drivers/octeon_ethernet
lrwxrwxrwx    1 root     root             0 May  7 20:30 /sys/class/net/eth5/device/driver -> ../../../../bus/platform/drivers/octeon_ethernet
lrwxrwxrwx    1 root     root             0 May  7 20:30 /sys/class/net/eth6/device/driver -> ../../../../bus/platform/drivers/octeon_ethernet
lrwxrwxrwx    1 root     root             0 May  7 20:30 /sys/class/net/eth7/device/driver -> ../../../../bus/platform/drivers/octeon_ethernet
lrwxrwxrwx    1 root     root             0 May  7 20:30 /sys/class/net/loop0/device/driver -> ../../../../bus/platform/drivers/octeon_ethernet
lrwxrwxrwx    1 root     root             0 May  7 20:30 /sys/class/net/loop1/device/driver -> ../../../../bus/platform/drivers/octeon_ethernet
lrwxrwxrwx    1 root     root             0 May  7 20:30 /sys/class/net/loop2/device/driver -> ../../../../bus/platform/drivers/octeon_ethernet
lrwxrwxrwx    1 root     root             0 May  7 20:30 /sys/class/net/loop3/device/driver -> ../../../../bus/platform/drivers/octeon_ethernet
root@OpenWrt:/# 

Disable firewall, configure different static IP addresses and test every interface manually.
Use Cat5/Cat5e cable with TIA/EIA-568A/B assignment, use ping for testing, check link status and RX/TX.

But anyway, those interfaces make me think you have some kind of hardware switch which requires additional configuration to work properly.