Network unreachable with TP-Link Archer C60 v2 and 23.05.0

Archer C60 v2 has broken network with the RC4 of 23.05.
I can't connect to anything except LAN devices.
Even if I ping an IP address, I get "ping: sendto: Network unreachable"
Reverted to RC3 where everything works flawlessly.

1 Like

I did a test, but /etc/init.d/network restart didn't solve anything. Only LAN devices are reachable.
I noticed a slower start-up of the router and this error messages regarding ath10k_pci

[   93.909763] ath10k_pci 0000:00:00.0: mac flush vdev 0 drop 0 queues 0x1 ar->paused: 0x0  arvif->paused: 0x0
[   93.933021] ath10k_pci 0000:00:00.0: mac flush null vif, drop 0 queues 0xffff
[   93.942155] ath10k_pci 0000:00:00.0: peer-unmap-event: unknown peer id 0
[   93.949219] ath10k_pci 0000:00:00.0: peer-unmap-event: unknown peer id 0
[   94.140104] phy1-sta0: deauthenticating from 2c:30:33:e9:00:b1 by local choice (Reason: 3=DEAUTH_LEAVING)
[  106.605737] ath10k_pci 0000:00:00.0: 10.4 wmi init: vdevs: 16  peers: 48  tid: 96
[  106.613572] ath10k_pci 0000:00:00.0: msdu-desc: 2500  skid: 32
[  106.643754] ath10k_pci 0000:00:00.0: wmi print 'P 48/48 V 16 K 144 PH 176 T 186  msdu-desc: 2500  sw-crypt: 0 ct-sta: 0'
[  106.655111] ath10k_pci 0000:00:00.0: wmi print 'free: 114572 iram: 12644 sram: 29508'
[  107.014798] ath10k_pci 0000:00:00.0: rts threshold -1
[  107.026641] ath10k_pci 0000:00:00.0: Firmware lacks feature flag indicating a retry limit of > 2 is OK, requested limit: 4
[  131.236642] ath10k_pci 0000:00:00.0: 10.4 wmi init: vdevs: 16  peers: 48  tid: 96
[  131.244436] ath10k_pci 0000:00:00.0: msdu-desc: 2500  skid: 32
[  131.274610] ath10k_pci 0000:00:00.0: wmi print 'P 48/48 V 16 K 144 PH 176 T 186  msdu-desc: 2500  sw-crypt: 0 ct-sta: 0'
[  131.285975] ath10k_pci 0000:00:00.0: wmi print 'free: 114572 iram: 12644 sram: 29508'
[  131.645614] ath10k_pci 0000:00:00.0: rts threshold -1
[  131.656866] ath10k_pci 0000:00:00.0: Firmware lacks feature flag indicating a retry limit of > 2 is OK, requested limit: 4

Thanks for your help

what other devices did you think you'd reach ?

or is LAN == wired ?

Can you show your /etc/config/network, and also the output of 'ip route' ?

ip route shows:
192.168.2.0/24 dev phy1-sta0 scope link src 192.168.2.50
192.168.50.0/24 dev br-lan scope link src 192.168.50.1

and this is /etc/config/network

config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config globals 'globals'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth1'

config interface 'wan6'
        option proto 'dhcpv6'
        option device 'eth1'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.50.1'
        option gateway '192.168.2.1'
        list dns '192.168.2.5'
        option device 'br-lan'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

config interface 'wwan'
        option proto 'static'
        option netmask '255.255.255.0'
        list dns '192.168.2.5'
        option ipaddr '192.168.2.50'
        option gateway '192.168.2.1'

config interface 'repeater_bridge'
        option proto 'relay'
        list network 'lan'
        list network 'wwan'
        option gateway '192.168.2.5'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

LAN isn't wired. The router is used as a repeater.
I can reach all the other devices in the WLAN network, even the one attached to the main router.
DNS resolution is working, but I can't go outside my LAN.

are your clients getting an IP from the main routers subnet, or the repeater ?

From the main router. The problem at the moment is that I cannot reach anything outside LAN from this Archer C60 router. The gateway is reachable and set and I can't understand what isn't working.

then try pinging 8.8.8.8 from one of the clients connected to the repeater.
if it works, do the same with google.com

It doesn't work

post the error message.

check the IP and default GW IP on the client connected via the repeater.
is the gw pointing towards the main router ?
can you ping the main router ?

did you follow https://openwrt.org/docs/guide-user/network/wifi/relay_configuration when you set it up ?

I even enclosed my configuration here.
However, I can ping the gateway and the gateway is set on the repeater. I can even reach the repeater via SSH from my server connected to the main router.

To be more clear, this configuration is working since 18.06.0 and it's working on 23.05.0-RC3. This is the first RC where this repeater stopped reaching the outside network.

It looks like the wwan interface came up - we can see the 192.168.2.0/24 route as expected - but the default route with 192.168.2.1 gateway wasn't created.

I am not sure what is causing this - I was seeing similar symptoms when I tried 23.05.0-rc4 on my pi zero W, but in my case /etc/init.d/network restart fixed it, while it doesn't seem to help in your config.

Regardless of that difference, I don't understand why the default route wasn't created. When starting the wwan interface, I would expect to see two routes being created at once, one with 192.168.2.0/24 dev phy1-sta0 scope link src 192.168.2.50 as you are seeing, and the other with default via 192.168.2.1 dev phy1-sta0...

2 Likes

You're right. The default route is missing. Now RC3 is running and I have
default via 192.168.2.1 dev phy1-sta0

1 Like

I did
ip route add default via 192.168.2.1
and now the network is up and everything is working.
However this isn't kept after reboot.
I even set the default gateway in Luci. It works but not after reboot.

1 Like

add it to your startup script.

Can you write me an example? I was able to add the gateway by simply clicking restart on WWAN interface. Maybe I don't have to restart the whole network service.

add the command at the cursor in

1 Like

That I know but ifdown wwan && ifup wwan isn't working

well no, but ip route add default via 192.168.2.1 would ?