Network takes up to 10 minutes to come up after boot on GL-AR750s

I have an GL-AR750s and compiled with the new nand version the firmware.
The problem is that after a new boot after 30 - 40 sec I get a successful ping, but only 3 or 4 times than it goes away again. After about 10 minutes the network and wifi is up and working fine.

Here is my /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb9:e958:bdcc::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.2.22'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.2.4'
	option dns '192.168.2.4'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 2 3'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0t 1'

my /etc/config/firewall

config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option src_ip		fc00::/6
	option dest_ip		fc00::/6
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT

# include a file with users custom iptables rules
config include
	option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp

and my kernel boot log

[    0.000000] Linux version 4.19.56 (guenter@sharppc) (gcc version 7.4.0 (OpenWrt GCC 7.4.0 unknown)) #0 Tue Jul 16 12:36:43 2019
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019750 (MIPS 74Kc)
[    0.000000] MIPS: machine is GL.iNet GL-AR750S
[    0.000000] SoC: Qualcomm Atheros QCA956X ver 1 rev 0
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 08000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] On node 0 totalpages: 32768
[    0.000000]   Normal zone: 288 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 32768 pages, LIFO batch:7
[    0.000000] random: get_random_bytes called from start_kernel+0x98/0x4a8 with crng_init=0
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 32480
[    0.000000] Kernel command line: console=ttyS0,115200n8 rootfstype=squashfs,jffs2
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 122232K/131072K available (4506K kernel code, 161K rwdata, 1036K rodata, 1200K init, 207K bss, 8840K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 51
[    0.000000] CPU clock: 775.000 MHz
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 4932285024 ns
[    0.000007] sched_clock: 32 bits at 387MHz, resolution 2ns, wraps every 5541893118ns
[    0.008222] Calibrating delay loop... 385.84 BogoMIPS (lpj=1929216)
[    0.074772] pid_max: default: 32768 minimum: 301
[    0.079825] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.086808] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.098486] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.108888] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.115434] pinctrl core: initialized pinctrl subsystem
[    0.121406] NET: Registered protocol family 16
[    0.132480] PCI host bridge /ahb/apb/pcie-controller@18250000 ranges:
[    0.139283]  MEM 0x0000000012000000..0x0000000013ffffff
[    0.144822]   IO 0x0000000000000000..0x0000000000000000
[    0.168999] PCI host bridge to bus 0000:00
[    0.173325] pci_bus 0000:00: root bus resource [mem 0x12000000-0x13ffffff]
[    0.180618] pci_bus 0000:00: root bus resource [io  0x0000]
[    0.186488] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.193649] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.202024] pci 0000:00:00.0: [168c:0050] type 00 class 0x028000
[    0.202078] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x001fffff 64bit]
[    0.202131] pci 0000:00:00.0: reg 0x30: [mem 0x00000000-0x0000ffff pref]
[    0.202203] pci 0000:00:00.0: supports D1
[    0.202211] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    0.203219] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 00
[    0.203244] pci 0000:00:00.0: BAR 0: assigned [mem 0x12000000-0x121fffff 64bit]
[    0.210999] pci 0000:00:00.0: BAR 6: assigned [mem 0x12200000-0x1220ffff pref]
[    0.219183] clocksource: Switched to clocksource MIPS
[    0.225551] NET: Registered protocol family 2
[    0.230878] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 4096 bytes)
[    0.238984] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.246379] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.253100] TCP: Hash tables configured (established 1024 bind 1024)
[    0.259933] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.266099] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.273076] NET: Registered protocol family 1
[    0.277706] PCI: CLS 0 bytes, default 32
[    0.282594] Crashlog allocated RAM at address 0x3f00000
[    0.289799] workingset: timestamp_bits=14 max_order=15 bucket_order=1
[    0.302462] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.308605] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.332913] io scheduler noop registered
[    0.337044] io scheduler deadline registered (default)
[    0.343167] ar7200-usb-phy usb-phy: phy reset is missing
[    0.350264] pinctrl-single 1804002c.pinmux: 544 pins, size 68
[    0.357338] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[    0.364712] console [ttyS0] disabled
[    0.368501] 18020000.uart: ttyS0 at MMIO 0x18020000 (irq = 9, base_baud = 1562500) is a 16550A
[    0.377642] console [ttyS0] enabled
[    0.385196] bootconsole [early0] disabled
[    0.409505] m25p80 spi0.0: w25q128 (16384 Kbytes)
[    0.414405] 6 fixed-partitions partitions found on MTD device spi0.0
[    0.420992] Creating 6 MTD partitions on "spi0.0":
[    0.425953] 0x000000000000-0x000000040000 : "u-boot"
[    0.431839] 0x000000040000-0x000000050000 : "u-boot-env"
[    0.438004] 0x000000050000-0x000000060000 : "art"
[    0.443619] 0x000000060000-0x000001000000 : "nor_firmware"
[    0.450062] 0x000000060000-0x000000260000 : "kernel"
[    0.455849] 0x000000260000-0x000001000000 : "nor_reserved"
[    0.466423] spi-nand spi0.1: GigaDevice SPI NAND was found.
[    0.472237] spi-nand spi0.1: 128 MiB, block size: 128 KiB, page size: 2048, OOB size: 128
[    0.480869] 1 fixed-partitions partitions found on MTD device spi0.1
[    0.487433] Creating 1 MTD partitions on "spi0.1":
[    0.492420] 0x000000000000-0x000008000000 : "ubi"
[    0.718349] libphy: Fixed MDIO Bus: probed
[    1.399550] libphy: ag71xx_mdio: probed
[    1.406542] switch0: Atheros AR8337 rev. 2 switch registered on mdio-bus.0
[    2.060655] ag71xx 19000000.eth: connected to PHY at mdio-bus.0:00 [uid=004dd036, driver=Atheros AR8216/AR8236/AR8316]
[    2.072340] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode: mii
[    2.080662] NET: Registered protocol family 10
[    2.089865] Segment Routing with IPv6
[    2.093747] NET: Registered protocol family 17
[    2.098401] 8021q: 802.1Q VLAN Support v1.8
[    2.108648] UBI: auto-attach mtd6
[    2.112150] ubi0: attaching mtd6
[    2.579189] random: fast init done
[    6.224198] ubi0: scanning is finished
[    6.276199] ubi0: attached mtd6 (name "ubi", size 128 MiB)
[    6.281917] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[    6.289017] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
[    6.296043] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
[    6.303240] ubi0: good PEBs: 1023, bad PEBs: 1, corrupted PEBs: 0
[    6.309537] ubi0: user volume: 2, internal volumes: 1, max. volumes count: 128
[    6.316992] ubi0: max/mean erase counter: 4/2, WL threshold: 4096, image sequence number: 1471575661
[    6.326427] ubi0: available PEBs: 0, total reserved PEBs: 1023, PEBs reserved for bad PEB handling: 19
[    6.336144] ubi0: background thread "ubi_bgt0d" started, PID 332
[    6.345569] block ubiblock0_0: created from ubi0:0(rootfs)
[    6.351295] ubiblock: device ubiblock0_0 (rootfs) set to be root filesystem
[    6.376682] VFS: Mounted root (squashfs filesystem) readonly on device 254:0.
[    6.390658] Freeing unused kernel memory: 1200K
[    6.395335] This architecture does not have kernel memory protection.
[    6.402010] Run /sbin/init as init process
[    7.288868] init: Console is alive
[    7.292715] init: - watchdog -
[    9.002588] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    9.171069] usbcore: registered new interface driver usbfs
[    9.176798] usbcore: registered new interface driver hub
[    9.182422] usbcore: registered new device driver usb
[    9.194756] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    9.208784] SCSI subsystem initialized
[    9.217336] ehci-platform: EHCI generic platform driver
[    9.223007] ehci-platform 1b000000.usb: EHCI Host Controller
[    9.228906] ehci-platform 1b000000.usb: new USB bus registered, assigned bus number 1
[    9.237116] ehci-platform 1b000000.usb: irq 13, io mem 0x1b000000
[    9.269223] ehci-platform 1b000000.usb: USB 2.0 started, EHCI 1.00
[    9.276385] hub 1-0:1.0: USB hub found
[    9.280633] hub 1-0:1.0: 1 port detected
[    9.285247] ehci-platform 1b400000.usb: EHCI Host Controller
[    9.291178] ehci-platform 1b400000.usb: new USB bus registered, assigned bus number 2
[    9.299405] ehci-platform 1b400000.usb: irq 14, io mem 0x1b400000
[    9.329227] ehci-platform 1b400000.usb: USB 2.0 started, EHCI 1.00
[    9.336381] hub 2-0:1.0: USB hub found
[    9.340677] hub 2-0:1.0: 1 port detected
[    9.348702] usbcore: registered new interface driver usb-storage
[    9.355837] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    9.365554] init: - preinit -
[   10.289298] usb 2-1: new high-speed USB device number 2 using ehci-platform
[   10.592626] hub 2-1:1.0: USB hub found
[   10.597010] hub 2-1:1.0: 4 ports detected
[   10.659459] random: procd: uninitialized urandom read (4 bytes read)
[   10.743312] random: jshn: uninitialized urandom read (4 bytes read)
[   10.799359] random: jshn: uninitialized urandom read (4 bytes read)
[   10.949278] usb 2-1.1: new high-speed USB device number 3 using ehci-platform
[   11.125120] usb-storage 2-1.1:1.0: USB Mass Storage device detected
[   11.142190] scsi host0: usb-storage 2-1.1:1.0
[   12.181609] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   12.187708] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
[   12.201584] scsi 0:0:0:0: Direct-Access     Generic  STORAGE DEVICE   0233 PQ: 0 ANSI: 0
[   12.430093] sd 0:0:0:0: [sda] 249737216 512-byte logical blocks: (128 GB/119 GiB)
[   12.438952] sd 0:0:0:0: [sda] Write Protect is off
[   12.443955] sd 0:0:0:0: [sda] Mode Sense: 0b 00 00 08
[   12.445083] sd 0:0:0:0: [sda] No Caching mode page found
[   12.450628] sd 0:0:0:0: [sda] Assuming drive cache: write through
[   12.463231]  sda: sda1
[   12.470088] sd 0:0:0:0: [sda] Attached SCSI removable disk
[   13.240524] eth0: link up (1000Mbps/Full duplex)
[   13.245381] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   13.252216] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
[   15.328518] mount_root: loading kmods from internal overlay
[   15.358141] kmodloader: loading kernel modules from //etc/modules-boot.d/*
[   15.365972] kmodloader: done loading kernel modules from //etc/modules-boot.d/*
[   16.131145] UBIFS (ubi0:1): background thread "ubifs_bgt0_1" started, PID 482
[   16.380923] UBIFS (ubi0:1): recovery needed
[   17.036733] UBIFS (ubi0:1): recovery completed
[   17.041471] UBIFS (ubi0:1): UBIFS: mounted UBI device 0, volume 1, name "rootfs_data"
[   17.049580] UBIFS (ubi0:1): LEB size: 126976 bytes (124 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
[   17.059839] UBIFS (ubi0:1): FS size: 122404864 bytes (116 MiB, 964 LEBs), journal size 6094848 bytes (5 MiB, 48 LEBs)
[   17.070804] UBIFS (ubi0:1): reserved for root: 4952683 bytes (4836 KiB)
[   17.077632] UBIFS (ubi0:1): media format: w4/r0 (latest is w5/r0), UUID E9575272-0803-41DB-A32B-E28196BC0019, small LPT model
[   17.101926] block: attempting to load /tmp/ubifs_cfg/upper/etc/config/fstab
[   17.142267] block: extroot: not configured
[   17.146639] UBIFS (ubi0:1): un-mount UBI device 0
[   17.151604] UBIFS (ubi0:1): background thread "ubifs_bgt0_1" stops
[   17.180115] UBIFS (ubi0:1): background thread "ubifs_bgt0_1" started, PID 485
[   17.643770] UBIFS (ubi0:1): UBIFS: mounted UBI device 0, volume 1, name "rootfs_data"
[   17.651909] UBIFS (ubi0:1): LEB size: 126976 bytes (124 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
[   17.662168] UBIFS (ubi0:1): FS size: 122404864 bytes (116 MiB, 964 LEBs), journal size 6094848 bytes (5 MiB, 48 LEBs)
[   17.673131] UBIFS (ubi0:1): reserved for root: 4952683 bytes (4836 KiB)
[   17.679969] UBIFS (ubi0:1): media format: w4/r0 (latest is w5/r0), UUID E9575272-0803-41DB-A32B-E28196BC0019, small LPT model
[   17.714206] mount_root: loading kmods from internal overlay
[   17.742809] kmodloader: loading kernel modules from /tmp/overlay/upper/etc/modules-boot.d/*
[   17.759965] kmodloader: done loading kernel modules from /tmp/overlay/upper/etc/modules-boot.d/*
[   18.450033] block: attempting to load /tmp/ubifs_cfg/upper/etc/config/fstab
[   18.478228] block: extroot: not configured
[   18.489524] mount_root: switching to ubifs overlay
[   18.525097] overlayfs: upper fs does not support xattr, falling back to index=off and metacopy=off.
[   18.541599] urandom-seed: Seeding with /etc/urandom.seed
[   18.648014] eth0: link down
[   18.667642] procd: - early -
[   18.671578] procd: - watchdog -
[   19.299900] procd: - watchdog -
[   19.303409] procd: - ubus -
[   19.348577] urandom_read: 5 callbacks suppressed
[   19.348585] random: ubusd: uninitialized urandom read (4 bytes read)
[   19.371836] random: ubusd: uninitialized urandom read (4 bytes read)
[   19.379673] procd: - init -
[   20.412823] kmodloader: loading kernel modules from /etc/modules.d/*
[   20.460372] Loading modules backported from Linux version v4.19.32-0-g3a2156c839c7
[   20.468189] Backport generated by backports.git v4.19.32-1-0-g1c4f7569
[   20.507301] urngd: v1.0.0 started.
[   20.523427] xt_time: kernel timezone is -0000
[   20.650068] PPP generic driver version 2.4.2
[   20.670159] NET: Registered protocol family 24
[   20.742213] ath10k 4.19 driver, optimized for CT firmware, probing pci device: 0x50.
[   20.760004] ath10k_pci 0000:00:00.0: enabling device (0000 -> 0002)
[   20.768728] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0
[   20.782986] random: crng init done
[   21.115904] firmware ath10k!fwcfg-pci-0000:00:00.0.txt: firmware_loading_store: map pages failed
[   21.262074] firmware ath10k!pre-cal-pci-0000:00:00.0.bin: firmware_loading_store: map pages failed
[   21.414008] firmware ath10k!QCA9887!hw1.0!ct-firmware-5.bin: firmware_loading_store: map pages failed
[   21.558820] firmware ath10k!QCA9887!hw1.0!ct-firmware-2.bin: firmware_loading_store: map pages failed
[   21.704063] firmware ath10k!QCA9887!hw1.0!firmware-6.bin: firmware_loading_store: map pages failed
[   21.849065] firmware ath10k!QCA9887!hw1.0!firmware-5.bin: firmware_loading_store: map pages failed
[   21.993992] firmware ath10k!QCA9887!hw1.0!firmware-4.bin: firmware_loading_store: map pages failed
[   22.139235] firmware ath10k!QCA9887!hw1.0!firmware-3.bin: firmware_loading_store: map pages failed
[   22.152573] ath10k_pci 0000:00:00.0: qca9887 hw1.0 target 0x4100016d chip_id 0x004000ff sub 0000:0000
[   22.162131] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
[   22.174666] ath10k_pci 0000:00:00.0: firmware ver 10.1-ct-87-__fW-022-b7d05fdf api 2 features wmi-10.x,has-wmi-mgmt-tx,mfp,txstatus-noack,wmi-10.x-CT,ratemask-CT,txrate-CT,get-temp-CT,tx-rc-CT,cust-stats-CT,retry-gt2-CT,txrate2-CT,beacon-cb-CT,wmi-block-ack-CT crc32 1a63a0ad
[   22.355568] firmware ath10k!QCA9887!hw1.0!board-2.bin: firmware_loading_store: map pages failed
[   22.365056] ath10k_pci 0000:00:00.0: board_file api 1 bmi_id N/A crc32 546cca0d
[   23.326836] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
[   23.341471] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
[   23.347899] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
[   23.356198] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 25208 iram: 12132'
[   23.400819] ath10k_pci 0000:00:00.0: htt-ver 2.1 wmi-op 2 htt-op 2 cal file max-sta 128 raw 0 hwcrypto 1
[   23.413858] ath10k_pci 0000:00:00.0: NOTE:  Firmware DBGLOG output disabled in debug_mask: 0x10000000
[   23.552780] ath: EEPROM regdomain: 0x0
[   23.552788] ath: EEPROM indicates default country code should be used
[   23.552790] ath: doing EEPROM country->regdmn map search
[   23.552803] ath: country maps to regdmn code: 0x3a
[   23.552807] ath: Country alpha2 being used: US
[   23.552810] ath: Regpair used: 0x3a
[   23.637981] ath: EEPROM regdomain: 0x0
[   23.637988] ath: EEPROM indicates default country code should be used
[   23.637991] ath: doing EEPROM country->regdmn map search
[   23.638004] ath: country maps to regdmn code: 0x3a
[   23.638009] ath: Country alpha2 being used: US
[   23.638012] ath: Regpair used: 0x3a
[   23.650022] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
[   23.651656] ieee80211 phy1: Atheros AR9561 Rev:0 mem=0xb8100000, irq=2
[   23.689163] kmodloader: done loading kernel modules from /etc/modules.d/*
[   34.043488] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   34.082724] br-lan: port 1(eth0.1) entered blocking state
[   34.088306] br-lan: port 1(eth0.1) entered disabled state
[   34.094224] device eth0.1 entered promiscuous mode
[   34.099214] device eth0 entered promiscuous mode
[   34.169418] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   34.228902] IPv6: ADDRCONF(NETDEV_UP): eth0.2: link is not ready
[   35.082585] eth0: link up (1000Mbps/Full duplex)
[   35.087443] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   35.142041] br-lan: port 1(eth0.1) entered blocking state
[   35.147630] br-lan: port 1(eth0.1) entered forwarding state
[   35.153698] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.2: link becomes ready
[   35.359270] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   38.292495] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
[   38.329573] br-lan: port 2(wlan1) entered blocking state
[   38.335068] br-lan: port 2(wlan1) entered disabled state
[   38.340908] device wlan1 entered promiscuous mode
[   40.182754] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
[   40.197425] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
[   40.203703] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
[   40.212494] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 25208 iram: 12132'
[   40.258320] ath10k_pci 0000:00:00.0: pdev param 0 not supported by firmware
[   40.278805] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   40.298494] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[   40.305318] br-lan: port 2(wlan1) entered blocking state
[   40.310852] br-lan: port 2(wlan1) entered forwarding state
[   40.332347] br-lan: port 3(wlan0) entered blocking state
[   40.337898] br-lan: port 3(wlan0) entered disabled state
[   40.343742] device wlan0 entered promiscuous mode
[   41.281431] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   41.288319] br-lan: port 3(wlan0) entered blocking state
[   41.293871] br-lan: port 3(wlan0) entered forwarding state

Any idea where I should start looking? What is the best way to troubleshoot.

OK, reading through your config here, it looks like this is being run as an AP, without routing to the WAN interface at all, yes?

The link is up for eth0 at 13 seconds after kernel start. The rest of the boot sequence around the wireless bring-up and adding to the bridge doesn't look strange at all.

I long lost track of the number of times I've flashed and rebooted an AR750S, and can't recall it not immediately responding over SSH.

If I were seeing a similar problem, I'd start watching the ARP table (ip neigh) on the router, as well as on 192.168.2.4. watch is available on most Linux platforms to make this kind of repetitive thing easier. procps-ng-watch for OpenWrt.

Edit: On the router, a script to periodically append the ARP table dump to a file probably makes more sense, since you don't have network connectivity. Poke me if you want an example.

I did download a different firmware version 10.2.4-1.0-00045 from https://github.com/kvalo/ath10k-firmware/tree/master/QCA9887/hw1.0/10.2.4-1.0

and it boots up very fast and works fine for me.

How did you replace the firmware on your router? I thought it comes with firmware-2.bin while it is firmware-5.bin on Github.

I placed the file into this folder lib/firmware/ath10k/QCA9887/hw1.0 and renamed it firmware-5.bin

1 Like

for @jeff do you not have any issues with the firmware? can you try out the firmware i referred to in this post and maybe this is a better solution. Could there be a hardware revision on my router as i just bought it a couple of weeks ago?

I have no unexpected issues with the firmware. The -CT drivers and firmware have been reliable for me. It is known that they don't support 802.11s mesh on the older chips, so devices like the Archer C7v2 and this need the non-CT firmware and drivers if you want to run 802.11s.

I'm still very, very puzzled as to why changing firmware changed anything with your networking problems. Your dmesg output shows that you should have had connectivity on br-lan within 45 seconds of kernel start.

I did have br-lan after 45 seconds , but only for 3 pings

The wan lights came for a short time and than the power light went off.

All I changed was the firmware. Is there a config file for the firmware that might have issues?

Now everything works fine no issues I rebooted several times.

I would check logread to see what is going on. That should not be happening. Without seeing the logs, it's nearly impossible to know if you've "fixed" the problem, or somehow are able to "ignore" it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.