Network Shares "unpopulated" or Share folder not mounting

The help I need is knowing the correct keywords to look for. I've tried: nas "unpopulated" and several variants, such as: spelling nas in full. I've tried "share" and "no files found", too. The suggestions to the right of this posting, are significantly not collateral with my difficulties. I cannot "Mount" the "Share" folder.

I've followed or tried to follow:


As this is a Linux box, doing CTRL-L brings up a login window for the network, but no user/password combo works. On the Windows side, the network opens but says "unpopulated".

I am trying to make the NAS drive readable. I don't care if it's writable (for now).

Lastly, the external device (hdd) is formatted: vfat.

I don't think /home exists by default and you need to actually use the mountpoint of your external drive. Check System/mountpoints and add your drive than use this mount via Network Shares/Path

Sorry. I didn't update the screenshot before the post to this forum. It reads:


Thats the device not the mountpoint of the filesystem?
It should look like this?

You might also want to manually (ssh) create the /mnt/??? dir and give it full access via chmod 0777 /mnt/???, otherwise the mountpoint will be lost on reboot.

Please forgive my inability to understand you.

root@OpenWrt:/mnt# ls
sda   sda1

so, I don't want to overwrite /sda or sda1, as they exitst in /mnt.

You can use the generated mount points under /mnt i think they come from the system/mountpoints/automount option at startup.

So just change /dev/sda1 to /mnt/sda in your samba/network shares path field. Not sure whats inside the /mnt/sda1, but you can try both and see which one contains your actual partition/files.

So far I have tried:


I see
but neither Anonymous nor Registered User are able to mount the folder named: Share (which I take to be the device given a network name)

remove the "allowed users" root and tick "Allow guests"