Network goes haywire when dumb AP is added

I have a TRENDnet TEW-714TRU single-Ethernet + 802.11N travel router I'm trying to add to an existing network. I've tried configuring it as a dumb AP, meaning that the wireless and Ethernet interfaces are bridged together and dnsmasq and odhcpd are stopped and disabled. The main internet-facing router on my network is a Buffalo WZR-HP-G300NH also running LEDE.

The travel router's network config looks like the following. I removed anything to do with WAN, because it has only one Ethernet port.

cat /etc/config/network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd05:3734:4036::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1 eth0'
        option proto 'static'
        option ipaddr '192.168.1.10'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'

config device 'lan_dev'
        option name 'eth0.1 eth0'
        option macaddr '00:14:d1:dd:ee:ff'

config switch
        option name 'rt305x'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'rt305x'
        option vlan '1'
        option ports '0 6'

The problem I'm seeing is that, when I connect the travel router to the LAN, everything works fine for a few seconds, but then eventually all traffic even between hosts on my LAN stops. As soon as I disconnect the travel router from the LAN, the network goes back to normal.

On the Buffalo router, when the travel router is on the LAN, I see many messages like this:

[2065205.279781] br-lan: received packet on eth0.1 with own address as source address
[2065206.277421] br-lan: received packet on eth0.1 with own address as source address

Are these messages referring to IP addresses or to MAC addresses?

The travel router's br-lan IP is statically assigned to 192.168.1.10. The Buffalo router's br-lan IP address is 192.168.1.1. When I run arp on the Buffalo router, I don't see anything obvious, like duplicate MAC addresses.

Would could be going on? Any pointers on what I can do to investigate further?

Could it be that a host that was connected to a different AP on the network, then connected to the travel router's AP, confuses the switches on the network, leading to a switching loop or something?

Thanks!

Hi Gigabit,

  1. I would first get my hands on a third router and switch out the Buffalo to see if that made a difference. If I did not have one handy then i would go to step 2 and come back to this if that does not help.

  2. apparently sometimes this issue can appear when nvram is not completely overwritten. When OpenWrt images are flashed to some routers sometimes it does not complete properly the first time or if a step is missed. It might be easier to re-flash, following directions carefully, and see if this helps.

  3. I would then get wireshark involved to see WTH is happening. I use wireshark as follows for LEDE and OpenWrt:

  • on my linux machine i open a CLI
  • at the command prompt I type: nc -l 9999 | wireshark -k -S -i -
  • on my linux machine I open another CLI
  • SSH to my LEDE router
  • on the LEDE router I enter: tcpdump -n -i 'interface' -s 65535 -w - not port 9999 | nc 192.168.55.9 9999

If you are not familiar with any of these tools let me know and I can point you in the right direction.

And before you start hunkering down and getting all CSI keep in mind sometimes this same message you are getting can happen to some routers when there is damage to the board etc..

So.. This is my first attempt at helping someone.. I hope it does.

Sean.

Why are you bridging eth0 and eth0.1 together?

1 Like

I totally missed that so being as I have the same thing set up here ( I think. correct me if I am wrong), but with different hardware, I tried it on mine.

I have:

a Tp-Link as the internet facing router.
a D-Link DIR-835 as a dumb AP with everything getting DHCP via the Tp-Link.

I have several devices connecting to the dumb AP.
I added eth0 to eth0.1 and rebooted to be sure the settings took
No Wild behavior.. just a few extra packets that I could see and definitely not the messages gigabit is seeing.

Bad practice but I think it just slows down the network. Because eth0 is tagged and eth0.1 is not...
Dont they more or less ignore each other?

@smjohnston, it turns out I have a second Buffalo router like the first one, flashed with LEDE already. I can set it up on an isolated LAN together with the travel router and see if I can reproduce the issue. I'd rather figure out what is going on without taking down the household's whole network.

@eduperez, good question. I started with the distribution network config file and removed the wan-related entries, so the eth0 and eth0.1 entries remained. The wireless interface is added to the bridge interface in /etc/config/wireless. Are you thinking that this is the reason for the trouble all over the network, or just pointing out that it doesn't look right?

By the way, as a clarification, the error messages about a packet received on eth0.1 with its own address as a source address are reported on the Buffalo router at 192.168.1.1, not the travel router. The messages start flooding when the travel router is added to the LAN and stop when its removed.

Besides the TEW-714TRU that is giving me trouble, I already have two other LEDE routers on the same LAN acting as access points. They are a Western Digital MyNet N750 and a DIR-860L. Together with the internet-facing Buffalo router, they're fine. The trouble only starts when the TEW-714TRU is added to the LAN.

@gigabit314,

I believe eduperez asked why eth0 and eth0.1 are bridged because eth0 is treated as a VLAN trunk by LEDE.
All the packets traveling on this trunk are tagged with the VLAN they belong to. It makes no sense to bridge them together and probably has security and performance implications.

near the bottom of the following page you can find a pictorial representation of what is going on:

https://wiki.openwrt.org/toh/linksys/wrt160nl

I looked up your TEW-714TRU.

I would love to see the default settings for this little single port device you have :slight_smile:

I think having eth0 bridged to eth0.1 was the problem. On the travel router, I removed everything from /etc/network/config having to do with eth0.1 and disabled VLAN. It is working OK now as a dumb AP.

My theory (please correct me if this is implausible) is that having the two bridged together caused broadcast packets arriving on, say, eth0 to be sent back out on eth0.1, which is back onto the same network. Eventually, this broadcast loop flooded the network.

@smjohnston, I looked in /rom for the default /etc/config/network, but it's not in there. I suppose it is generated on first boot or something like that, so my edits have replaced the default file. If there's a way to recover it without losing my current config, I'm happy to get it for you.

Most drivers (except very old broadcom b24) don't handle wireless lan bridging with wan/lan (switch). Doing so is called wireless bridge which needs special packages and configuration to work.

See here:
https://wiki.openwrt.org/doc/howto/clientmode

@Gigabit,
No worries. You should thank eduperez for catching that. I have been trying to get my system to do the same thing yours was but can't. For some reason it doesn't care when I bridge eth0 with eth0.x

@kyav1929 the link you provided deals with connecting 2 wired networks over a wireless link. different thing.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.